does not recognize upper case extension as image (.JPG)

Bug #49033 reported by Tim McIntyre on 2006-06-08
8
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Wishlist
thunderbird (Ubuntu)
Low
Mozilla Bugs

Bug Description

Binary package hint: mozilla-thunderbird

since my camera (popular olympus model) stores the image names in all upper case letters i believe thunderbird should handle all case extensions

Tim

what's the status of this?

I'm going to confirm this as an enhancement request. It seems reasonable enough.

Tim McIntyre (salfordfred) wrote :

Binary package hint: mozilla-thunderbird

since my camera (popular olympus model) stores the image names in all upper case letters i believe thunderbird should handle all case extensions

Tim

Tim McIntyre (salfordfred) wrote :

oops:
steps to reproduce.

compose a new email.. (will need to give a recipient)
insert > image > choose file

browse to location with image file without lowercase extension

Tim

Yves Junqueira (yves.junqueira) wrote :

I can always reproduce that with the latest mozilla-thunderbird from edgy, 1.5.0.5-0ubuntu1

I confirm this bug.
I looks like the "Image Files" filter in the file dialog only filters out image files with lower case extensions.
As a workaround the "All files" filter has to be selected.

Changed in mozilla-thunderbird:
status: Unconfirmed → Confirmed

I have forwarded this bug upstream as https://bugzilla.mozilla.org/show_bug.cgi?id=346971.

Changed in thunderbird:
status: Unknown → Unconfirmed
Changed in mozilla-thunderbird:
importance: Undecided → Low

Assigned to Mozilla Team

Changed in mozilla-thunderbird:
assignee: nobody → mozilla-bugs
Changed in thunderbird:
status: New → Invalid
Changed in thunderbird:
status: Invalid → Confirmed
Jesper Larsen (knorr) wrote :

This bug is still present in 2.0.0.16 and 3.0a2.

*** Bug 346971 has been marked as a duplicate of this bug. ***

*** Bug 466365 has been marked as a duplicate of this bug. ***

*** Bug 379282 has been marked as a duplicate of this bug. ***

What with all the dupes being on Linux, and even the XUL filepicker on Linux working fine, this would seem to be a Widget: GTK bug.

Created attachment 349674
Patch

For some reason I'm getting the feeling that this approach is a little dangerous, but so far it works. GTK takes a shell blob for its pattern matching which is like regular expressions ultra lite. It seems to me from documentation /*/i wouldn't work.

Looks OK, but g_strstrip needs its result to be freed, so this is actually leaking (and always was).

+MakeCaseInsensitiveShellGlob(const char* existingString) {

aExistingString

You should also add a comment that aExistingString is a UTF8 string, but that this function is OK because g_ascii_isalpha will return false for any non-ASCII character in the string so all non-ASCII characters are just passed through.

Created attachment 349677
Patch 2

g_strstrip is a macro which doesn't need freeing (as I've explained IRL). Added the comment.

(In reply to comment #9)
> +MakeCaseInsensitiveShellGlob(const char* existingString) {
>
> aExistingString

You didn't address this comment.

Please mention in your comment that aExistingString is UTF8.

Created attachment 349684
Patch 3

Whoops, sorry, I missed that comment.

Comment on attachment 349684
Patch 3

Since this old bug has a fairly trivial fix (ignore my first comment, I now know what shell globs are/aren't capable of) it would be nice to get this out for 1.9.1.

Changed in thunderbird:
status: Confirmed → Invalid

Comment on attachment 349684
Patch 3

a191=beltzner - should we add a test for this new test?

I don't think you can, really. This bug is all about a modal dialog for an external toolkit. The best you can get is a Litmus test, I suppose.

Created attachment 350406
Patch with commit message

For checkin

*** Bug 473832 has been marked as a duplicate of this bug. ***

Jesper Larsen (knorr) on 2009-01-17
Changed in thunderbird:
status: Invalid → Unknown
Changed in thunderbird:
status: Unknown → Fix Released
Micah Gersten (micahg) on 2009-12-10
Changed in thunderbird:
milestone: none → 3.0
Micah Gersten (micahg) wrote :

Marking Triaged pending release of Thunderbird 3 in Lucid.

Changed in thunderbird (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.