Ubuntu

Bad translation in the tooltip box of mozilla thunderbird icon

Reported by Removed by request on 2006-05-30
14
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Low
Alexander Sack

Bug Description

Binary package hint: mozilla-thunderbird

I'm an Ubuntu French user and translator (Dapper 6.06 up to date) and I've found a bad translation.
We don't translate any mozilla package, I've asked the french mozilla team about that but nobody can solve my problem (they don't find the string) :
When you stay with your cursor on the mozilla thunderbird icon, this string is displayed in a tooltip box (in french) :
"Thunderbird Mail
Lire et écrire votre mél "

In fact "mél" doesn't exist in french but "mél." exist and musn't be used as a noun.
So the correct translation should be :
"Thunderbird Mail
Lire et écrire vos courriels" (plural form is better in french)

I've found the bad string in /usr/share/applications/thunderbird.desktop but I don't know how to correct this.

The debian maintainer can't help me but is interested by the patch.

KarlGoetz (kgoetz) wrote :

(from top of the bug report) Binary package hint: mozilla-thunderbird

to change the string add the 'deb-src' line to your sources list for main, and run 'apt-get update' and ' apt-get source mozilla-thunderbird' (i'm not sure how to do this in a GUI).
The source is about 35mb.
you can then change the string in the package.
( in mozilla-thunderbird.desktop)
That said, i'm supprised it cant be done through rosetta.

Thanks but how can I do it so that everybody will take advantage of my change ?

Benoît Turpin wrote:
> Thanks but how can I do it so that everybody will take advantage of my
> change ?
>
i dont know the Proper Tools to use, but perhaps attaching your modified
file to the bug report and making the report 'with patch' status. then
you can ask a developer to make the correct changes.
Check the packages changelog for the best person to email about it :)
they should be the top email address.
kk

KarlGoetz (kgoetz) wrote :

hi Benoît, have you had any progress on this bug?

Changed in mozilla-thunderbird:
status: Unconfirmed → Needs Info

Hi, I'm sorry but I have no longer time to spend on bugs.
Moreover, my Ubuntu is now in English.

PS : I had contacted the maintener but it was useless. I had contacted the mozilla french team, same result, don't know what to do.

KarlGoetz (kgoetz) wrote :

Any action on this bug from the [ubuntu, debian] mozilla crew?

Looks like there's something wrong here... Let's solve this silly and unsmart bug. The .desktop file is not part of a language pack, it's shared by all languages, in the package 'mozilla-thunderbird'.

I made a new .desktop file, adding "Lire et écrire des courriels" as Comment, to fit with Evolution's Comment; and a translated name, because there wasn't any: "Messagerie Thunderbird". Attaching the diff. Hope someone can apply it, there's even no need to build from source to fix it!

Changed in mozilla-thunderbird:
status: Needs Info → Confirmed

Assigned to Mozilla Team

Changed in mozilla-thunderbird:
assignee: nobody → mozilla-bugs

Alexander Sack: I've subscribed you because I saw you're the current maintainer of mozilla-thunderbird package, and that simply applying this patch to the .desktop file would solve this bug. This should take you one minute, no need to build sources, and we can wait for a new package version to be released for getting the patch in the distro. The patch could also be applied to new thunderbird package in gutsy to avoid making the same error. Sorry for the inconvenience and thank you for your work.

Alexander Sack (asac) wrote :

why have people always be so firm about their language :) ... anyway, thanks for bringing to my attention. Will be fixed.

Changed in thunderbird:
assignee: mozilla-bugs → asac
status: Confirmed → In Progress
importance: Medium → Low
Alexander Sack (asac) wrote :

well ... should be fixed in gutsy already. At least thats what I see when I look at in-source .desktop file.

Thanks for your contribution,

 - Alexander

Changed in thunderbird:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers