build dependency on GCC-4.3 [armel]

Bug #401165 reported by Matthias Klose on 2009-07-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
lightning-sunbird (Ubuntu)
Undecided
John Vivirito
Karmic
Undecided
John Vivirito
thunderbird (Ubuntu)
High
Alexander Sack
Karmic
High
Alexander Sack

Bug Description

Binary package hint: thunderbird

Please build using thunderbird with the default GCC on armel; afaik there's no bug report open for this, neither for thunderbird nor for GCC.

Required to demote GCC-4.3 for karmic.

Matthias Klose (doko) on 2009-07-18
Changed in thunderbird (Ubuntu Karmic):
importance: Undecided → High
milestone: none → karmic-alpha-5
status: New → Confirmed
Changed in thunderbird (Ubuntu Karmic):
assignee: nobody → John Vivirito (gnomefreak)
assignee: John Vivirito (gnomefreak) → nobody
Changed in lightning-sunbird (Ubuntu Karmic):
assignee: nobody → John Vivirito (gnomefreak)
status: New → Invalid
John Vivirito (gnomefreak) wrote :

Sorry seems i read it wrong you want to go from 4.3 to 4.2 and i upgraded it to 4.3

Matthias Klose (doko) wrote :

No, it should be built with an unversioned GCC, or with 4.4 for karmic. I didn't look at lightning-tb

On 07/19/2009 03:18 PM, Matthias Klose wrote:
> No, it should be built with an unversioned GCC, or with 4.4 for karmic.
> I didn't look at lightning-tb
>
ok I will open lightning task back up and build with 4.4.
Thanks

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Changed in lightning-sunbird (Ubuntu Karmic):
status: Invalid → Triaged
John Vivirito (gnomefreak) wrote :

OK done and pushed to branch:
https://code.launchpad.net/~gnomefreak/sunbird/ubuntu-0.x.9.10

Branch should be populated shortly.

John Vivirito (gnomefreak) wrote :

ok working on this, should be done in a bit.

Changed in thunderbird (Ubuntu Karmic):
assignee: nobody → John Vivirito (gnomefreak)
John Vivirito (gnomefreak) wrote :

ok neither are fixed i will fix it and should both be done tomorrow im running out of energy today

John Vivirito (gnomefreak) wrote :

ok both are done, now using default GCC GCC++ i have asked for a merge into branch Alex uses for tbird and will ping him about sunbird for review

Changed in thunderbird (Ubuntu Karmic):
status: Confirmed → In Progress
Changed in lightning-sunbird (Ubuntu Karmic):
status: Triaged → In Progress
Alexander Sack (asac) wrote :

Michael can you please file a bug against gcc for the thunderbird build failures with 4.4? I am not sure we want to back this out before thats fixed.

Alexander Sack (asac) wrote :

taking over as this needs some armel fixes first.

Changed in lightning-sunbird (Ubuntu Karmic):
assignee: John Vivirito (gnomefreak) → Alexander Sack (asac)
Changed in thunderbird (Ubuntu Karmic):
assignee: John Vivirito (gnomefreak) → Alexander Sack (asac)
Alexander Sack (asac) wrote :

actually i wanted to take the thunderbird part.; moving back lightning to gnomefreak.

Changed in lightning-sunbird (Ubuntu Karmic):
assignee: Alexander Sack (asac) → John Vivirito (gnomefreak)
John Vivirito (gnomefreak) wrote :

Lightning now has all Arm fixes that we have in tbird. I dont have an ARM box to test with and PPA doesnt build ARM yet.
If someone wants to test please feel free to grab my branch:
https://code.launchpad.net/~gnomefreak/sunbird/ubuntu-0.x.9.10
and test but if thunderbird2 builds lightning should build.

John Vivirito (gnomefreak) wrote :

On 07/24/2009 08:58 AM, John Vivirito wrote:
> Lightning now has all Arm fixes that we have in tbird. I dont have an ARM box to test with and PPA doesnt build ARM yet.
> If someone wants to test please feel free to grab my branch:
> https://code.launchpad.net/~gnomefreak/sunbird/ubuntu-0.x.9.10
> and test but if thunderbird2 builds lightning should build.
>
Alexander let me know what other ARM fixes that I should add to
Lightning when you get done with Tbird.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

"How can i get lost, if i have no where to go"
    -- Metallica from Unforgiven III

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 2.0.0.22+build1+nobinonly-0ubuntu3

---------------
thunderbird (2.0.0.22+build1+nobinonly-0ubuntu3) karmic; urgency=low

  * drop gcc-4.3 armel dependency in karmic (LP: #401165)
    - update debian/control
    - update debian/rules

 -- Alexander Sack <email address hidden> Tue, 04 Aug 2009 16:41:14 +0200

Changed in thunderbird (Ubuntu Karmic):
status: In Progress → Fix Released
John Vivirito (gnomefreak) wrote :

Ok this is fixed in lightning-sunbird in branch will ask Alexander to sponsor soon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-sunbird - 0.9+nobinonly-0ubuntu3

---------------
lightning-sunbird (0.9+nobinonly-0ubuntu3) karmic; urgency=low

  [ John Vivirito ]
  * Fixes (LP: #178785)
    - debian/rules: Added build option --enable-official-branding to build with official branding
    - debian/patches: Removed deb299697-lp42559-use-FC_ANY_METRICS.patch to fix build errors
    - debian/patches: Updated series
  * Fixes (LP: #399400)
    - debian/rules: Removed the convert icon section
    - debian/sunbird.links: Adjusted link to use the 128 icon
  * Fixes (LP: #401165)
    - debian/control: Removed GCC and GCC++ from build-deps
    - debian/rules: Commented out GCC and GCC++ lines to build using default
    - debian/patches: Added ftbfs_gcc44_elif.patch to fix FTBFS
    - debian/patches/series: Updated
  * Fixes (LP: #385325) crash in JS due to usage of wrong floating point number$
    - debian/patches: Added bz322806_arm-vfp-2538:3f78d5e894bc
    - debian/patches/series: Updated
  * Fixes (LP: #378754)
    - debian/control: Fixed typo in calendar-google-provider description.
  * Fixes (LP: #358084): add arm(el) xpcom patches from thunderbird package
    - add debian/patches/18_arm_xpcom_unused_attribute.dpatch
    - add debian/patches/38_arm_xpcom_optim.dpatch
    - add debian/patches/bz339782_cvs_xptcinvoke_arm_backport_1.13.patch
    - update debian/patches/series
  * debian/patches:
    - Add debian/patches/412610_attachment_309958.patch: to prevent crash on MAX_PATH
    - update debian/patches/series

 -- John Vivirito <email address hidden> Fri, 21 Aug 2009 10:57:02 -0400

Changed in lightning-sunbird (Ubuntu Karmic):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers