Strip CUPS/ from the front of displayed printer names

Bug #40074 reported by Pascal De Vuyst on 2006-04-18
20
Affects Status Importance Assigned to Milestone
firefox (Baltix)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Low
Unassigned
thunderbird (Ubuntu)
Low
Mozilla Bugs

Bug Description

In the File -> Print dialog "CUPS/" should be stripped from the front of displayed printer names, since all printing in Ubuntu is done via CUPS. This is already done for Firefox, for consistency reasons this should also be done for Thunderbird.

netgrabber (johannes8) wrote :

I agree we should keep things consistent

netgrabber (johannes8) on 2006-05-20
Changed in mozilla-thunderbird:
status: Unconfirmed → Confirmed

Assigned to Mozilla Team

Changed in mozilla-thunderbird:
assignee: nobody → mozilla-bugs
Alexander Sack (asac) wrote :

Is this still an issue for you?

In Feisty both Firefox and Thunderbird print dialogs seem to have the "CUPS/" prefix again. So the behaviour is consistent again.
I'm closing the bug.

Changed in thunderbird:
status: Confirmed → Fix Released
Changed in firefox:
status: Unconfirmed → Rejected
status: Unconfirmed → Fix Released
Changed in thunderbird:
status: Fix Released → Rejected
Jonathan Ernst (jonathan.ernst) wrote :

CUPS/ is not stripped in Firefox print dialog, this is a problem because one cannot read the printer's name without resizing the dialog.

Furthermore the dialog size is not saved (see #173667)

Changed in firefox:
status: Fix Released → Confirmed
Jonathan Ernst (jonathan.ernst) wrote :
Alexander Sack (asac) wrote :

fixed in firefox-3.0 - we use native print dialog now.

Changed in firefox-3.0:
importance: Undecided → Low
status: New → Fix Released
Alexander Sack (asac) wrote :

firefox 2 wont see a fix.

Changed in firefox:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments