Still unable to connect to 1 particular POP server

Bug #367341 reported by Prof.Arronax on 2009-04-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: thunderbird

For years I have been reporting this same bug and I see, with this fresh install of Thunderbird on my Ubuntu machine, that it is STILL NOT CORRECTED. Regrettably I don't have the prior thread for this complaint so I'll have to start "fresh".

I have 5 e-mail accounts that are POP accessible. 1 at yahoo, 1 at sstar.com, 1 at comcast.net and 2 at sursum-corda.com.
Those on the sursum-corda.com server (which I operate) are inaccesible via Thunderbird. Any attempt to connect and Thunderbird sends "CAPA" and posts this pop-up message: "Sending of username did not succeed. Mail server 10.0.0.3 responded: CAPA". Precisely what it has always done.

Here is the log snippet from the POP server:
===========cut============
* 08:17:07 (9) Incoming connection from 10.0.0.20 on 04/26/09.
] 08:17:07 (9) +OK Internet Rex POP3 server ready <3250.1240755427@mailserv>
= 08:17:07 (9) AUTH <<<<<<<< "=" is an incoming command from the client
] 08:17:07 (9) -ERR Unrecognised command. <<<<<<<< "]" is a reply from the server to the client
= 08:17:07 (9) CAPA
] 08:17:07 (9) CAPA
= 08:17:16 (9) USER marc
] 08:17:16 (9) +OK Need password.
! 08:18:17 (9) Connection closed: timeout receiving command. <<<<<<60 seconds of waiting for Thunderbird
===========cut============

At one time, one of the coders of Thunderbird said that he thought he had removed or altered the log-in algorithms
to correct for this anomaly; but apparently he had not, and the problem continues to this date. Note that I am able to access that pop account from ANY other e-mail client, including: The Bat!, Outlook Express, Outlook, mail2web.com, PMMail/2, PMMail Pro, etc.

It should be noted that SENDING mail from Thunderbird via the SMTP server at sursum-corda.com IS successful:
===========cut=============
* 08:33:14 (9) Inbound connection from 10.0.0.20 at 04/26/09.
] 08:33:15 (9) 220 sursum-corda.com Internet Rex ESMTP daemon at your service.
# 08:33:16 (9) EHLO [10.0.0.20] LOG KEYS: "*" = information
] 08:33:16 (9) 250- sursum-corda.com Hello [10.0.0.20] "]" = outbound reply
] 08:33:16 (9) 250-8BITMIME "#"=inbound command
] 08:33:16 (9) 250-SIZE
] 08:33:16 (9) 250-AUTH CRAM-MD5 LOGIN
] 08:33:16 (9) 250 HELP
# 08:33:25 (9) AUTH CRAM-MD5
 # (line suppressed)
] 08:33:25 (9) 334 =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
] 08:33:25 (9) 235 Authentication accepted.
===========cut=============

Can someone please take up this coding issue and get it finally corrected?

ProblemType: Bug
Architecture: i386
Dependencies:

DistroRelease: Ubuntu 8.10
NonfreeKernelModules: nvidia
Package: mozilla-thunderbird None [modified: /var/lib/dpkg/info/mozilla-thunderbird.list]
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunderbird
Uname: Linux 2.6.27-14-generic i686

Prof.Arronax (marclewis303) wrote :

Update: After more experimenting I was able to do a POP connection by enabling the "Use secure authentication" tick box in the server settings. Odd. None of the other servers require this, nor do any of the other clients I mentioned in my first posting. IOW, Thunderbird is the only client that requires the "secure authentication" to talk successfully to the Internet Rex POP server.

Not sure if any other action need be taken at this point in as much as very few of these POP servers are utilised. Nonetheless some coder may want to have a look at the original stated problem.

Prof.Arronax (marclewis303) wrote :

FURTHER UPDATE: Apparently my conclusion that using secure authentication solved the problem was a bit premature. It was able to negotiate successfully only ONCE. All other attempts fail
_at the client end_. The log-in to the server is actually successful, but Thunderbird is so confused
about what commands to send that it thinks it is NOT logged in or authenticated. Here is another log snippet that also contains a successful connection from another machine (running The Bat! under Windows XP):
 ===========cut==========
* 10:16:30 (5) Incoming connection from winxp-c.bbsgroup (10.0.0.7) on 04/26/09.

] 10:16:30 (5) +OK Internet Rex POP3 server ready <9.1240762590@mailserv>

= 10:16:30 (5) USER marc

] 10:16:30 (5) +OK Need password.

= 10:16:30 (5) PASS xxxxxxxxx

> 10:16:30 (5) User marc logged in.

] 10:16:30 (5) +OK Mailbox locked and loaded.

= 10:16:30 (5) STAT

] 10:16:30 (5) +OK 18 1621171

= 10:16:31 (5) LIST

] 10:16:31 (5) .

= 10:16:31 (5) UIDL

] 10:16:31 (5) .

= 10:16:31 (5) QUIT

] 10:16:31 (5) +OK Internet Rex POP3 server mailserv signing off.

- - (Start of Thunderbird's transaction attempt)
* 10:18:17 (5) Incoming connection from 10.0.0.20 on 04/26/09.

] 10:18:17 (5) +OK Internet Rex POP3 server ready <10.1240762697@mailserv>

= 10:18:17 (5) AUTH

] 10:18:17 (5) -ERR Unrecognised command.

= 10:18:18 (5) CAPA

] 10:18:18 (5) CAPA

= 10:18:25 (5) APOP marc (data suppressed)
> 10:18:25 (5) User marc logged in.

] 10:18:25 (5) +OK Mailbox locked and loaded.

= 10:18:38 (5) CAPA

= 10:18:38 (5) APOP marc (data suppressed)
] 10:18:38 (5) -ERR Command invalid in transaction state.

= 10:18:43 (5) CAPA

= 10:18:44 (5) APOP marc (data suppressed)
] 10:18:44 (5) -ERR Command invalid in transaction state.

= 10:18:54 (5) CAPA

= 10:18:54 (5) APOP marc (data suppressed)
] 10:18:54 (5) -ERR Command invalid in transaction state.

= 10:19:00 (5) CAPA

= 10:19:00 (5) APOP marc (data suppressed)
] 10:19:00 (5) -ERR Command invalid in transaction state.

= 10:19:04 (5) CAPA

= 10:19:04 (5) APOP marc (data suppressed)
] 10:19:04 (5) -ERR Command invalid in transaction state.

! 10:19:06 (5) Connection closed: remote dropped the connection.

 ===========cut==========

Obviously the "-ERR Command invalid in transaction state." means that the APOP login attempt
is superfluous and misplaced; the user is already logged into the server. Again, Thunderbird has this "CAPA" tic - perhaps it has a touch of Tourette syndrome? <grin> But really, this sort of coding error does need to be addressed. In the mean-time I'll have to stick to utilising the Windows machine for dependable e-mail communications.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Stephen Butler (kg7je) wrote :

This happened to me after installing the most recent fixes for bug 1169984. It did work in 13.04 prior to that update.

Stephen Butler (kg7je) wrote :

PS. Comcast is my only mail box access by Thunderbird.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers