mozilla-thunderbird keeps asking a password when working off-line

Bug #280987 reported by andbelo on 2008-10-09
4
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Invalid
Low
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: mozilla-thunderbird

1) Ubuntu 8.04.1

2) Thunderbird 2.0.0.17

3) When "Work Offline" is selected in Thunderbird it asks the password to download messages depending on the settings. After that it should not ask the password again until working offline is deselected.

4) It keeps asking for the password when it is time to check for new messages.

My settings: using a master password to encrypt stored passwords

This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox: http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey: http://www.mozilla.org/projects/seamonkey/

Getting this on Windows XP, TB 1.5.0.5

TB prompts for password after first interval of time you set for it to check for new messages on server. In other words, TB starts its sequence of actions to check the server for new mail even when you selected work offline.

Same problem here TB 1.5.0.8

Even if I choose to work offline, after the time defined in the server; I get prompted for Master Password.

The fact is that even if I enter the password, TB won't download any messages.

If I don't enter, whenever a connection is time queued, the password is requested.
I don't think this should happen. If offline no connections should be "attempted".

Forgot to mention that this was in the Linux version

And is still present in TB 1.5.0.9 (linux)

confirming based on multiple reports.

This is still present in Thunderbird 2.0

In detail:

When starting Thunderbird offline the Master password is requested after some time. The time it takes to see the request is determined bu the "Check new messages every X minutes" option in the account section.

What seems to happen is that even when offline, the process for connecting to server is still triggered and the Master password request pops-up. This can be very annoying if the user has several accounts, since the password is requested every time the timing cycle goes by. However if the master password is correctly inserted, this window no longer appears until restart.

Also if you then change to online, you won't need to insert the password again.

Hope this helps to clarify the problem

(Re comment #7) Yes, I think you've nailed the cause, and I can expand on that info somewhat.

The behavior of trying to retrieve messages when offline seems to be a function of account type, and each type seems to work the same in TB 2.0.0.0 as in 1.1.7. What I see is this:

POP account - correctly refrains from trying to download messages while offline, including at startup and shutdown.

IMAP account - will try to download messages every X minutes even if offline. This can be disabled by leaving X blank in Tools -> Account Settings -> Server Settings.

RSS feeds - will try to download messages both at startup and again every X minutes, even though offline.

A side issue is that it may no longer be possible to start TB offline. I use a shortcut with the "-offline" command line option, but it seems to be ignored in 2.0.0.0; that may be pursued as another bug. I still feel the root problem that the engine tries to download messages while offline ought to be fixed, though, so I'm not abandoning this bug.

I couldn't find another bug that deals with the root problem, so I'm changing the title of this one to reflect it.

I'd like to work on this, but I don't know enough about the code to locate the variable that determines online/offline status. Please reply offline if you can tell me that.

Actually I only use POP3 accounts and have the master password problem, so it's not only related to RSS and IMAP. Did you mean that with these two it actually downloads or tries to? The Pop3 account also have the "Check every X minutes" option. Check under: Account settings -> account -> Server Settings

Im my experience, with pop3 accounts, it tries to download too but even after inserting the master pass it won't download anything. The don't download part is correct, since I'm offline. The "tries to" isn't :)
I guess is not only related to IMAP and RSS, at least when it comes to the master password thing.

On 2.0 in the Advanced section I have "Ask me for online state at startup" so I'm prompted every time I start TB. And it starts online or offline. Offline is not ignored i.e. I check the down left corner and it reports offline and works as mentioned above.

About the code, I can't help you on that. I'm a mere TB user. No coding experience :|

Yes, I meant it: my POP3 account is set to download every 5 minutes, but unlike the IMAP and RSS accounts, the POP3 account appears "smart" enough to refrain from making network connection requests when TB is offline.

Sorry, my mistake: all accounts attempt to download while offline, but on the POP account I don't see a prompt for the master password because the download function doesn't ask for it until after it receives an initial response from the POP server.

*** Bug 383228 has been marked as a duplicate of this bug. ***

Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9.1a2pre) Gecko/20080813032636

Not seeing any of the behavior described in this bug, with either IMAP or Pop3. When in offline mode, Tb stays quiet, no attempts whatsoever to contact servers.

andbelo (andbelo) wrote :

Binary package hint: mozilla-thunderbird

1) Ubuntu 8.04.1

2) Thunderbird 2.0.0.17

3) When "Work Offline" is selected in Thunderbird it asks the password to download messages depending on the settings. After that it should not ask the password again until working offline is deselected.

4) It keeps asking for the password when it is time to check for new messages.

My settings: using a master password to encrypt stored passwords

Joel Goguen (jgoguen) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in mozilla-thunderbird:
status: New → Incomplete
andbelo (andbelo) wrote :

Ok, no problem.

I am currently using Ubuntu 8.10 amd64 and just did a quick test: I tested the on-line and off-line mode with the internet either on or off. Results:

with thunderbird already opened:

Internet on and on-line mode: default, works as expected
Internet on and off-line mode: hasn't requested the master password
Internet off and off-line mode: hasn't requested the master password
Internet off and on-line mode: hasn't requested the master password

opening thunderbird without internet connection: keeps asking the master password to check the pop e-mail server. That is ok, once it is supposed to be working in on-line mode

now setting off-line mode: keeps asking the master password. Here! It shouldn't ask anything once it is supposed to be working in off-line mode

Conclusion: the bug remains in Ubuntu 8.10

Joel Goguen (jgoguen) wrote :

Confirming this because of Mozilla bug 286325.

Changed in mozilla-thunderbird:
status: Incomplete → Confirmed
Changed in thunderbird:
status: Unknown → Invalid
Joel Goguen (jgoguen) wrote :

I believe this has enough information for the developers to begin work, so I'm marking this Triaged. I've also commented on the upstream bug asking again for that bug to be changed from the Resolved/Expired state.

Changed in thunderbird (Ubuntu):
status: Confirmed → Triaged
Micah Gersten (micahg) wrote :

Here's a different upstream bug. It's marked WorksForMe, so I think this is fixed in Thunderbird 3.

Changed in thunderbird:
status: Invalid → Unknown
Micah Gersten (micahg) wrote :

Setting to Low since the workaround is to Cancel the dialog.

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
Micah Gersten (micahg) wrote :

I confirmed this is fixed in Thunderbird 3.

Changed in thunderbird:
milestone: none → 3.0
Changed in thunderbird:
status: Unknown → Invalid
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Low

Does not WORKSFORME - please reopen. Thunderbird/3.0.7 with IMAP, RSS, and Local (movemail) accounts (only the IMAP account requires a password).

Offline Settings: "Ask me for online state at startup"

Launch Thunderbird, select "Work Offline".

Thunderbird asks for master password. If I click cancel, the dialog pops up again after 10 minutes when the IMAP account checks again. If I change IMAP to check every 1 minute, dialog pops up every 1 minute.

I suggest opening a new bug (and please CC: me on it). I WFMed this one because I no longer see the problem using POP (I no longer use IMAP).

"-offline" not working is another problem: bug 355889 (note the final comment there, written by a real jerk to whom Windows users don't matter).

I'm also seeing new behavior where two or (more often) three master-password-request dialogs appear on the screen when starting TB 3.1.4, often interrupting each other so that the password I type goes partly to one and partly to another, requiring me to re-enter it multiple times. This is a stupid low-level programming error: when one master-password dialog is on the screen, TB should refuse to create another and simply wait for the result of the first.

(In reply to comment #16)

> I'm also seeing new behavior where two or (more often) three
> master-password-request dialogs appear on the screen when starting TB 3.1.4,
> often interrupting each other so that the password I type goes partly to one
> and partly to another, requiring me to re-enter it multiple times. This is a
> stupid low-level programming error: when one master-password dialog is on the
> screen, TB should refuse to create another and simply wait for the result of
> the first.
We went to a lot of trouble to do exactly what you describe. Sounds like for some reason your setup exposed an issue that we're not seeing here. One known issue is that password protected newsgroups have the bug, but if all you have are IMAP accounts, we haven't seen that issue.

I don't have only IMAP accounts; I no longer use IMAP at all. I use POP3 for mail, NNTP for news, and a fair number of RSS feeds. Will be happy to tell more about my setup if it helps diagnose this (should I file a new bug, or has somebody beaten me to it?)

Do any of your newsgroups require authentication? If so, this is a known issue, I believe.

The news server does require a login, which I have set up using a master password.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.