Ubuntu

Lightning 0.9 broken w/ Thunderbird 2.0.0.17

Reported by enigma_0Z on 2008-10-06
64
This bug affects 8 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: thunderbird

Thunderbird Lightning Extension version 0.9 downloaded from Mozilla's website broken with Thunderbird 2.0.0.17 in Hardy and Intrepid.

When viewing the calendar, no calendars, appointments, or even the grid that appointments go in, is drawn.

Very non-functional. This issue did not exist with stock Thunderbird shipped with Ubuntu Hardy. Lightning extension (0.8) shipped with Ubuntu works fine.

Acura Tech (acuratech) wrote :

I have the same issue : intrepid up to date with the thunderbird shipped with intrepid and lightning 0.9 from mozilla addons website . I can not create new calendar : the option is disabled . I have test with a new thunderbird profile and I have the same issue .

Alexey Androsov (doochik) wrote :

I have the same problems: can't create new calendar, events or tasks, all buttons are disabled.
I tried to intstall libstdc++5 and create a new profile, problems aren't solved.

OS: Kubuntu 8.04
TB: 2.0.0.17

log in attachment

Nicolás Schubert (nischg) wrote :

Just confirming this bug.

Lars W (lars-larswolter) wrote :

also confirming:
Thunderbird Version 2.0.0.17 (20080925)
Lightning Version 0.9 (2008091718)
Ubuntu 8.10 - the Intrepid Ibex

Thunderbird Console Errors (some occure multiple times):
Fehler: [Exception... "Invalid ClassID or ContractID" nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)" location: "JS frame :: file:///home/lars/.mozilla-thunderbird/x8en8gmv.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js :: initBaseComponent :: line 67" data: no]
Quelldatei: file:///home/lars/.mozilla-thunderbird/x8en8gmv.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js
Zeile: 67

Fehler: [Exception... "ServiceManager::GetService returned failure code:" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: chrome://calendar/content/calUtils.js :: getDateFormatter :: line 200" data: no]
Quelldatei: chrome://calendar/content/calUtils.js
Zeile: 200

Fehler: [Exception... "ServiceManager::GetService returned failure code:" nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)" location: "JS frame :: file:///home/lars/.mozilla-thunderbird/x8en8gmv.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js -> file:///home/lars/.mozilla-thunderbird/x8en8gmv.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js :: getCalendarManager :: line 145" data: no]
Quelldatei: file:///home/lars/.mozilla-thunderbird/x8en8gmv.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js -> file:///home/lars/.mozilla-thunderbird/x8en8gmv.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calUtils.js
Zeile: 145

exactt (giesbert) wrote :

Confirming this for a Hardy i386 installation.

description: updated
Changed in thunderbird:
status: New → Confirmed
Naz (nazmulism) wrote :

The fix for this bug is to install libstdc++5:

sudo aptitude install libstdc++5

Then Lightening should work fine with Thunderbird.

-Thunderbird version 2.0.0.17
-Lightening version 0.9
-Ubuntu Intrepid RC

enigma_0Z (enigma-0za) wrote :

Have you tried that yourself?

I've heard that several times and tried it several more. Unless there's been a change in TB or libstdc++5 since October 6, this will (and did) have no effect. Next time I'm on Linux, I'll try it again.

Alexey Androsov (doochik) wrote :

lightning 0.8 has dependence to libstdc++6, i think newer version has this dependence too.
so Installing libstdc++5 take no effect, i try it by myself

viktara (vik-propco) wrote :

Installing libstdc++5 does seem to make this work using hardy, TB 2.0.0.17 and lightning 0.9

You DO have to reinstall lightning after installing libstdc++5.

Alexander Sack (asac) wrote :

not really sure what the problem is. does lightning really use libstdc++5?

Changed in thunderbird:
importance: Undecided → Low
Joel Chav (cdljoel) wrote :

Hello everybody,

I've got the same problem as yours. I'm using on Windows a software called "Portable Thunderbird", I've moved my profile to Ubuntu on my NetBook (Acer Aspire One) with the brand new 8.10 version. I've suffered a lot to make it work. The only thing i've found to resolve this issue :

Found my old backup with lightning plugin version 0.8, remove in the extension folder the folder for lightning and then install lightning extension from ubuntu repository.

Then i could read my calendar and all my events in thunderbird ...

Thunderbird profile seems to be difficult in ubuntu because you can't use all extensions (in the add'ons section of thunderbird).

Is there any possibility to install lightning 0,9 for ubuntu ?

nh2 (nh2) wrote :

Confirmed.

Installing libstdc++5 and then reinstalling Lightning (from Mozillas Webiste) made it work.

C. Reis (reic) wrote :

I can also confirm this bug. Installing libstdc++5 and the reinstall of lightning really does the trick. Thx for the workaround.

Dominic van Berkel (barometz) wrote :

Bug and solution confirmed.

SSteckeler (simon-steckeler) wrote :

Bug and solution confirmed.

John Vivirito (gnomefreak) wrote :

We dont ship 0.9 please report bug upstream not here until i am able to finish 0.9. i have already fixed the depends on this for 0.9. Please dont report lightning-sunbird 0.9 problems until we release it.
This has nothing to do with thunderbird at all.

Changed in thunderbird:
status: Confirmed → Invalid

Bug confirmed, but workaround does not work with amd64.

exactt (giesbert) wrote :

@Björn Schreiweis
Are you using the version form here: http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/0.9/contrib/ ? that one works for me...

John Vivirito (gnomefreak) wrote :

Please use forums or email to discuss this further, all this is doing is adding to bug emails.

eeknay (eeknay23) wrote :

>> Installing libstdc++5 and then reinstalling Lightning (from Mozillas Webiste) made it work.

Confirmed (Ubuntu Interpid, TB 2.0.0.18, Lighting 0.9)

Amir Moulavi (amir-moulavi) wrote :

>> Installing libstdc++5 and then reinstalling Lightning (from Mozillas Webiste) made it work.

Confirmed (Kubuntu Interpid, TB 2.0.0.18, Lightning 0.9). Now it works like before. Thanks for the work around.

John Vivirito wrote:
> Please use forums or email to discuss this further, all this is doing is
> adding to bug emails.
>
>
do we have a "package" 0.9 bug? if so we can make this invalid i think.

lanzen (lanzen) wrote :

It really looks like it. libstdc++5 at last cured it here. A call for a dependency should be added.

Thanks

John Vivirito (gnomefreak) wrote :

lanzen this bug is closed and 0.9 depends on ++6 not 5 please dont comment on closed bugs and not sb 0.9 until we work out bugs that were found.

mrfelton (tkp) wrote :

just confirming the fix here. Sorted it out on 4 laptops (using both hardy and intredid).

Pacho (fchaves) wrote :

The bug is present using Thunderbird 2.0.0.19 on Windows XP... any suggestions or workaround??

John Vivirito (gnomefreak) wrote :

Please dont comment on an invalid bug if you dont have to. For windows and lightning 0.9 in everything before Jaunty file the bug with Mozilla.

Peter (fpeter) wrote :

libstdc++5 solves the problem on 8.1 interpid (after reinstall lightning)

Fredy (fycsao) wrote :

An additional confirmation...
Installing libstdc++5 in Ubuntu 8.10 solves the problem with Thunberbird 2.0.0.21.
Similar to previous comment is necessary reinstall linghtning.

John Vivirito (gnomefreak) wrote :

Fredy we do not ship 0.9 for 8.10 or lower. this bug is closed for that reason if it doesnt work file bug upstream since we dont ship it you either used upstreams build (file bug mozilla) or you used the one in my PPA (not supported use at own risk)
Please stop commenting on a closed bug,

Jeffonline (jeffonline) wrote :

Confirmed (Ubuntu Jaunty, TB 2.0.0.21, Lighting 0.9)

libstdc++5 solves the problem on 9.04 and after reinstall lightning

kickwin (kickwin) wrote :

Yes libstdc++5 fixed the problem.

For new users like me, go to Synaptics (if Ubnutu) or any other install manager and type libstdc, you will the ++5 version, install it. Now reinstalling Lightning should do the job.

rudy88 (rudy88) wrote :

That worked for me too.
Ubuntu 9.04, Thunderbird 2.0.0.22, lightning 0.9.

Great!

John Vivirito (gnomefreak) wrote :

upsteam lightning uses libstdc++5 and ours uses libstdc++6.
upstreams version will over ride ours in the profile.

raphael (ethadm) wrote :

solved.

Jonathon James (isamaranga) wrote :

Unfortunately this problem is not fixed for me, running Jaunty. Installing or uninstalling libstdc++5 has no effect. I realize this is a closed bug, but could anyone help me or at least point me to where I can find a solution. Thanks.

jem555 (jem555) wrote :

Hi. Last time it happend to me worked ok on Jaunty...but I did fresh install using Karmic and there's no libstdc++5, only ++6... now it didn't worked like before...
Any help please?
Thanks.

John Vivirito (gnomefreak) wrote :

++6 works here with our package. upstream 0.9 needs ++5 IIRC, this should be fixed in 1.0 upstream should bump depends to ++6

Caras Galadhon (michal-hanzal) wrote :

confirming bug on karmic, thunderbird 2.0.0.23, lightning 0.9
libstdc++6 doesn't work...

Peter Henriksen (repete) wrote :

yet another confirmation on karmic, thunderbird 2.0.0.23 and lightning 0.9, and libstdc++6

Jonathon James (isamaranga) wrote :

In Jaunty I completely removed and then reinstalled thunderbird to solve the
problem. You may also want to try to use the Thunderbird 3.0 development
build from the mozilla daily repository.

On Tue, Nov 3, 2009 at 1:32 PM, Peter Henriksen <email address hidden> wrote:

> yet another confirmation on karmic, thunderbird 2.0.0.23 and lightning
> 0.9, and libstdc++6
>
> --
> Lightning 0.9 broken w/ Thunderbird 2.0.0.17
> https://bugs.launchpad.net/bugs/278853
> You received this bug notification because you are a direct subscriber
> of the bug.
>

John Vivirito (gnomefreak) wrote :

Please dont comment on closed bugs, all it does is send me unneeded emails. This is more of a profile bug or using upstream package. Please rename your .mozilla-thunderbird profile and start on new profile. as for using 3.0 it does not support lightning from our repos, I dont recall if they fixed it in upstream 1.0 and/or thunderbird3.0

Mike (insomniux) wrote :

yet another confirmation on karmic, thunderbird 2.0.0.23 and lightning 0.9, and libstdc++6 on amd64

Dirty workaround: create two symlinks like
lrwxrwxrwx 1 root root 16 2009-12-23 23:12 libstdc++.so.5 -> ./libstdc++.so.6
lrwxrwxrwx 1 root root 21 2009-12-23 23:13 libstdc++.so.5.0.13 -> ./libstdc++.so.6.0.13
Made it work instantaneously

(sorry for the addition to this dead bug....)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments