scrollboxes scroll to offset 0 when resized

Bug #244635 reported by Martin Olsson on 2008-07-01
4
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Low
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

1. install thunderbird (I used 2.0.0.14 for this repro)
2. create a large set of local folders so that you have about two screenfulls of local folders
3. select the top "inbox" node
4. scroll the list of local folders to the bottom
5. resize the local folders panel to be a little bit bigger

Expected:
I just want to resize it, I don't want it to change the scroller position as a side effect,

Actual:
The scrollbox/panel that contains the local folder will automatic scroll to offset 0 making the selected "inbox" item visible again.

Note: I think this is a bug in the mozilla platform or whatever because I see the same buggy effect when I create a large amount of filter rules inside the "Tools::Message Filters" dialog (to repro the bug in there I just create two screenfulls of filter rules (about 60 or so) and then select the first rule, scroll to the bottom and then resize the entire "Message Filters" dialog window.

Martin Olsson (mnemo) wrote :

The list view used Edit::Preferences::Advanced::Encryption::View Certificates::Authorities for Firefox 2.0.0.15 on Ubuntu exhibits the same problem, so it's definately a platform problem. This problem has been fixed in FF3 though so compiling against the mozilla trunk XULRunner will likely be sufficient to fix this bug (this is itself of course not exactly a trivial thing to do I suppose).

Changed in thunderbird:
status: Unknown → Invalid

User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier:

Per bug 454632, the default <tree> behaviour of always scrolling to keep the current selection viewable, while desirable in Thunderbird, isn't generally desirable in other uses of <tree>.

The patch in 454632 will update <tree> to default to not keeping the current selection viewable upon reflow, which means Thunderbird will need to be updated to set the 'keepcurrentinview' attribute true.

Reproducible: Always

Steps to Reproduce:
1. Select an item in the tree.
2. Resize the containing element
3. Weep a little.

Created an attachment (id=353852)
Patch v1

Adds the 'keepcurrentinview' attribute to the thread pane <tree> element.

(From update of attachment 353852)
this looks ok to me - checking with Neil for SM part.

(From update of attachment 353852)
I'd add the attribute in the middle like you did for Thunderbird, this avoids fiddling around with /> ;-)
I think Mnyromyr should get to look at this too.

Ah, I added it to the end in order to keep the true/false attributes grouped together - but I'm fine with either.. 'tis a trivial change either way :)

(From update of attachment 353852)
You need to patch up the folderTree as well; and please follow Neil's advice on attribute placement.

r=me with that fixed

Created an attachment (id=356249)
Patch v2

Addresses Mnyromyr's comments (to update folderTree as well)
Addresses Neil's comments re: placement of attributes

Moving 454632 from Depends to Blocks since 454632 can't land until this patch lands

(From update of attachment 356249)
You weren't around when I finally managed to persuade Mnyromyr that we don't need it for the folder pane after all :-)

Pushed:

changeset: 1628:6bb13202f7cd
user: Nick Kreeger <email address hidden>
date: Tue Jan 13 10:40:17 2009 -0800
summary: Fixing Bug 470263 - Use of <tree> needs to be updated to keep current selection in view upon reflow. r=bienvenu, mnyromyr. sr=neil. Patch by Stephen Lau <email address hidden>.

changeset: 1630:47c9fe5de473
tag: tip
parent: 1628:6bb13202f7cd
parent: 1629:4cfbdb787aa3
user: Nick Kreeger <email address hidden>
date: Tue Jan 13 10:44:45 2009 -0800
summary: Merge bug 470263

Micah Gersten (micahg) wrote :

Upstream went through a few duplicates. Here's the latest.

Changed in thunderbird:
status: Invalid → Unknown
milestone: none → 3.0
Micah Gersten (micahg) wrote :

Marking triaged pending release of Thunderbird 3 in Ubuntu.

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in thunderbird:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.