Not able to paste image into thunderbird compose mail window

Bug #241276 reported by SK on 2008-06-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Won't Fix
Wishlist
Nominated for 2.0 by Andrei Komolov
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: thunderbird

Editing window in Linux does not accept images from the clipboard.

ProblemType: Bug
Architecture: i386
Date: Thu Jun 19 07:41:34 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: mozilla-thunderbird 2.0.0.14+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunderbird
Uname: Linux 2.6.24-19-386 i686

Created attachment 296847
Paste clipboard image into composer under Linux/Unix

I don't think you need the #ifdef MOZILLA_1_8_BRANCH since the patch isn't very likely to get accepted for tb2, only for tb3.

To get the patch included, set the appropriate review/superreview flag of the patch.
See http://developer.mozilla.org/en/docs/Getting_your_patch_in_the_tree

Marking NEW as we got a patch.

Comment on attachment 296847
Paste clipboard image into composer under Linux/Unix

I'm not a reviewer for this code, try <email address hidden> perhaps?

Comment on attachment 296847
Paste clipboard image into composer under Linux/Unix

Please make your patch against the latest trunk CVS.

Hmm, it seems this issue is fixed in latest trunk already (at least what I can read from the sources) :| Can you paste images from clipboard under Linux? (compiling trunk here again will take some hours).

(In reply to comment #5)
> Hmm, it seems this issue is fixed in latest trunk already (at least what I can
> read from the sources) :| Can you paste images from clipboard under Linux?
> (compiling trunk here again will take some hours).
>

AFAICT you can. This was fixed as part of bug 21747.

Comment on attachment 296847
Paste clipboard image into composer under Linux/Unix

guess we don't need this then.

I suppose Linux distributions might want to take this on branch, in which case we could take it on branch too. But we don't need it on trunk anymore.

Ok, so do I have to open the bug again and trigger a review for branch?

Blizzard, caillon, who decides what to take on branch for Linux these days?

I trust the Linux brain trust at the distributions - caillon, asac, others. With your review, of course.

For 1.8.0.x that's asac and me.
For 1.8.1.x that's still dveditz and co.

This patch would need to get reviewed/approved for the 1.8.1 branch first I think before we'd take it on the 1.8.0 branch so we don't "regress" moving forward. But I'm not opposed to having it, pending discussion with asac if the rest falls into place, though I'd rather see the patch support more than just jpg (not sure if that's possible back then)

- tv.tv_sec = 0;
+ tv.tv_sec = 5;
         tv.tv_usec = kClipboardTimeout;

You're adding 5 seconds here? wouldn't it make more sense to change kClipboardTimeout?

+ if (gdk_pixbuf_get_has_alpha(new_pixbuf) == TRUE)
+ format = imgIEncoder::INPUT_FORMAT_RGBA;

Why bother since we can't create a transparent image anyway?

(In reply to comment #13)
> - tv.tv_sec = 0;
> + tv.tv_sec = 5;
> tv.tv_usec = kClipboardTimeout;
>
> You're adding 5 seconds here? wouldn't it make more sense to change
> kClipboardTimeout?
Well, because increasing the microseconds is not enough, you need a timeout
of several seconds for large images.

> + if (gdk_pixbuf_get_has_alpha(new_pixbuf) == TRUE)
> + format = imgIEncoder::INPUT_FORMAT_RGBA;
>
> Why bother since we can't create a transparent image anyway?
We can't? So why does ImageEncoder provide that format flag?

Ciao,
Tobias

Maybe the encoder is capable of creating transparent images, but you're a) creating a JPEG, which doesn't support transparency and b) passing "transparency=none".

> Well, because increasing the microseconds is not enough, you need a timeout
> of several seconds for large images.

OK, but you're changing kClipboardTimeout to mean "the clipboard timeout, minus five seconds", which is not very intuitive. Either you need two constants, say kClipboardTimeoutSeconds and kClipboardTimeoutMicroseconds, or you need to change kClipboardTimeout to 5000000 microseconds and do some arithmetic to split it up into the tv fields.

SK (skiani) wrote : images paste

Binary package hint: thunderbird

Editing window in Linux does not accept images from the clipboard.

ProblemType: Bug
Architecture: i386
Date: Thu Jun 19 07:41:34 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: mozilla-thunderbird 2.0.0.14+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunderbird
Uname: Linux 2.6.24-19-386 i686

SK (skiani) wrote :
Rui Boon (ruiboon) wrote :

Thank you for reporting this bug and helping to make Ubuntu better. According to the source code, "image pasting from the clipboard is only implemented on Windows right now" This bug has already been reported upstream at https://bugzilla.mozilla.org/show_bug.cgi?id=412196 You may like to track the status over there. Thanks

Changed in thunderbird:
status: Unknown → In Progress
Rui Boon (ruiboon) wrote :

This is not a bug per se as the source comment explicitly mentioned that image pasting is not implemented in non-windows OSes. This however, is a wishlist. Upstream report suggest that this will only be implemented in thunderbird-3.0 and not the current 2.0 versions.

Changed in thunderbird:
status: New → Confirmed

Comment on attachment 296847
Paste clipboard image into composer under Linux/Unix

Comments need to be addressed

Micah Gersten (micahg) wrote :

Marking this Triaged as we have an upstream bug. This is actually fixed in Thunderbird 3, but the upstream bug is to see if this will be fixed in Thunderbird 2.

Changed in thunderbird (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Changed in thunderbird:
milestone: none → 3.0
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Wishlist
Bernard Decock (decockbernard) wrote :

Can't paste image from an open OpenOffice document into thunderbird.

Thunderbird : Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.15) Gecko/20101027 Lightning/1.0b1 Thunderbird/3.0.10
Open Office OOO320m12 (Build 9483).

When you select a picture from your document (copy), you can't copy this image into Thunderbird. However if you open GIMP,
you can create an image from the clipboard (=> means that OO has transferred the image to the clip-board!). If you select the
just created image in Gimp, you can copy and paste this image into Thunderbird.

cameleon (el-cameleon-1) wrote :

I can confirm this bug is still present (and very annoying) with Ubuntu 11.10 and Thunderbird 8 :-(

Tobias, do you still work on this -annoying- bug? Seems most of the job is done, so it would be a pity if we stop when 90% of the job is done :-(

-> WONTFIX as this works on recent versions, and the 1.8 branch is dead.

sorry, it doesn't works for me on Ubuntu 11.10 and TB8 (also tryed with earlybird). Are you sure that this bug is fixed?

Yup- just tried it, works just fine - ubuntu (still 11.04) and tb 3.1.13, also latest trunk.
Make sure you're using HTML compose mode though...

Changed in thunderbird:
status: In Progress → Won't Fix

Created attachment 585161
exemple of odt document which doesn't work in Thunderbird 8

exemple of an image of a car in a odt document which doesn't work in Thunderbird 8.
I also try in safe mode, the result is the same: the "past" command in the "Edit" menu is disabled (gray). I am sure I compose mail in html. I also check that the past command works in other application (like Gimp).

Could you do the test to with this particular file? Any other person can give its feedback?

Yeah copying from that file doesn't work. Maybe the source have to be in compatible format (jpg/gif/png)? Try finding a pic on the web, in firefox go to the image and use "Copy Image" from the context menu, then paste in thunderbird. That's what i tested.

Ok, I understand now that my problem should have its own bug report. I will try to find an existing one or create a new one if needed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.