Message is partially lost if disk is full

Bug #23302 reported by Eric Feliksik on 2005-10-05
24
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Medium
Mozilla Bugs

Bug Description

I was receiving new mail when thunderbird told me there wasn't enough disk space
(hmm, actually I'm not even sure if it was thunderbird, I guess it was). The
result is that a mail I received (from sender X), fetched with POP3, was only
partially received, *and* deleted from the server. Now that I made disk space
and restarted thunderbird, another message (from sender Y) is concatenated after
the partially received one. The message is shown as sent by sender X in the
mailbox-list, but the body looks like this:

[START OF BODY]

Hoi hoi,

PaMa gaat naar Poeldijk! En daar zal het hele koor zich voor moeten
inzetten, want we hebben nog maar een paar repetities om nieuwe liederen
in te studeren. Ik benFrom - Thu Oct 6 00:32:24 2005
X-Account-Key: account3
X-UIDL: d62d5a895e70ac33429979b65de5dc56
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <email address hidden>
X-Flags: 0000
Delivered-To: GMX delivery to <email address hidden>
Received: (qmail invoked by alias); 05 Oct 2005 20:55:14 -0000
Received: from prancer.startpda.net (EHLO prancer.startpda.net) [213.193.242.5]
  by mx0.gmx.net (mx016) with SMTP; 05 Oct 2005 22:55:14 +0200
Received: from dancer (dancer.internal [10.10.0.3])
 by prancer.startpda.net (Postfix) with SMTP id C7DE158207

[......MORE BODY]

So the headers of the message from sender Y, and the body of the message (body
of 2nd message is not shown here) are concatenated to the first message.
The first message is partially lost.

Matt Zimmerman (mdz) wrote :

This bug has been marked as a duplicate of bug 22842.

Paul Dufresne (paulduf) wrote :

I reopen it, removing Tolleg Fog Heen as assignee (my guess is that he is there just as a default value when importing from older bugzilla), because I wrote a new specification for the general case of bug 22842, but as it may take much time to actually be implemented, I think thunderbird may wish to have some 'temporary hack' to avoid this bug. And bug 22842 may well be closed now that a spec have been written, but I don't wish this one to be closed at the same time.

Changed in mozilla-thunderbird:
assignee: tfheen → nobody
status: Rejected → Unconfirmed
Alex Latchford (alex.latchford) wrote :

I am presuming this is still an issue, thus I am marking it as confirmed.

Thanks, Alex.

Changed in mozilla-thunderbird:
assignee: nobody → mozillateam
status: Unconfirmed → Confirmed
David Farning (dfarning) on 2007-02-24
Changed in mozilla-thunderbird:
assignee: mozillateam → mozilla-bugs
Alexander Sack (asac) on 2007-05-13
Changed in thunderbird:
status: Unconfirmed → Rejected
W3ird_N3rd (w3ird-n3rd) wrote :

I had Thunderbird 2.0.0.17 running (and checking mail every 10min automatically) while I ran out of disk space because of a DVB recording (why doesn't kaffeine stop before eating the last 50MB or so?).

My mailbox seems fine, but when I check for mail now, Thunderbird wants to download 11.000 messages or so. Messages that already are in the inbox but Thunderbird doesn't seem to understand that. I could obviously download those 11.000 messages and delete them again, but it doesn't seem right. Rebuilding the index didn't help.

Proposed solution: let Thunderbird check if there is enough disk space before collecting mail. If there's less than 200MiB (I'm just picking a number) available, do not collect mail from the server. This way you can never get into this corrupted state in the first place..

W3ird_N3rd (w3ird-n3rd) wrote :

I figured out what happened: popstate.dat lost some records, apparently this happens when you run out of disk space. Unfortunately there's not really any way to rebuild popstate.dat based on inbox contents (guess that's not going to work anyway with all the locally removed mail) so I re-downloaded the messages Thunderbird wanted to download and deleted them again. Now popstate.dat is complete again.

affects: thunderbird → ubuntu
no longer affects: ubuntu
affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.