[snap] GUI not show. Thunderbird snap won't open with AMD Ryzen 4750 Pro (Ubuntu 21.04)

Bug #1936047 reported by Eduardo Rojas Rodríguez
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

In a laptop Thinkpad t14s AMD 4750 PRO (Renoir GPU) with Ubuntu 21.04 (5.11.0-22-generic)

When opening Thunderbird Snap, from GUI menu or from command line, 2 processes are opened, and the program GUI is not displayed.

eduardo@edu-ThinkPad-T14s:~$ pgrep -a thunderbird
9173 /snap/thunderbird/127/thunderbird-bin
9253 /snap/thunderbird/127/thunderbird-bin

Killing the last process allows the program GUI to start fully and be displayed.

Thunderbird Snap version:
Name........Version.Rev.Tracking.....Publisher
thunderbird 78.11.0 12 latest/stable canonical✓

Here are the jurnalctl -t audit -f logs

jul 13 21:38:41 edu-ThinkPad-T14s audit[8630]: AVC apparmor="DENIED" operation="capable" profile="/snap/snapd/12398/usr/lib/snapd/snap-confine" pid=8630 comm="snap-confine" capability=4 capname="fsetid"
jul 13 21:38:47 edu-ThinkPad-T14s audit[8630]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.thunderbird.thunderbird pid=8630 comm=64636F6E6620776F726B6572 exe="/snap/thunderbird/127/thunderbird-bin" sig=0 arch=c000003e syscall=314 compat=0 ip=0x7f5c7f6b1639 code=0x50000
jul 13 21:41:32 edu-ThinkPad-T14s audit[9016]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.firefox.firefox pid=9016 comm="MainThread" exe="/snap/firefox/558/firefox-bin" sig=0 arch=c000003e syscall=314 compat=0 ip=0x7fd5bdfa8639 code=0x50000
jul 13 21:43:54 edu-ThinkPad-T14s audit[9173]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.thunderbird.thunderbird pid=9173 comm=64636F6E6620776F726B6572 exe="/snap/thunderbird/127/thunderbird-bin" sig=0 arch=c000003e syscall=314 compat=0 ip=0x7fc72440b639 code=0x50000
jul 13 21:53:44 edu-ThinkPad-T14s audit[9788]: SECCOMP auid=1000 uid=1000 gid=1000 ses=3 subj=snap.thunderbird.thunderbird pid=9788 comm=64636F6E6620776F726B6572 exe="/snap/thunderbird/127/thunderbird-bin" sig=0 arch=c000003e syscall=314 compat=0 ip=0x7f09bf711639 code=0x50000

After killing the last process the GUI its fully loaded and thunderbird snap work.

This is a related Answer form Launchpad
https://answers.launchpad.net/snappy/+question/697307

Maybe its something with new amdgpu drivers, since in another laptop (thinkpad t460 intel with Ubuntu 21.04) this does not happen.

summary: - [Snap] GUI not show. Opening Thunderbird snap causes 2 processes to open
+ [snap] GUI not show. Opening Thunderbird snap causes 2 processes to open
(Ubuntu 21.04)
description: updated
tags: added: hirsute
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote (last edit ):

I must add that, in the same Thinkpad t14s AMD 4750 PRO (Renoir GPU) with Ubuntu 20.04.2 LTS kernel 5.8 this problem does not happen.

this can be important because in august the Ubuntu LTS its going to upgrade the kernel (if I understand correctly) this can break the snap for a lot of AMD laptops users

summary: - [snap] GUI not show. Opening Thunderbird snap causes 2 processes to open
+ [snap] GUI not show. Thunderbird snap won't open with AMD Ryzen 4750 Pro
(Ubuntu 21.04)
Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote :

Tested with linux kernel 5.11.0-31-generic and drivers updated from MESA 21.0 to 21.3 using the oibaf PPA. This problem persist

Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote (last edit ):

Tested with Ubuntu 20.4.3 with the new kernel 5.11 and now the this problem is present in the LTS version.

tags: added: snap
Revision history for this message
Eduardo Rojas Rodríguez (edurojas) wrote :

Confirm this is fixed in new snap rev from Thunderbird 91.

Closing

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers