send button does not work

Bug #1604394 reported by Tim Passingham on 2016-07-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

On 19/7/16 I accept updates for thunderbird 38 to 45.2, using the standard ubuntu update process on 16.04.1 xenial, kernel "4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux" (followed by a lightning extension update).

I could not send any email, nor spell check. Nothing happened when I pressed the buttons. So I downgraded to 1.38.6.0+build1-0ubuntu1 (and replaced the lightning extension). All now works again. I had to force and lock this version using synaptic.

I don't see how this can be anything to do with my setup, since 38 works OK.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed

Same thing here, I can add that none of this work:
- "Send" button
- Ctrl+Enter (shortcut for Send)
- Ctrl+Shift+Enter (shortcut for Send later)

I started thunderbird from terminal to see if something gets logged to the terminal, but I did not see anything.

By the way, I disabled any extension that had anything to do with the Sending or composing functionality.
Tried in Gnome, Kde(Plasma), XFCE, same behavior.

Downgrading to 1.38.* (via synaptic GUI) worked also for me.

Tim Passingham (tim-8aw3u04umo) wrote :

For the importance level, this version of Thunderbird is unusable, at least on some systems. Not everyone will find it that easy to downgrade to 38, so it really needs to be withdrawn ASAP before too many people update to it.

Tim Passingham (tim-8aw3u04umo) wrote :

I'm happy to test a beta fix if that helps, given a ppa or other method.

Tim Passingham (tim-8aw3u04umo) wrote :

I'm also happy to try and help to diagnose the problem if it's only happening on some systems.

Tim Passingham (tim-8aw3u04umo) wrote :

I have tried version 45 on a different system, running trusty 14.04, and it works properly.

What can do I do help resolve the problem on my 16.04 system?

Tim Passingham (tim-8aw3u04umo) wrote :

Hi again,

I thought I should at least try testing without any extensions enabled. That fixed it on xenial :-)

The offending extension was QuoteAndComposeManager 0.3.32.3 (1/16/13). Disabling this resolved the issue. My other extensions (especially Lightning, which is important to me) are OK.

For me this issue can now be closed (extensions presumably not being part of 'the package'). However Daniele De Felice may still have issues.

Hi again,
now it works also for me.
The addon responsible for the bug was "Edit Sender".
I think that the problem is that a very similar functionality is already integrated in the new version of thunderbird.
I think the bug can be closed.

Tim Passingham (tim-8aw3u04umo) wrote :

I assume someone at ubuntu has to close this. If it's up to be as the raiser, could someone let me know what the appropriate procedure is.

I also found a new version of the QuoteAndComposeManager extension (0.4.1) that works in version 45.

Close this?

As i wrote, for me it works, so you can close it.
If I can close it, I don't see how :)

I've marked it 'fix released'.

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers