all settings>appeance does not provide option to show/hide underlined letters in menus

Bug #1499942 reported by Humphrey van Polanen Petel on 2015-09-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

Pressing <Alt> reveals the main menu with keyboard short-cuts properly underlined.
Pressing one of those keys reveals the drop-down menu with keyboard short-cuts *not* underlined.
Moving the cursor down by pressing the <Down> key will make the underlines appear.

This is behavior is unfriendly towards those who prefer to use the keyboard, because of suffering "mouse arm".

There appears to be a setting somewhere to make those letters underlined.
Therefore there should be a setting in System setting>All setting>Appearance that allows the user to choose.
That setting not being there makes it a matter of bad design which goes against the spirit of ubuntu which qualifies it as a bug.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity-control-center 14.04.3+14.04.20140922-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.16.0-49.65~14.04.1-generic 3.16.7-ckt15
Uname: Linux 3.16.0-49-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.15
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Sep 26 12:39:38 2015
ExecutablePath: /usr/bin/unity-control-center
InstallationDate: Installed on 2015-09-08 (18 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_unity-control-center: deja-dup 30.0-0ubuntu4

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Martha Bourgois (mat.bourgois) wrote :

still the case on 18.04

Khurshid Alam (khurshid-alam) wrote :

There was never settings like that. Gnome disables mnemonics for several apps or the apps doesn't provide any shortcuts. Not a u-c-c bug.

Changed in unity-control-center (Ubuntu):
status: Confirmed → Invalid
Changed in unity-control-center (Ubuntu):
status: Invalid → New

With all due respect, but I do not accept Khurshid's decision.
Regardless of whether there was or was not a setting like that is not relevant.
The point is that the absence of underlining on shortcut keys aggravates the pains in my (and I suspect many other user's) mouse arm. Unnecessarily.
I am of the opinion that this is an issue that needs to be rectified.
Hence I have reopened this bug.

gf (gf-interlinks) wrote :

Hello Humphrey,
Just to clarify for the programmers:
What version of Ubuntu are you in?
What are the applications in which you use the keyboard shortcuts?
What are the versions of those applications?

I know you described it in your bug descriptions but could you post the exact steps to create the problem (including mouse movements and keyboard actions)?
For example:
1. open ... application
2.
3....

Thanks
G

C de-Avillez (hggdh2) wrote :

I have a machine running 16.04, under Unity.
* I opened LibreOffice Writer, and then:
  * pressed Alt -- the LOW main menu appears, and the entries have their character trigger underlined;
  * pressed Alt-F -- the submenu for File opens up, and *all* character triggers are underlined. But No other main menu
  entry shows the triggers, including entries from Main.
* Opened Firefox. Alt alone shows the main menu, but *only* File has been set to use a character trigger.
* Opened Chrome -- Alt shows the main menu and behaves like Firefox, with one exception: Alt-F shows a different sub-
  menu from (using the mouse) pointing to, and clicking on, File.

For the other sub-menus from Main (for the three appls tested), some already have default (and personalised) keyboard shortcuts.

I am not a DE (Gnome, or Unity, or any other DE) programmer, but it sounds like this is the expected behaviour.

I do agree that minimising mouse usage is a Good Idea (TM); even more, I sort of agree that a *common* behaviour should be expected, and desired. But this (I think) would require a revamp of the UI for all programs (since it is quite clear that this is, to a point, controlled by each individual program).

Not sure how to keep on here.

gf (gf-interlinks) wrote :

Thanks for looking into this, C.

I had thought I could change the bug report to another ubuntu package, if u-c-c is incorrect.

Now after your results, perhaps I could change the package to the specific program package, (for example, Thunderbird) and change status to wishlist. That's only if there is one specific program that Humphrey uses a lot and he and I could focus on getting that one program updated.

I know you are busy with another project. Thanks for taking the time to try out the different programs.
Take care
:)
G

I am running 16.04

Below are programs I have tested (pinned to my taskbar)

<Alt> = y = horizontal menu with shortcut keys underlined
<Alt> = x = horizontal menu, but no shortcut keys underlined
<Alt> = - = no horizontal menu
<Alt-X> = x = dropdown menu, but no shortcut keys underlined

name <Alt> <Alt-X>
nautilus y x
terminal x
leafpad y x
firefox y x
thunderbird y x
virtualbox y x
gedit y x
calculator x
search for files -
shutter y x
remmina y x
system settings x
disks x
baobab x

Would be nice if window management were a platform, so to speak.

gf (gf-interlinks) wrote :

Hi Humphrey,
I am not sure what next step to take here. I was hoping you'd tell me the main application, that you use all the time, which is giving you the most grief. Then, we could change this bug report to that program's package.

This sounds like a "wishlist" item and I will get the bug control team to change the importance to that level. But there needs to be a target, a specific application.

Based on the Ubuntu Control Team's answer, it looks like they won't fix all of Ubuntu, and that you need to talk to the programmer of each application that has the problem, to get them to fix their interface.

So, on which application do you want to focus this particular bug report?
Thanks for your patience
:)
G

Hi G,

I apologize for missing that.

Thunderbird would be my choice.

Humphrey

gf (gf-interlinks) wrote :

OK, thanks for the fast reply, Humprey. I will change it to that package and will write up a summary for the programmers.
Have a great morning!
:)
G

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
gf (gf-interlinks) wrote :

Hi again Humphrey,
What version of Thunderbird are you in?
:)
G

affects: unity-control-center (Ubuntu) → thunderbird (Ubuntu)
gf (gf-interlinks) wrote :

And could you list for me the specific steps in Thunderbird to demonstrate one sub-menu not having shortcut letters properly indicated?

I have the latest version 60 of Thunderbird and it would help if I could attach screen prints of the problem.

Take care and thanks for your patience.
:)
G

Sorry.

Thunderbird 52.9.1 (64-bit)

gf (gf-interlinks) wrote :

Hi Humphrey,
Thanks for the TB version and the screen print. Thank you in advance for your patience as I have more questions for you...

I see on your screen print of the "Edit" menu, there are several shortcuts already. For example, for the "undo" function in the edit menu, you can do that straight from the main Thunderbird window (with no menu showing). You hold the control button and the letter "z" to undo an operation.

The underlines in the "Edit" menu are showing up right away for me as soon as I hit control-E (in 18.04, TB 52.9.1 64-bit). Is that the concern or is it that additional shortcut keys are needed in the menus?

Humphrey, here is a partial summary:
------------------------------

Steps to reproduce:
1. Open Thunderbird
2. Select a message
3. Hold down the “alt” key and press letter “e”

Expected behaviour: as soon as the "edit" menu shows on screen, each item in the menu should have one letter underlined, indicating the keyboard shortcut to activate that item.

Actual behaviour: When edit menu shows up, the keyboard shortcut options are not being displayed right away (none of the letters are underlined). One has to hit the down arrow to cause the underlining to be displayed.

Additional notes:
Reporter has attached screen print of the edit menu showing no underlined letters.
Reporter is aware that this is an enhancement request.
Bug has been confirmed by one other person in Ubuntu 18.04.
Triager has NOT been able to replicate this bug in Ubuntu 18.04, TB v52.9.1.

----------

Humphrey, please could you make corrections to (or completely re-write as needed) the partial summary above, to suit what you are hoping for? Please also add in additional steps that indicate where mouse movement/clicks.

Thanks
:)
G

gf (gf-interlinks) wrote :

Hi Humphrey,
I think the title of this bug is unclear. What do you think about the following revised title:

Menu item keyboard shortcut underlined letters do not show up right away

Please edit/correct as needed.
Thanks
G

C de-Avillez (hggdh2) wrote :

Setting to wishlist as requested in #ubuntu-bugs.

Changed in thunderbird (Ubuntu):
importance: Undecided → Wishlist
gf (gf-interlinks) wrote :

Thanks for changing the importance level for me, C!
:)
G

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers