No cursor/keyboard action in email being composed

Bug #1490821 reported by Anders Sjögren on 2015-09-01

This bug report will be marked for expiration in 22 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Kubuntu install with XFCE desktop. Thunderbird 31.8.0.

Since a few months I have an intermittent behavior where, for no apparent reason, when I start to compose a new email message, there is no cursor in the address field or message field (when I click there). Mouse works as normal and can select text.

On top of this, and this is the suspected bug, the missing cursor often but not always means that any keyboard action (trying to write) works on the main Thunderbird window. Space, for instance, scrolls through the message in the message pane in the main Thunderbird window, even if the new being composed in another window is on top.

The only way around this issue is to restart Thunderbird or to open a new email window. When I open another new message window, the cursor is back in the original email message window.

I have noticed that it takes much longer time to load the email message window the first time I start Thunderbird, compared to email message 2,3 etc. Now, when I see the above issue opening a new email message also takes more time. I am guessing something crashes in the backend and that it is restarted when I open another new message window.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: thunderbird 1:31.8.0+build1-0ubuntu0.14.10.1
ProcVersionSignature: Ubuntu 3.16.0-44.59-generic 3.16.7-ckt14
Uname: Linux 3.16.0-44-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.14.7-0ubuntu8.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: anders 2679 F.... pulseaudio
 /dev/snd/controlC0: anders 2679 F.... pulseaudio
BuildID: 20150715162430
Channel: Unavailable
CurrentDesktop: XFCE
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
Date: Tue Sep 1 07:18:28 2015
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
IpRoute:
 default via 192.168.1.1 dev p3p1 proto static
 192.168.1.0/24 dev p3p1 proto kernel scope link src 192.168.1.13 metric 1
Locales: extensions.sqlite corrupt or missing
MostRecentCrashID: bp-4a972d4c-97c3-4487-a40e-380872150720
PrefSources:
 prefs.js
 [Profile]/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults/preferences/lightning.js
ProcEnviron:
 LANGUAGE=sv_SE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=Safe Mode/Safe Mode (Out of date)
RelatedPackageVersions:
 adobe-flashplugin 1:20150716.1-0utopic1
 kopete 4:4.14.1-0ubuntu2
 totem-mozilla 3.10.1-1ubuntu6
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: thunderbird
SubmittedCrashIDs: bp-4a972d4c-97c3-4487-a40e-380872150720
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 02/06/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.02
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: FS437T
dmi.board.vendor: Shuttle Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.02:bd02/06/2014:svnShuttleInc.:pnDS437T:pvrV1.0:rvnShuttleInc.:rnFS437T:rvr1.0:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: DS437T
dmi.product.version: V1.0
dmi.sys.vendor: Shuttle Inc.
---
AddonCompatCheckDisabled: False
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC1D0p: anders 4690 F...m pulseaudio
 /dev/snd/controlC1: anders 4690 F.... pulseaudio
 /dev/snd/controlC0: anders 4690 F.... pulseaudio
BuildID: 20180522092721
Channel: Unavailable
CurrentDesktop: XFCE
DistroRelease: Ubuntu 16.04
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
IpRoute:
 default via 192.168.1.1 dev p3p1 proto static metric 100
 169.254.0.0/16 dev p3p1 scope link metric 1000
 192.168.1.0/24 dev p3p1 proto kernel scope link src 192.168.1.13 metric 100
Locales: extensions.sqlite corrupt or missing
MostRecentCrashID: bp-6290ed11-55d4-493f-83a5-25c080180222
Package: thunderbird 1:52.8.0+build1-0ubuntu0.16.04.1
PackageArchitecture: amd64
Plugins: Shockwave Flash - /usr/lib/adobe-flashplugin/libflashplayer.so (adobe-flashplugin)
ProcVersionSignature: Ubuntu 4.4.0-128.154-generic 4.4.131
Profiles: Profile0 (Default) - LastVersion=52.8.0/20180522092721 (In use)
RelatedPackageVersions: adobe-flashplugin 1:20180607.1-0ubuntu0.16.04.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: no
RunningIncompatibleAddons: False
SubmittedCrashIDs:
 bp-6290ed11-55d4-493f-83a5-25c080180222
 bp-4bacd9d1-b4cc-46aa-8418-a1c590170628
 bp-ab291a27-7cc9-44ce-8159-315ab0170602
 bp-4a972d4c-97c3-4487-a40e-380872150720
Tags: xenial
Themes: extensions.sqlite corrupt or missing
Uname: Linux 4.4.0-128-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

WifiSyslog:

_MarkForUpload: True
dmi.bios.date: 02/06/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.02
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: FS437T
dmi.board.vendor: Shuttle Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.02:bd02/06/2014:svnShuttleInc.:pnDS437T:pvrV1.0:rvnShuttleInc.:rnFS437T:rvr1.0:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: DS437T
dmi.product.version: V1.0
dmi.sys.vendor: Shuttle Inc.
---
AddonCompatCheckDisabled: False
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC1D0p: anders 4690 F...m pulseaudio
 /dev/snd/controlC1: anders 4690 F.... pulseaudio
 /dev/snd/controlC0: helen 2194 F.... pulseaudio
                      anders 4690 F.... pulseaudio
BuildID: 20180522092721
Channel: Unavailable
DistroRelease: Ubuntu 16.04
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
IpRoute:
 default via 192.168.1.1 dev p3p1 proto static metric 100
 169.254.0.0/16 dev p3p1 scope link metric 1000
 192.168.1.0/24 dev p3p1 proto kernel scope link src 192.168.1.13 metric 100
Locales: extensions.sqlite corrupt or missing
MostRecentCrashID: bp-6290ed11-55d4-493f-83a5-25c080180222
Package: thunderbird 1:52.8.0+build1-0ubuntu0.16.04.1
PackageArchitecture: amd64
Plugins: Shockwave Flash - /usr/lib/adobe-flashplugin/libflashplayer.so (adobe-flashplugin)
ProcEnviron:
 LANGUAGE=sv_SE
 TERM=xterm
 PATH=(custom, no user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 4.4.0-128.154-generic 4.4.131
Profiles: Profile0 (Default) - LastVersion=52.8.0/20180522092721 (In use)
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: Home directory not accessible: Permission denied
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions: adobe-flashplugin 1:20180607.1-0ubuntu0.16.04.1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: yes
  Hard blocked: no
RunningIncompatibleAddons: False
SubmittedCrashIDs:
 bp-6290ed11-55d4-493f-83a5-25c080180222
 bp-4bacd9d1-b4cc-46aa-8418-a1c590170628
 bp-ab291a27-7cc9-44ce-8159-315ab0170602
 bp-4a972d4c-97c3-4487-a40e-380872150720
Tags: xenial
Themes: extensions.sqlite corrupt or missing
Uname: Linux 4.4.0-128-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

_MarkForUpload: True
dmi.bios.date: 02/06/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.02
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: FS437T
dmi.board.vendor: Shuttle Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 10
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.02:bd02/06/2014:svnShuttleInc.:pnDS437T:pvrV1.0:rvnShuttleInc.:rnFS437T:rvr1.0:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
dmi.product.name: DS437T
dmi.product.version: V1.0
dmi.sys.vendor: Shuttle Inc.

Anders Sjögren (anders-i) wrote :
gf (gf-interlinks) wrote :

Hello Anders,
Thank you for submitting this bug and reporting a problem with Thunderbird. You made this bug report in 2015 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you run the following (only once):
apport-collect BUGNUMBER
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.
G

Changed in thunderbird (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected xenial
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Hi G,

I am afraid the problem remains and happens about as often as two years ago.
Furthermore, a very similar issue happens more seldom with Mozilla
Firefox, which I sometimes have to restart to be able to enter text into
any field.
I have uploaded the data. Cool feature!
Thanks for your support!

/Anders

On 2018-07-12 15:29, gf wrote:
> Hello Anders,
> Thank you for submitting this bug and reporting a problem with Thunderbird. You made this bug report in 2015 and there have been several versions of Ubuntu and Thunderbird since then.
>
> Could you confirm that this is no longer a problem and that we can close the ticket?
> If it is still a problem, are you still interested in finding a solution to this bug?
> If you are, could you run the following (only once):
> apport-collect BUGNUMBER
> and upload the updated logs and and any other logs that are relevant for this particular issue.
>
> Thank you again for helping make Ubuntu and Thunderbird better.
> G
>
>
> ** Changed in: thunderbird (Ubuntu)
> Status: New => Incomplete
>

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

To post a comment you must log in.