Thunderbird doesn't use Ubuntu icon theme

Bug #135066 reported by Hanno on 2007-08-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mozilla-thunderbird

Thunderbird 2's icon theme is quite different to 1.5 and doesn't blend well with Ubuntu's default theme. These icons look very different to Evolution's icons for the same tasks.

It would be nice if Thunderbird was more integrated with Ubuntu's visual theme or even able to use the system's icon theme.

Thanks!

Hanno (hzulla) wrote :

Thunderbird's theme, as currently found in Gutsy (August 27, 07)

Hanno (hzulla) wrote :

Evolution's icons for the same tasks look quite different.

Hanno (hzulla) wrote :

Evolution and Nautilus both use the system's icon theme, Thunderbird does not.

Hanno (hzulla) wrote :

Just as an example, compare Evolution and Thunderbird icons for "reply", "forward" or "new message" and compare the folder icons.

Changed in mozilla-thunderbird:
assignee: nobody → mozilla-bugs
importance: Undecided → Wishlist
Micah Gersten (micahg) wrote :

Moved to thunderbird package as mozilla-thunderbird is for 1.5 only.

affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)

I'm fairly sure mozilla won't allow Ubuntu to distribute thunderbird with Ubuntu icons and still call it Thunderbird, so I'm going to tentatively mark it "won't fix". If the mozilla team feels otherwise, please reopen this bug.

Changed in thunderbird (Ubuntu):
status: New → Won't Fix
Hanno (hzulla) wrote :

Ubuntu's Firefox package is also distributed with a Tango-based theme, activated by default, which looks rather different to the default Firefox GUI.

So why should they mind if Ubuntu does the same for Thunderbird?

Changed in thunderbird (Ubuntu):
status: Won't Fix → New
Hanno (hzulla) wrote :

There are three theme packages for Thunderbird that might apply, but all of them are outdated and need some work:

https://addons.mozilla.org/de/thunderbird/addon/3946

https://addons.mozilla.org/de/thunderbird/addon/2258
https://addons.mozilla.org/de/thunderbird/addon/9458

Hanno (hzulla) wrote :

Ok, just realized after a quick test:

Firefox adheres to GTK icon sets (and thus changes its icon theme with the GTK theme), but Thunderbird does not.

Therefore, Thunderbird doesn't need a Human/Tango theme package, but "simply" needs to follow the same GTK theme settings that Firefox already does.

John Vivirito (gnomefreak) wrote :

Sarah was correct. To use official icons we have to keep official branding all over the app icons, naming, ect...
Mozilla packages not using system wide GTK is another bug and has been reported in LP and upstream

Changed in thunderbird (Ubuntu):
status: New → Won't Fix
John Vivirito (gnomefreak) wrote :

see what upstream does

Changed in thunderbird (Ubuntu):
assignee: Mozilla Bugs (mozilla-bugs) → nobody
status: Won't Fix → Incomplete
Changed in thunderbird:
status: Unknown → New

Even though we're going to alter the main toolbar layout in TB3, we still need to provide new linux icons for those who wish to customize the toolbar.
This bug is to track those icon fixes.

Created an attachment (id=384835)
new icons and css

Stuff done in this patch:
* Reordered the entrys to match the imagemap.
* Changed a bunch of things to use GTK+ stock icons instead.
* Put those at the end.

Did you check the address book toolbar? I thought it used the image mapped toolbar for some icons...

Could you include the archive icon too? (bug 480470) I can take care of hooking it up.

*** Bug 494666 has been marked as a duplicate of this bug. ***

Changed in thunderbird:
status: New → Invalid

Created an attachment (id=385067)
updated patch with archive icon

No css for archive included here though, as I wasn't sure what class or id it should be.

We should really try to get this in for b3, as otherwise the toolbar stands out as non-tango...

(From update of attachment 385067)
I just tried it out, and it looks very good to me!

(From update of attachment 385067)
i didn't get a chance to try this out so I'll just trust that it rocks :)

Micah Gersten (micahg) wrote :

Upstream is marked as a duplicate. Adding new bug.

Changed in thunderbird:
status: Invalid → Unknown
Micah Gersten (micahg) wrote :

This was fixed upstream. Marking triaged pending release of Thunderbird 3 in Ubuntu.

Changed in thunderbird (Ubuntu):
status: Incomplete → Triaged
Changed in thunderbird:
milestone: none → 3.0
Changed in thunderbird:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.