moztraybiff (tray icon enabler extension) doesn't work in gutsy version of thunderbird 2

Bug #133171 reported by Fabien Lusseau
4
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
High
Alexander Sack

Bug Description

Binary package hint: mozilla-thunderbird

I have tested with the official release of thunderbird 2 and it work perfectly ...

But the ubuntu gutsy release it doesn't work at all

The only difference that i have show in gutsy's version is that he is linked with libstdc++6 and the official with libstdc++5 .

I think that he have no incidences ...

link with the extension website: http://moztraybiff.mozdev.org/

Related branches

Revision history for this message
Fabien Lusseau (fabien-beosfrance) wrote :

When i install libnspr-dev this extension work. can you add this dependence in the thunderbird packages (it is not a very big package and it solve all problems with pre compiled thunderbird extensions ...)

Revision history for this message
mikkael (mikkael) wrote :

same here, its not working.

there is no package called libnspr-dev
installing libnspr4-dev did not help.

im on kubuntu

Revision history for this message
Fabien Lusseau (fabien-beosfrance) wrote : Re: [Bug 133171] Re: moztraybiff (tray icon enabler extension) doesn't work in gutsy version of thunderbird 2

Yes installing libnspr4-dev correct this problem but you have to remove
your current thunderbird profile to make it work ...(or reinstall
moztraybiff but i haven't tested ...)

mikkael a écrit :
> same here, its not working.
>
> there is no package called libnspr-dev
> installing libnspr4-dev did not help.
>
> im on kubuntu
>
>

Revision history for this message
mikkael (mikkael) wrote :

ok, this works. thanks a lot

Revision history for this message
Fabien Lusseau (fabien-beosfrance) wrote :

No problems it is a pleasure, I think this packages have to become a
dependency of thunderbird, it is a very big problem ...

mikkael a écrit :
> ok, this works. thanks a lot
>
>

Revision history for this message
Alexander Sack (asac) wrote :

If installing those -dev packages really helped, then thunderbird should install compatibility links for libnspr4.so and libnss3.so in $pkglibdir (like firefox already does). bumping importance of this bug and targetting it for beta.

Thanks,
  - Alexander

Changed in mozilla-thunderbird:
assignee: nobody → asac
importance: Undecided → High
status: New → Triaged
Alexander Sack (asac)
Changed in mozilla-thunderbird:
status: Triaged → In Progress
Revision history for this message
Robert Hrovat (robi-hipnos) wrote :

It seems you don't need to remove current TB profile. Reinstalling moztraybiff extension made it work again.
Thanks for the tip, I really missed that one.

Revision history for this message
Alexander Sack (asac) wrote :

fix uploaded. now waiting for approval from release manager.

Changed in thunderbird:
status: In Progress → Fix Committed
Revision history for this message
Alexander Sack (asac) wrote :

thunderbird (2.0.0.6-0ubuntu4) gutsy; urgency=low

  * debian/thunderbird.links: install upstream-compatibility links to
    system nss3 and nspr4 files (LP: #133171).

 -- Alexander Sack <email address hidden> Mon, 24 Sep 2007 10:58:41 +0200

Changed in thunderbird:
status: Fix Committed → Fix Released
Revision history for this message
Fabien Lusseau (fabien-beosfrance) wrote :

Yes it work thank you :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers