Thunderbird uses ISO 8859-1 by default instead of UTF-8.

Bug #1296759 reported by Mikaela Suomalainen on 2014-03-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Now it's year 2014 and all chars should be available for everyone.

UTF-8 is available as option in GMail https://support.google.com/mail/answer/22841 and it should be working for everyone. UTF-8 is also the default character encoding in Python 3 and I believe that all Linux distributions including *Ubuntu have used it as default for years, so why Thunderbird isn't?

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: thunderbird 1:24.4.0+build1-0ubuntu0.13.10.2
ProcVersionSignature: Ubuntu 3.11.0-18.32-generic 3.11.10.4
Uname: Linux 3.11.0-18-generic x86_64
NonfreeKernelModules: nvidia
AddonCompatCheckDisabled: False
ApportVersion: 2.12.5-0ubuntu2.2
Architecture: amd64
AudioDevicesInUse:
 KÄYTTÄJÄ PID ACCESS KÄSKY
 /dev/snd/controlC1: mikaela 1855 F.... pulseaudio
 /dev/snd/controlC0: mikaela 1855 F.... pulseaudio
 /dev/snd/pcmC0D0p: mikaela 1855 F...m pulseaudio
BuildID: 20140318002531
CRDA: Error: [Errno 2] Tiedostoa tai hakemistoa ei ole: 'iw'
Channel: Unavailable
Date: Mon Mar 24 16:31:36 2014
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-02-01 (51 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
IpRoute:
 default via 10.0.0.1 dev eth0 proto static
 10.0.0.0/8 dev eth0 proto kernel scope link src 10.255.255.1 metric 1
 10.0.0.0/8 dev wlan0 proto kernel scope link src 10.255.255.4 metric 9
MarkForUpload: True
PrefSources:
 prefs.js
 /usr/lib/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults/preferences/enigmail.js
 /usr/lib/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults/preferences/000system.js
Profiles: Profile0 (Default) - LastVersion=24.4.0/20140318002531 (In use)
RelatedPackageVersions: gecko-mediaplayer 1.0.8-4ubuntu1
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/11/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0504
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: CM6330_CM6630_CM6730_CM6830
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev x.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0504:bd12/11/2012:svnASUSTeKComputerINC.:pnCM6330_CM6630_CM6730_CM6830-8:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnCM6330_CM6630_CM6730_CM6830:rvrRevx.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: CM6330_CM6630_CM6730_CM6830-8
dmi.product.version: System Version
dmi.sys.vendor: ASUSTeK Computer INC.

Mikaela Suomalainen (mikaela) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers