thunderbird handles mailto: links incorrectly, generates wrong receipient address

Bug #1288418 reported by Daniel Kessel on 2014-03-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
High
Unassigned

Bug Description

Tested under xubuntu trusty daily. Not sure if the bug is in the chromium package or in thunderbird...

Thunderbird handles mailto: links correctly. I opened a link in chromium, and that caused the creation of a mail with "mailto:<email address hidden>" as the recipient. That is an error, and sending such a mail will always fail.

The user will have to manually check recipient addresses to avoid this issue.

I performed a package test from the QA tracker:
http://packages.qa.ubuntu.com/qatracker/milestones/306/builds/55990/testcases/1496/

Test-case name: thunderbird/tb-005
This test will check that Thunderbird can send messages using mailto: links found on web sites

Clicking here should open a new email in Thunderbird with <email address hidden> as the recipient.
Clicking here should open a new email in Thunderbird with <email address hidden> as the recipient and "Just Testing" as the subject
Clicking here should open a new email in Thunderbird with <email address hidden> as the recipient, "Just Testing" as the Subject and should put two lines of text in the email body.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: thunderbird 1:24.2.0+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-12.32-generic 3.13.4
Uname: Linux 3.13.0-12-generic i686
NonfreeKernelModules: wl
AddonCompatCheckDisabled: False
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: daniel 1483 F.... pulseaudio
BuildID: 20131206222113
Channel: Unavailable
CurrentDesktop: XFCE
Date: Wed Mar 5 22:12:38 2014
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2014-02-26 (6 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140225)
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.212 metric 9
Plugins: Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=24.2.0/20131206222113 (In use)
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/29/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/29/2009:svnDellInc.:pnInspiron1011:pvrA06:rvnDellInc.:rnCN0Y53:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: Inspiron 1011
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.

Daniel Kessel (dkessel) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1288418

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Changed in thunderbird (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers