thunderbird doesn't remember maximized window state in Ubuntu Gnome

Bug #1265898 reported by Tobiasz Jarczyk on 2014-01-03
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Confirmed
Medium
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Not sure if this is thunderbird or gnome-shell related issue.

Steps to reproduce:
1. Run thunderbird.
2. Maximize thunderbird window.
3. Close thunderbird.
4. Run thunderbird again.
5. Notice that thunderbird window is not maximized - maximized window state was not saved during closing.

Expected behaviour:
In 5. thudnderbird window is open in maximized state.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: thunderbird 1:24.2.0+build1-0ubuntu1
Uname: Linux 3.13.0-031300rc6-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.12.7-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dotnokato 1431 F.... pulseaudio
 /dev/snd/pcmC0D0p: dotnokato 1431 F...m pulseaudio
BuildID: 20131206222054
Channel: Unavailable
CurrentDesktop: GNOME
Date: Fri Jan 3 21:02:28 2014
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-10-15 (79 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release amd64 (20131015)
IpRoute:
 default via 10.100.10.1 dev eth0 proto static
 10.100.10.0/24 dev eth0 proto kernel scope link src 10.100.10.8 metric 1
 10.100.10.0/24 dev wlan0 proto kernel scope link src 10.100.10.12 metric 9
Plugins:
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
 Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
 Gnome Shell Integration - /usr/lib/mozilla/plugins/libgnome-shell-browser-plugin.so (gnome-shell)
PrefSources:
 prefs.js
 [Profile]/<email address hidden>/defaults/preferences/gnomeintegration.js
Profiles: Profile0 (Default) - LastVersion=24.2.0/20131206222054 (In use)
RelatedPackageVersions:
 rhythmbox-mozilla 3.0.1-1ubuntu8
 gnome-shell 3.8.4-0ubuntu6
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: Upgraded to trusty on 2013-11-05 (59 days ago)
dmi.bios.date: 05/08/2007
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68TT2 Ver. F.07
dmi.board.name: 30B0
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 40.15
dmi.chassis.asset.tag: CNU7110B09
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68TT2Ver.F.07:bd05/08/2007:svnHewlett-Packard:pnHPCompaqnx6325(EY349EA#AKD):pvrF.07:rvnHewlett-Packard:rn30B0:rvrKBCVersion40.15:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Compaq nx6325 (EY349EA#AKD)
dmi.product.version: F.07
dmi.sys.vendor: Hewlett-Packard

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20100101 Firefox/10.0.2 Iceweasel/10.0.2
Build ID: 20120217174734

Steps to reproduce:

I open thunderbird (for me icedove on debian) and I maximize the window by dragging it to the top (gnome-shell). Then I close thunderbird.

Actual results:

When I start again thunderbird, it does not start in a maximized size but only covers 75% of my screen (like at the first start).

Expected results:

Thunderbird should remember and starts with a maximized window. This problem occurs also when I maximize with the button (if I add a maximized button to windows in gnome-shell with gnome-tweak-tool).

(In reply to ppr from comment #0)
See solution here: http://kb.mozillazine.org/Localstore.rdf

Thanks
To force creation of a new file localstore.rdf with:

mv ~/.icedove/XXXXX(profile)/localstore.rdf ~/.icedove/XXXXX(profile)/localstore-old.rdf

(put .thunderbird instead of .icedove if you are not using debian)

seems to work. At the first startup of thunderbird/icedove I maximized the window and closed with CTRL+Q and the window starts maximized after that.

In fact, the solution of comment #2 only works if I close thunderbird with Ctrl+Q. If I close it with Alt+F4 with the X button, thunderbird will start not-maximized.

(In reply to ppr from comment #3)
> In fact, the solution of comment #2 only works if I close thunderbird with
> Ctrl+Q. If I close it with Alt+F4 with the X button, thunderbird will start
> not-maximized.

So can we consider your issue solved?

delete ~/.icedove/XXXXX(profile)/localstore.rdf is a workaround and I don't know what was the problem in this file at the first time.

want to attach the file to the bug ?

Created attachment 603756
file localstore.rdf

File attached, could someone try to recreate the bug with this file?

(In reply to ppr from comment #8)
> File attached, could someone try to recreate the bug with this file?

I tried it and with a monitor resolution of 1366*768 it starts occupying around 75% of the screen.
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0.2) Gecko/20120216 Thunderbird/10.0.2
Application Build ID: 20120216022139

Tobiasz Jarczyk (dotnokato-q) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Tobiasz Jarczyk (dotnokato-q) wrote :

Reading comments in https://bugzilla.mozilla.org/show_bug.cgi?id=732812 I've found that the workaround for this bug is to close thunderbird with Ctrl+Q - this saves window maximized state.

Tobiasz Jarczyk (dotnokato-q) wrote :

Of course, if for the next time, I close the thunderbird in any other way than Ctrl + Q the issue appears once again - the window maximized state is not remembered.

Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Low: Minor, with easy work around.

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
Frank Cizmich (frank-cizmich) wrote :
Frank Cizmich (frank-cizmich) wrote :

Same problem but can't solve with workaround mentioned here.
Ubuntu12.04
Thunderbird 31.0
Attached localstore.rdf that gets recreated after each time I erase it.

Not a big deal but annoying :-)

St Weiss (stweiss) wrote :

Problem still exists in Kubuntu 15.10.
Deleting localstore.rdf does not work, with or without exiting with Ctrl-Q.

This problem seems to occur on Mint 18 Cinnamon too (unless an extension is causing it).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.