Ubuntu

Non-Thunderbird IMAP folders not visible to Thunderbird

Reported by Lars Noodén on 2007-06-27
6
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Wishlist
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mozilla-thunderbird

I have several pre-existing IMAP folders created by Pine in an account. Thunderbird does not seem to find or display these folders or their contents.

However, if I create a new folder using Thunderbird on that account, Pine can see it immediately and transfer messages to/from that folder.

the folders can be found by "subscribing" but the term doesn't make sense to me

IMAP is now enabled for Gmail. Actually when you add a new account it's possible to select Gmail but all predefined settings are for POP access. If I want to add IMAP access I need to go through 'Email account'

Steps to reproduce:
1 Enable IMAP in your Gmail account.
2 Open Thunderbird, and select Tools > Account Settings.
3 Click Add Account.
4 Select the Email account radio button and click Next. The Identity screen appears.
5 Enter your full name in the Your Name field. Enter your full Gmail email address (<email address hidden>) in the Email Address field, and click Next.
6 Select IMAP as the type of incoming server you are using. Enter imap.gmail.com in the Incoming Server field.
etc.

Expected result:
Just select Tools > Account Settings > Add Account > Gmail and then select IMAP or POP access

*** Bug 400978 has been marked as a duplicate of this bug. ***

I would even go further and suggest that IMAP be promoted as a better default than POP.

Furthermore, this should also set the locations for special folders (Drafts, Deleted, Sent).

In the case of sent mail, I believe IMAP should only be used to store a copy if the user is NOT using Google's SMTP server (which does it for you). For example, I have to use my home ISP's SMTP server, so I do need to record sent mail by recording a copy with IMAP.

not to forget the Trash folder as well. See:

http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php

However, in my opinion the amateur end-users won't know what SMTP servers are, much less set them to something else. So since the wizard is meant to be as user-friendly as possible, maybe the default Gmail settings should still be set.

And there should be a list of notes somewhere on Google which says what IMAP features Gmail doesn't support.

Found it:
http://mail.google.com/support/bin/answer.py?answer=78761&topic=12762

Trash folder bug entry would be:

Bug 182274

Adding the Gmail IMAP issues meta bug as dependency. Before we enable Gmail imap we should probably wait a bit until at least the most serious of them are fixed. (It's mostly server bugs in the end I think.)

Created an attachment (id=288165)
proposed fix (WIP)

This adds the Gamil IMAP option to the list.

(From update of attachment 288165)
>+ <NC:trashFolderName>[Gmail]/Trash</NC:trashFolderName>

I'm still on the fence about it, but according to (around the middle of) http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php Gmail's opinion is that using [Gmail]/Trash as the trash folder isn't a good idea.

Yeah, still some stuff to figure out here. Ideally, and given the model they use, I would have expected mails that get marked as deleted to show up in Trash when they are "deleted" from the last "folder". Then just using the "Remove them immediately" option would have worked quite nicely.

International folder names could also cause some small trouble, but as I understand it only (part of) those with english gmail UI have IMAP access at this point.

(In reply to comment #9)
> International folder names could also cause some small trouble, but as I
> understand it only (part of) those with english gmail UI have IMAP access at
> this point.

You only need the english UI to enable IMAP. After that one can switch back to german or whatever. But then the Folder names are [Google Mail]/Papierkorb depending on the locale.
The settings wizard should also handle the difference between gmail.com and googlemail.com, because both the server and the IMAP Folder names need to be changed.

I believe we should default the Gimap delete setting to 'Remove immediately'.

It is probably best to default the Drafts folder to the 'Local Folders' account, because of bug #402132, at least until Google provides either UIDPLUS or search by Message-ID.

In , Ffes (ffes) wrote :

Isn't this related to bug #182274?

yes Imap tends to be a bit nicer than pop by default pop marks all msgs read if you have leave on server most newbs wont set this also imap tends to be handier in roaming and or dual boot I/E Linux / Windoze and or multiple machines.

with pop owning multiple machines and having to run slow sync software can be a royal pain , and if you use the web ui for while your at a work pc no biggy all your read or unread stay synced and folders on desktop laptop and web stay nice nice , and linux dosent thunderbird and windows thunderbird dosent become a blackhole like pop mail can

anyhow it'd be a royal plus to explit the hell out of imap since it always has ben better then pop but in the past a bit slow due to the bandwith but with hi speed so pervasive thease days the few extra secouds is priceless for all the system bouncing a IT security admin like myself dose . in the end imap saves me countless hours.

(In reply to comment #11)
> It is probably best to default the Drafts folder to the 'Local Folders' account,
> because of bug #402132, at least until Google provides either UIDPLUS or search by Message-ID.

FYI.
"search by Message-ID" problem seems to have been fixed by Gmail IMAP.
See Bug 402132 Comment #16 on 2007-12-08.

Another recommendation I'd like to make is to default the [Gmail]/Spam folder, [Gmail]/Sent Mail folder and [Gmail]/Drafts folder to be the defaults for Thunderbird's Junk, Sent and Drafts folders, respectively.

Marcus Asshauer (mcas) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in mozilla-thunderbird:
status: New → Incomplete

I would not favor defaulting IMAP Gmail folders to T-bird folders. That sounds as if you are defeating the purpose of choosing IMAP over POP. IMAP allows for keeping multiple devices (desktop pc, portable pc, handhelds like smart phones, iphones, etc.) sync whereas POP doesn't.

(In reply to comment #15)
> Another recommendation I'd like to make is to default the [Gmail]/Spam folder,
> [Gmail]/Sent Mail folder and [Gmail]/Drafts folder to be the defaults for
> Thunderbird's Junk, Sent and Drafts folders, respectively.
>

I was not talking about making that the default for the global folders. What I meant was that, when setting up a GMail IMAP account, the account-specific options for Junk, Sent and Drafts should use [Gmail]/Spam, [Gmail]/Sent Mail and [Gmail]/Drafts so that these things would be automatically synced to any other client that was using Gmail IMAP. (Having access to all Sent Mail and Drafts on all machines is a godsend). I know that it is possible to configure this by hand, but I think that it should be the default in order to make configuration simpler for the average end-user.

OK, I understand you now.

(In reply to comment #17)
> I was not talking about making that the default for the global folders. What I
> meant was that, when setting up a GMail IMAP account, the account-specific
> options for Junk, Sent and Drafts should use [Gmail]/Spam, [Gmail]/Sent Mail
> and [Gmail]/Drafts so that these things would be automatically synced to any
> other client that was using Gmail IMAP. (Having access to all Sent Mail and
> Drafts on all machines is a godsend). I know that it is possible to configure
> this by hand, but I think that it should be the default in order to make
> configuration simpler for the average end-user.
>

Let me post here my thoughts.
Realistically, the IMAP interface for GMail is very different from a normal one.
It seems to me that ideal client behavior would be the following:

The spam filter be disable for just the Gmail account. For many people Google's own spam features are enough, and TB's on top of it just adds complication. Obviously it should be possible to use it if desired. Either which way, the "Junk" button in the interface should move the message to [Gmail]/Spam.
Ideally, when in the [Gmail]/Spam folder, the Not junk UI feature would be availible, which would IMAP "move" the message to the Inbox folder.

Sent mail should be copied to [Gmail]/Sent Mail only if the Gmail Smtp is not being used.

Draft messages should be saved to [Gmail]/Drafts, and messages in that folder should be recognised as drafts, allowing them to be open for continued editing.

All Special delete handling such as the keeping a local copy of deleted messages should be disabled. Those features really mess with GMail's IMAP features.
The button that sends the IMAP delete button should actually have several personas. When in the Inbox folder, it should be labeled "Archive", when in a tag folder, it should be labeled "Remove Tag", and when in the in the [gmail]/Trash or [gmail]/Spam folder it should be labled "Purge".

A new Interface button should be added labeled "Delete" that simply Does an IMAP move of the selected messages to [Gmail]/Trash. This button should be disabled in the [Gmail]/Trash folder and the [Gmail]/Spam folder.

Finally, a new interface button labled "Tag" should be added. When clicked it would display a list of the IMAP folders, possibly excluding the "[Gmail]/*" folders. Selecting a folder would result in an IMAP "move" of the selected message(s) to the chosen folder.

If all the above were done, the interface would be highly sensible and work well. (Except for errors on my part due to misunderstanding the gmail IMAP equivalency chart). as it stands right now, configuring Tb to do all those things is almost impossible. Some are easy enough to do, but others basically need extensions currently.

(In reply to comment #19)
> Finally, a new interface button labled "Tag" should be added. When clicked it
> would display a list of the IMAP folders, possibly excluding the "[Gmail]/*"
> folders. Selecting a folder would result in an IMAP "move" of the selected
> message(s) to the chosen folder.
That is a bad idea. Tags and folders are very different in Thunderbird. The intended use is, apparently, to provide an interface to move messages between user-label folders, but that already exists. Even if it is labelled "Label" to avoid confusion with tags, it does not provide any new function.

Thunderbird stores tags as IMAP flags on the message.

> All Special delete handling such as the keeping a local copy of deleted
> messages should be disabled. Those features really mess with GMail's IMAP
> features.
In other words, the default delete model should be "Remove immediately".

> The button that sends the IMAP delete button should actually have several
> personas. When in the Inbox folder, it should be labeled "Archive", when in a
> tag folder, it should be labeled "Remove Tag", and when in the in the
> [gmail]/Trash or [gmail]/Spam folder it should be labled "Purge".
I think all of this can be summarised by changing the Delete button label to "Remove", if the delete model is not "Move to Trash".

> A new Interface button should be added labeled "Delete" that simply Does an
> IMAP move of the selected messages to [Gmail]/Trash. This button should be
> disabled in the [Gmail]/Trash folder and the [Gmail]/Spam folder.
>
An interesting idea, but I think it would be better to allow an accelerator key to modify the delete model. E.g., holding down the 'Ctrl' key could force the "Move to Trash" action.

(In reply to comment #20)

>That is a bad idea. Tags and folders are very different in Thunderbird.
>The intended use is, apparently, to provide an interface to move messages
>between user-label folders, but that already exists. Even if it is
>labelled "Label" to avoid confusion with tags, it does not provide
>any new function.

Yes, but it makes one of the fundamental actions in the Gmail e-mail paradigm easier, and more noticeable. Despite the terminology conflict, any Gmail user will recognize the folders as being Gmail tags, and would be looking for a way to add tags or remove tags. At the very least, having some way to easily add what Gmail calls tags to a message would be quite desirable.

>In other words, the default delete model should be "Remove immediately".
Exactly.

>I think all of this can be summarised by changing the Delete button label
>to "Remove", if the delete model is not "Move to Trash".
That would work. I have a slight preference for the context sensitive labels, but that is just me.

>> A new Interface button should be added labeled "Delete" that simply Does an
>> IMAP move of the selected messages to [Gmail]/Trash. This button should be
>> disabled in the [Gmail]/Trash folder and the [Gmail]/Spam folder.
>>
>An interesting idea, but I think it would be better to allow an accelerator key
>to modify the delete model. E.g., holding down the 'Ctrl' key could force the
>"Move to Trash" action.
Reasonable enough. It may be nice if the label on the button changed while holding down 'ctrl' so people could have a chance to discover this feature without just hearing about it.

Did you have an comments on making the exisitng spam filter optional for Gmail. (Gmail's spam filters are so good, they are all most people would ever need, so the local one would probably just get in the way). Or about having the (un)mark as spam feature integrate with the Imap spam folder. (So there is a button that a user can push to easily let Gmail know a message is (not) spam).

What about my assessment of the sent items folder and drafts folder?

(In reply to comment #21)
To <email address hidden>:
Please don't confuse terms, and please don't misuse terms.
 (a) Gmail's term of "Label"(==Mail folder name/structure in Gmail IMAP)
 (b) Tb's term of "tag", which Gmail never uses, which is called "flag"
     or "keyword" in protcol definition of IMAP
 (c) Tb's term of "label" used before Thunderbird 2.0, which is called "tag"
     by Th 2.0 or after.

*** Bug 436233 has been marked as a duplicate of this bug. ***

Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!.

Changed in mozilla-thunderbird:
status: Incomplete → Invalid

The problem still exists in 8.04 I can go in with Pine and create a folder on the IMAP server. Then I can open Thunderbird and have to jump through the hoops above to find and use it. It's there, just that Thunderbird does not find it without help.

Lars Noodén (larsnooden) wrote :

Confirmed that the problem still exists in Thunderbird 2.0.0.14 (20080505) on Kubuntu 8.04

Changed in mozilla-thunderbird:
status: Invalid → Incomplete

Lars Noodén wrote:
> Confirmed that the problem still exists in Thunderbird 2.0.0.14
> (20080505) on Kubuntu 8.04
>
> ** Changed in: mozilla-thunderbird (Ubuntu)
> Status: Invalid => Incomplete
>
Here are steps that should help you. Can you please lists the steps you
have been using to attempt and is this a GMail IMAP account?
T this moment in time i don't have an IMAP account but i should have one
by end of day. I would prefer a free IMAP account but i can always hack
Gmail to use IMAP

1. you can use movemail
2. then you can probably specify that as the location
3. maybe you can even set a custom location for Mail for certain accounts

--
Sincerely Yours,
     John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

John Vivirito (gnomefreak) wrote :

Here is a post to clean up mistakes in last one.

> T this moment in time i don't have an IMAP account but i should have one
Should be
At this moment in time i don't have an IMAP account but i should have one

> 2. then you can probably specify that as the location
Should be:
2. then you can probably specify the location of the folders you want to add <Example would be ~/.Mail>

Lars Noodén (larsnooden) wrote :

I already have a work-around, that's not the issue. It's easy to use the normal IMAP account creation process to add a Gmail IMAP account.

The problem described in the bug report is that the Account Creation Wizard has an option for Gmail, but that Gmail choice is specifically missing the ability to create an IMAP account.

Lars Noodén (larsnooden) wrote :

Sorry for the above, I mixed bug reports.

Ok. To respond to this bug (#122529) it is possible to get the mail from the IMAP server, I just have to go and subscribe manually to each pre-existing IMAP folder:

Account Settings -> Manage Folder Subscriptions -> Subscribe

From there every thing with Thunderbird works as it should.

Lars Noodén wrote:
> Sorry for the above, I mixed bug reports.
>
Gmail doesnt support IMAP so you would have to talk to them about
supporting it.
As for Gmail choice not having an IMAP set up would be because Gmail
doesnt support it. Once they decide or are pushed to support IMAP there
isnt anything that can really be done. As i recall Mozilla decided to
have a Gmail option for Tbird-2 just to make it easier to add gmail
account. You can file or look for a bug upstream on this issue to see if
they will impletment this option. It would be nice to have but its
Google that needs to do the work. I doubt Moailla will do it without
Gmail first doing it. Please post upstream links here to we can track them.

--
Sincerely Yours,
     John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

John Vivirito (gnomefreak) wrote :

Lars Noodén wrote:
> Sorry for the above, I mixed bug reports.
>
Can you please give me the other bug repost so i can transfer what i
send to that bug to keep everything in order.

--
Sincerely Yours,
     John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

John Vivirito (gnomefreak) wrote :

That is not a bug but rather a setting that needed to be changed.
It doesnt have a good change of changing that from setting to default. You can either file/look for bug upstream at: https://bugzilla.mozilla.org/
I will leave this as incomplete until you have decided on what you would like to do but this isn't a Ubuntu change rather a Mozilla change. If you file or find a bug upstream please post the link here and we will decide if that is the exact issue as there may be 100 bugs close to your bug but not the same.

John Vivirito (gnomefreak) wrote :

Marked as a wishlist bug.

Changed in mozilla-thunderbird:
importance: Undecided → Wishlist
John Vivirito (gnomefreak) wrote :

Sorry about that i even got confused :( ok this is a setting not so much a bug. I am going to close this bug as its a feature more so than a bug. Can you please state how you would want it to work other than the setting you change. Please reopen when you have more info for this bug but as of right now there isnt any info saying this is a bug.

Changed in mozilla-thunderbird:
importance: Wishlist → Low
status: Incomplete → Invalid
Lars Noodén (larsnooden) wrote :

Hmm. I still see it as a bug, but am willing to call it something else as long as it gets solved.

I would like (and expect) that mailboxes/folders on the remote IMAP server show up (are subscribed) automatically in Thunderbird. It's bug in that I can create IMAP forlders using other clients and then none of these folders show up in Thunderbird...

John Vivirito (gnomefreak) wrote :

Lars Noodén wrote:
> Hmm. I still see it as a bug, but am willing to call it something else
> as long as it gets solved.
>
> I would like (and expect) that mailboxes/folders on the remote IMAP
> server show up (are subscribed) automatically in Thunderbird. It's bug
> in that I can create IMAP forlders using other clients and then none of
> these folders show up in Thunderbird...
>
Its seen as a wishlist because its a feature request more than a bug
since thunderbird never did what you want it to do so the only way is to
use movemail or change settings.
Since you were able to fix this due to settings that means that is the
way Mozilla wants you to do it. but for it to change it would need to be
found or filed upstream.

--
Sincerely Yours,
     John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Lars Noodén (larsnooden) wrote : OT

@john:

Gmail has supported IMAP as long as I have been using it. You may be thinking of MS Exchange which has problems with IMAP. Since you ask, here is the bug report for Gmail IMAP:

    https://bugzilla.mozilla.org/show_bug.cgi?id=436233

-> https://bugzilla.mozilla.org/show_bug.cgi?id=400931

And here are the instructions, not that they should be needed:
    http://mail.google.com/support/bin/answer.py?answer=77662

John Vivirito (gnomefreak) wrote :

Your correct sorry i was thinking of something else. I cant confirm if it was MS exchange since its been a while since i used it. Will change everything accordingly and add bug to track

Changed in mozilla-thunderbird:
importance: Low → Wishlist
status: Invalid → Confirmed
Lars Noodén (larsnooden) wrote :

Thanks. Gmail is being used increasingly, especially as a work-around to provide e-mail at sites where the official addresses are burdened by defective products used in place of an IMAP mail service.

So the corrected Account Wizard will be a help to many.

Changed in thunderbird:
status: Unknown → In Progress

How about combining GMAIL folders with Thunderbird tags in this way:
* Import GMAIL folders as Thunderbird tags
* When setting a tag in Thunderbird also do a IMAP move to corresponding folder in GMAIL (which would set the GMAIL tag on the message)
* If a message appear in a GMAIL folder also automatically apply the corresponding Thunderbird tag

Created an attachment (id=340788)
proposed fix, v2

In wait of the new account setup, here is an updated version. This patch
 - adds the Gmail IMAP option to the list of account types
 - makes it possible for ISPs to have several account types in a file - bug 65715

It
 - sets up drafts to be in [Gmail]/Drafts
 - uses IMAP delete model: "remove it (from view) immediately", but sets the predefined folder to [Gmail]/Trash for convenience if someone wants to change it
 - don't store a copy in Sent (since gmail takes care of that for you), but sets the sent mail folder to [Gmail]/Sent in case someone wants to change it

---

I don't know what's up with having to use <NC:FccFolder> and not <NC:fccFolder>... but this way it works.

(From update of attachment 340788)
this looks OK, thx, Magnus.

changeset: 530:def009b7345c
http://hg.mozilla.org/comm-central/rev/def009b7345c

->FIXED

I don't have access to a google mail account, so I hope someone who does can verify that it works. (It's the same settings as gmail, only replacing gmail with googlemail.)

Changed in thunderbird:
status: In Progress → Fix Released
Micah Gersten (micahg) wrote :

This is now working in the latest Thunderbird 3 beta. Please report any other bugs you may find. You can test the latest Thunderbird 3 beta here:
https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa

A word of caution, that this is still beta software and you might encounter bugs.

Changed in mozilla-thunderbird (Ubuntu):
status: Confirmed → Fix Released
Micah Gersten (micahg) wrote :

I made an error, this should remain Triaged as it has not been released in Ubuntu yet.

affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)
Changed in thunderbird (Ubuntu):
status: Fix Released → Triaged
Micah Gersten (micahg) on 2009-12-14
Changed in thunderbird:
milestone: none → 3.0
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.