thunderbird crashes at startup

Bug #1187724 reported by Tim Watts on 2013-06-05

This bug report will be marked for expiration in 6 days if no further activity occurs. (find out why)

12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

This is repeatible.

thunderbird --safe-mode also crashes

Removing ~.thunderbird/ does not fix the problem.

Running thunderbird as another user (different home directory, user never ran thunderbird before) DOES fix the problem and thunderbird starts normally.

Clearly there is something about my user environment which is crashing thunderbird - but it is also a bug in thunderbird (it should not crash).

I have tried removing gconf settings too - but that made no difference.

Next step suggestions would be welcome!

Cheers

Tim

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: thunderbird 17.0.6+build1-0ubuntu0.13.04.1
ProcVersionSignature: Ubuntu 3.8.0-21.32-generic 3.8.8
Uname: Linux 3.8.0-21-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: twatts 1920 F.... pulseaudio
BuildID: 20130510125337
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Channel: Unavailable
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
Date: Wed Jun 5 11:24:25 2013
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-04-26 (39 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
IpRoute:
 default via 137.73.122.1 dev eth0 proto static
 137.73.122.0/24 dev eth0 proto kernel scope link src 137.73.122.214 metric 1
 169.254.0.0/16 dev eth0 scope link metric 1000
IwConfig:
 eth0 no wireless extensions.

 lo no wireless extensions.
MarkForUpload: True
NoProfiles: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
RfKill:

RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:

dmi.bios.date: 07/31/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 0F428D
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 3
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd07/31/2009:svnDellInc.:pnOptiPlex960:pvr:rvnDellInc.:rn0F428D:rvrA00:cvnDellInc.:ct3:cvr:
dmi.product.name: OptiPlex 960
dmi.sys.vendor: Dell Inc.

Tim Watts (tw-dionic) wrote :
Tim Watts (tw-dionic) wrote :

Today I tried something new:

Log out and back into X.

Kill all processes that I owned except X server and terminal (so killed dbus, gconfd and all manner of things).
mv'ed my *entire* home directory into a subdir called TEMP/ taking care to include all .xxxx (DOT) subdirs

Started thunderbird - it still crashed!

And yet, it runs fine as another user displaying on my X server.

This is weird - the only context left for it is my UID, groups and envvars. And none of them are that weird.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Christian Renaux (kortak) wrote :

Hi,

I have exactly the same problem i Ubuntu 13.04 after upgrade and tried what you have done with the same results. So I am quite desperate as I want all my emails back with all the folders. I have been able to retrieve my Inbox in "Evolution" but not my folders.

So does anybody has an idea ?

Cheers.

Tim Watts (tw-dionic) wrote :

Finally - I have the solution (at least for me!).

We are using LDAP for user accounts via pam_ldap.

I did not have nscd (name service cache daemon) installed. Although it makes no difference to anything else, I did try installing it and
bingo! thunderbird works again.

This is still clearly a bug - but at least I have a workaround.

Could this be your problem too Christian?

Cheers,

Tim

Christian Renaux (kortak) wrote :

Hi Tim,

Thank you very much for your fast answer, I didn't see it until yesterday as I did not receive any notification.

Thus, I tried your solution and I can't tell how happy I am as it works perfectly well now with the installation of "nscd". We are using also an LDAP server through pam_ldap.

I hope this bug will be resolved for other users, as it was not so easy to find this thread...and so the solution.

Again thank you for your help,
Christian.

Changed in thunderbird (Ubuntu):
status: Confirmed → New
status: New → Confirmed
Paul White (paulw2u) wrote :

Is this still an issue for anyone now that Thunderbird 60.5.1 is the currently supported version?

Changed in thunderbird (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers