thunderbird changes character encoding of message when signing

Bug #1104124 reported by Santiago Roland on 2013-01-24
This bug affects 6 people
Affects Status Importance Assigned to Milestone
enigmail (Ubuntu)
thunderbird (Ubuntu)

Bug Description

When composing a message, everything is fine. I write some text like this one:
Este mensaje te llega bien? o te llega con los tíldes mal?
árbol, verán.... mádre que lo parió... :)

Then when i hit send, it signs the message and sets up the ASCII markings ---- BEGIN OF PGP SIGNED MESSAJE ----- and so... and then the body of the message transforms to this one.

Este mensaje te llega bien? o te llega con los t■ldes mal?
£rbol, ver£n.... m£dre que lo pari￳...)

Is this a bug? When i send this message it appears fine in the Sent folder... and i tried to send messages for myself and in thunderbird it looks allright too. But i send to my wife that she use Evolution mail and it shows with the strange characters. The same characters that Thunderbird shows when it is signing the message.

Any ideas?

Best Regards,

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 17.0.2+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: fglrx
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
BuildID: 20130106044124
 Card hw:0 'SB'/'HDA ATI SB at 0xfeb00000 irq 16'
   Mixer name : 'Realtek ALC892'
   Components : 'HDA:10ec0892,10438410,00100302'
   Controls : 44
   Simple ctrls : 21
 Card hw:1 'U0x46d0x991'/'USB Device 0x46d:0x991 at usb-0000:00:13.2-2, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:0991'
   Controls : 2
   Simple ctrls : 1
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 8
   Mono: Capture 6 [75%] [27.00dB] [off]
 Card hw:2 'Generic'/'HD-Audio Generic at 0xfea40000 irq 89'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 6
   Simple ctrls : 1
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: Unavailable
Date: Thu Jan 24 12:53:53 2013
ForcedLayersAccel: False
 auto lo
 iface lo inet loopback
InstallationMedia: Xubuntu 12.04 "Precise Pangolin" - Beta amd64 (20120228)
 default via dev wlan0 proto static dev wlan0 scope link metric 1000 dev wlan0 proto kernel scope link src metric 2
MarkForUpload: True
 Shockwave Flash - /usr/lib/flashplugin-installer/
 IcedTea-Web Plugin (using IcedTea-Web 1.2 (1.2-2ubuntu1.3)) - /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/ (icedtea-7-plugin)
 PATH=(custom, no user)
Profiles: Profile0 (Default) - LastVersion=17.0.2/20130106044124 (In use)
RelatedPackageVersions: icedtea-7-plugin 1.2-2ubuntu1.3
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
 Jan 24 12:40:33 bulldozer NetworkManager[1194]: <info> (wlan0): supplicant interface state: completed -> 4-way handshake
 Jan 24 12:40:34 bulldozer wpa_supplicant[1264]: WPA: Key negotiation completed with 50:67:f0:92:d3:a0 [PTK=CCMP GTK=CCMP]
 Jan 24 12:40:34 bulldozer NetworkManager[1194]: <info> (wlan0): supplicant interface state: 4-way handshake -> completed
 Jan 24 12:40:36 bulldozer wpa_supplicant[1264]: WPA: Group rekeying completed with 50:67:f0:92:d3:a0 [GTK=CCMP]
 Jan 24 12:40:37 bulldozer wpa_supplicant[1264]: WPA: Group rekeying completed with 50:67:f0:92:d3:a0 [GTK=CCMP] 12/02/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0901
dmi.board.asset.tag: To be filled by O.E.M. M5A99X EVO
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0901:bd12/02/2011:svnTobefilledbyO.E.M.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnASUSTeKCOMPUTERINC.:rnM5A99XEVO:rvrRev1.xx:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.: To be filled by O.E.M.
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: To be filled by O.E.M.

affects: thunderbird (Ubuntu) → enigmail (Ubuntu)

I can confirm the bug is in Enigmail, because sending the same message without signing, the character encoding is the correct one. Also i confirmed that Evolution is not mis-reading the mail. I sent a mail from k-9 mail client from my android ICS tablet signed with the same private key and Evolution reads the message fine.

In Evolution, btw, the message footer says "Key is not Valid" and my wife kave my public key in seahorse, that confirms that Enigmail is messing up with the keys. The same signed message sent from k-9 says "Key Valid" in the message footer.

Isn't this a security issue? i'll mark like one.

Best regards.

This is a security issue?

This is a message in my Sent folder. It appears to have a not valid signature, crazy because i send it. Instead of the strange characters it should be the "áéíóú" string with tildes.


Tried to reinstall Enigmail but no luck

Ok, i solved the issue going to Edit > Preferences > Display: under Fonts > Advanced and there was Western ISO .. and UTF-8 encodings in outgoing and incoming. The issue still in the sense that you actually can set up UTF-8 encoding when composing messages and when hit send, Thunderbird changes the encoding to Western and the spanish tildes go bananas and the PGP sign gives a different hash that the one that was calculated in UTF-8 ebcoding. This is still an issue because when you change encoding for a particular message, the above setting overrides it and messes up with the PGP sign validity.


Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in enigmail (Ubuntu):
status: New → Confirmed
Philipp Gassmann (phiphi.g) wrote :

Upstream Bug: Bad charset encoding when reply to GPG Signed message
(Sourceforge Bugtracker not supported by launchpad)

Patrick Brunschwig (patrick-u) wrote :

The correct upstream bug is (character encoding glitch), which has been fixed. Even though bug 54 carries a similar title, it covers a different issue.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed

Already fixed in version 1.5.1

Changed in enigmail (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.