Turn on full headers or long To: list and there is no scroll bar

Bug #1084 reported by Paul O'Malley on 2005-06-19
72
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Low
SeaMonkey
Invalid
Undecided
Unassigned
mozilla-thunderbird (Debian)
Invalid
Undecided
Unassigned
thunderbird (Ubuntu)
Medium
Unassigned

Bug Description

When full headers are turned on, or if long to: and cc: lists are expanded there is no scroll bar

User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/85.7 (KHTML, like Gecko) Safari/85.5
Build Identifier: thuderbird 20031013

sometimes a mail header has a lot of lines, many more than can fit into the window currently
showing the mail headers (when you do a view all headers).
the problem is there is no way to scroll down the headers to see them all, and sometimes even
maximizing the window doesn't show them all.
can you add a scrollbar to this area?

Reproducible: Always

Steps to Reproduce:
1. find an email with a lot of headers
2. view all headers
3. you can't see them all

Expected Results:
put a scroll bar there

workaround is to view message source

I was just about to files this as a bug. The other problem is, when you view
all headers on a massive email, you can't see the body of the message either.
There is no way to scroll down to see either the rest of the headers or the message.

1 comments hidden view all 405 comments
In , Apel (apel) wrote :

This is not limited to OSX (Windows build 20040113)

1 comments hidden view all 405 comments

Well, it also happens in Linux, I think it is safe to say that it happens in all
platforms.

1 comments hidden view all 405 comments

Same behavior with
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.6) Gecko/20040113

Workaround: Export message to text-file and open it with another editor...

1 comments hidden view all 405 comments

i would also appreciate an option for the headers to scroll with the page like
netscape 4.7.

1 comments hidden view all 405 comments

Can somebody change the 'Hardware' field to 'All' on this bug?

1 comments hidden view all 405 comments

This bug is either a dupe of bug 56825 or bug 9942

see bug 216605 for more info...

1 comments hidden view all 405 comments

Created an attachment (id=153241)
UserChrome.CSS file adding scrollbars to header window

This file, when placed in Thunderbird's Chrome directory (in Windows XP it's
C:\Documents and Settings\<Name>\Application
Data\Thunderbird\Profiles]default\*.slt\chrome\) this will add scroll bars to
the header window when Headers are set to Full. This works with Netscape 7.x,
Mozilla 1.x, and Thunderbird 0.7.2. However in Thunderbird, when the headers
are scrolled, horizontal lines will appear on top of the headers that were
below the bottom of the header window. Clicking anywhere in the header window
makes those lines dissappear, but if the headers are scrolled up and down again
afterwards, the lines will reappear. The text for the file was originally
posted to one of the Netscape newsgroups a year or two ago.

1 comments hidden view all 405 comments

This file did not work with Mozilla 1.6 and 1.7 for Linux though.

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

See the CSS tweak in bug 240313. Works OK in TB as well as Moz, but it's not
perfect.

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 242063 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 241463 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

That dupe (bug 241463) notes that if the window is not tall enough, the message
pane pushes down to obscure the status bar, and also the bottom of the folder
pane in some layouts, potentially making some folders inaccessible.

See the work that is going on in bug 9942 towards this same problem in the
Seamonkey mail/news program.

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 261322 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 247163 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 265452 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 269088 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments
In , Mcow (mcow) wrote :

*** Bug 269780 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments

As a different solution to the problem, it would be great if the headers
appeared "inline" with the message, a la evolution.

1 comments hidden view all 405 comments

(In reply to comment #19)
> As a different solution to the problem, it would be great if the headers
> appeared "inline" with the message, a la evolution.

I believe it was stated in a dupe of this bug that you can press ctrl + U and
view the "source" of the message ala Firefox. This works like you describe.

Matt Zimmerman (mdz) on 2006-03-31
Changed in mozilla-thunderbird:
assignee: nobody → adconrad
Gary Coady (garycoady) on 2006-04-26
Changed in mozilla-thunderbird:
status: Unconfirmed → Confirmed
Christian Reis (kiko) on 2006-12-05
description: updated
Changed in mozilla-thunderbird:
status: Unknown → Confirmed
Changed in thunderbird:
status: Unknown → Confirmed
Changed in thunderbird:
status: Confirmed → In Progress
Changed in mozilla-thunderbird:
assignee: adconrad → mozillateam
Alexander Sack (asac) on 2007-10-17
Changed in mozilla-thunderbird:
assignee: mozillateam → mozilla-bugs
jan (jan-ubuntu-h-i-s) on 2008-08-26
description: updated
Changed in thunderbird:
status: In Progress → Confirmed
325 comments hidden view all 405 comments

(In reply to comment #164)

> Please stop: adding random comments on this bug makes it _less_ likely to get
> addressed.

Random comments:

Comments like the above quote made me decide to stop reporting bugs to this organization.

A bug like this should have been fixed LONG AGO. If no one wants to fix it, fine, it only makes your product look bad.

>>Comments like the above quote made me decide to stop reporting bugs to this
organization.

This, plus the amazing complexity and inefficiency of the search engine to make sure a bug has not been reported yet.

>>A bug like this should have been fixed LONG AGO.

And you know the best? After five years, this bug has been "Assign To: Nobody" !

Who the heckassigns bug in here ?
If we really must contribute to get bugs fixed, then I'll VOLONTEER to assign bugs!

1 comments hidden view all 405 comments

Please stop commenting on this bug without useful information how to fix this bug. If you want to have a discussion start a thread on Mozillazine but don't spam 105 CC members with a couple of useless comments. THANKS!!

1 comments hidden view all 405 comments

>>don't spam 105 CC members with a couple of useless comments.

Tell me what's wrong sending useless comments in a useless bug report system?

1 comments hidden view all 405 comments

(In reply to comment #173)
[...]
> Who the heckassigns bug in here ?
> If we really must contribute to get bugs fixed, then I'll VOLONTEER to assign
> bugs!

Normally, people only assign bugs to themselves or to nobody, so if you're willing to _work_ on a bug and fix it, rather than just talking, you're welcome to assign the bug to yourself. Beware though, that if you do, everyone will expect *you* to fix the bug.

1 comments hidden view all 405 comments

Created an attachment (id=344790)
Fix

Conveniently enough, messagereader took out the pinstripe margins and padding, so mcow's version works fine for both. Let's land this, and take anything else elsewhere.

1 comments hidden view all 405 comments

(From update of attachment 344790)
Pretty nice! r=mkmelin

1 comments hidden view all 405 comments
Changed in thunderbird:
status: Confirmed → In Progress
Changed in thunderbird:
status: In Progress → Fix Released
1 comments hidden view all 405 comments

Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081027 Shredder/3.0b1pre ID:20081027025100 and on Windows.

1 comments hidden view all 405 comments
Henrik Nilsen Omma (henrik) wrote :

Mozilla landed a fix upstream last month (adding a scroll bar). We should see it in Jaunty.

Changed in mozilla-thunderbird:
status: Confirmed → In Progress
Alexander Sack (asac) wrote :

.... right, when thunderbird 3.0 enters the archive ... no fix for 2.0 branch though.

thunderbird-3.0 beta 1 packages from mozillateam are in ~fta PPA for testing.

grikdog (dcoshel) wrote :

Confirmed. Version 2.0.0.18 (20081125), Ubuntu Hardy 8.04. Please fix this.

Lars Noodén (larsnooden) wrote :

Also present in Version: 2.0.0.18+nobinonly-0ubuntu0.8.10.1 on 8.10:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu 8.10"

Alexander Sack (asac) wrote :

this was fixed in comm-central, meaning that we wont see a fix until thunderbird-3.0 hits the archive.

Changed in thunderbird:
assignee: mozilla-bugs → nobody
FewClues (fewclues) wrote :

I'm getting calls from all of my Linux students with this same problem. We always tout how fast Linux can fix problems over those of Microsoft. Well waiting on 3.0 for a fix blows that theory out of the water. I'm moving my class and anyone else that who asks over to Evolution. It works and it works now.

Marco Cimmino (cimmo) wrote :

FewClues:
then you might stop to teach false statements, Linux is a kernel and Thunderbird just an email application available for Mac, Windows and Linux.

Ubuntu cannot fix all bugs about all applications that ships and also this is not so trivial bug. There are plenty bugs more important than this.

For your learning Wikipedia may also help:
http://en.wikipedia.org/wiki/Linux

*** Bug 479700 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments

*** Bug 479700 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments

*** Bug 483559 has been marked as a duplicate of this bug. ***

1 comments hidden view all 405 comments

"Verified fixed"... - yes, and thanks a lot for that, but...
It looks as if we've jumped out of the frying pan into the fire!

Posted follow-up Bug 511408: Header pane should auto-resize and/or at least be resizable for large content (can't view many to-recipients when expanded, view all headers etc.)

Now we've got a scroll bar, but the header pane doesn't resize an inch any more (as it used to) when we expand long headers (e.g. lots of TO- or CC-recipients), or even view all headers. What is worse, we can't even resize it manually. So the maximum that we get to see at one glance in a "normal" header is 2 lines of addresses, which equivalents to 6 unknown email addresses that can be viewed at a time without scrolling. Which is a nuisance, because when I expand headers or even "view all headers", what I really want is to see more of them... I reckon that's a pretty regular scenario, any birthday invitation and surely lots of business emails can easily have more than 6 recipients, maybe 10, 20, 30? Even worse for "view all headers", all you can see at one glance is a couple of lines out of your total headers which can easily fill half a page or more. Very sad. Way too much inconvenience for the very basics of handling email - still.

1 comments hidden view all 405 comments

*** Bug 526351 has been marked as a duplicate of this bug. ***

Micah Gersten (micahg) on 2009-12-10
Changed in thunderbird:
milestone: none → 3.0
1 comments hidden view all 405 comments
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: In Progress → Fix Released
Alexander Sack (asac) wrote :

thanks all ... this is a four digit bug and was closed by thunderbird 3 upload ;) ... i know it took a while, but seems there are still miracles to happen ;).

Changed in thunderbird:
importance: Unknown → Low
Phillip Susi (psusi) wrote :

This ancient bug was fixed eons ago, but has not been closed because Debian removed the package and forgot about the bug, leaving it open. Taking this old boy out behind the shed and putting it to rest.

Changed in mozilla-thunderbird (Debian):
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid
Changed in seamonkey:
status: New → Invalid

Created attachment 580669
Screenshot of missing scrollbar

This bug is back see attached header.

I think it is this bug rather than Bug #511408 which complains about resizing, but thinks the scrollbar is there.

Please file a new bug.

Comment on attachment 580669
Screenshot of missing scrollbar

This is now bug 709515.

Displaying first 40 and last 40 comments. View all 405 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.