Ubuntu

Thunderbird heavy IMAP traffic downloading messages

Reported by nils on 2012-11-02
102
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Thunderbird (as of version 16?) generates a lot of IMAP traffic, continually redownloading messages. One issue has been resolved (see https://bugzilla.mozilla.org/show_bug.cgi?id=803843 and https://launchpad.net/bugs/1068921 ) but this issue remains. It is open in bugzilla as https://bugzilla.mozilla.org/show_bug.cgi?id=806760

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010234852

Steps to reproduce:

Reopening bug #802217 as it is a separate issue from #803843 as per https://bugzilla.mozilla.org/show_bug.cgi?id=803843#c33

This is happening (at least) for 16.0.2 as downloaded from Ubuntu.

The continuous downloading is happening in the same folders where the size growth from bug 803843 was happening, so the same messages are probably triggering it.

To trigger the behaviour I only need to go to the folder. Leaving the folder and going back into it right away triggers it again.

The test message from the other bug does not trigger this behaviour for me. I took it, forwarded it to myself with a 10mb PDF attachment to increase its size, and have no problems opening it in a folder that contains just that message, and it doesn't redownload.

What seems to help is repairing the folder. After I repair them, switching into it doesn't trigger the behaviour anymore. I have one folder with 10 messages where it is still triggered (its only 500kb or so). I would guess that if I repair it it will fix the problem as it did in the several other folders before.

Can you save the .msf from that folder ?

I see the issue in SeaMonkey 2.13.1 as well.
We updated from 2.10.1 to 2.13.1 and now we have several IMAP issues, including:
- slow opening of messages with big attachment (should retrieve only text when initially showing the message and retrieve attachment only when it is saved)
- wrong information in Size column of the message list, changing when attachments are opened
- attachments sometimes cannot be opened, the dreaded "This part will be downloaded on demand" problem that has been lingering for a long time. repair of the .msf file fixes it, but it re-occurs when visiting another message and returning
- apparently depending on details of the MIME structure of the message, some messages show consistent problems and on other messages it is not reproducible

I will investigate with 2.13.2 just released, and with 2.12

I have done a lot of testing and decided to revert to 2.12.1 which solves our issues.
2.13.2 is better than 2.13.1 but there are still problems.

I have the same issue in Tb17 on Mac 10.8.2

Interesting fact: When compacting the affected folder, *all* instances of that duplicated email are removed from the file.

If you need additional info, I'm happy to help/test.

I am having this issue on TB16.0.2 with Win7x64. I am not experiencing any IMAP mail growth. My inbox is about 40mb and is not growing. The folders that are constantly being redownloaded do not appear to be growing without bound, either.

@Eric: does the issue go away when you repair (right click -> properties) the folder?

Additional information:
With SeaMonkey 2.13.1 when an attachment cannot be opened (doubleclick on attachment, the saved temporary file is not correct and the started application throws an error), a repair fixes the problem for 1 try, the problem comes back when re-visiting the same message and another repair is required.
With SeaMonkey 2.13.2 and a freshly created .msf it works OK, but when repair is selected the problem then occurs. (inverse of 2.13.1)

This is a setup where IMAP is used (UW IMAPD) and folders are NOT synchronized for offline use.
So the file growth is not visible, but there still are problems.

I just found myself with a 208gb /home/user/.thunderbird folder. Compacting the affected folders does drop the size by around 50gb, and doesn't seem to grow as much as it used to prior to 16.0.2 but I'm still getting banned by Google for a few hours at a time due too much bandwidth.

Its still re-downloading the messages. Will grab anything you need or more information.

Ubuntu 12.10

Folder repair is a local phenomenon. In other words, the folder being repaired is the *local* filesystem folder.

I can create a brand new Thunderbird profile and have this problem. It will act like it is downloading all the messages and eventually finish. Once I close Thunderbird, it starts all over on the next restart.

Additionally, a message that I just clicked on and viewed in the preview pane will be re-downloaded the next time I click on it. The little status area at the bottom says "loading message."

In TB15, when the message is downloaded it does not attempt to re-download it the next time I view it.

Join bug 805830 if you are banned from gmail.

I am experiencing the same behavior running TB 16.0.2 under Ubuntu 12.04. IMAP keeps downloading but not writing into the folder and after a few hours google is banning my account for excessive usage. While I was using TB 16.0.1 the filesize of the IMAP folder was constantly increasing. This is a serious problem rendering such a critical program mostly unusable.

Just for giggles I have repaired my inbox folder and am still noticing the same issues:

* Clicking around on various messages, every time I return to the same message it appears to be downloaded again.

* Going to File->Offline->Download/Sync Now and selecting to sync the Inbox results in a status message being displayed that it is downloading the various messages, but no changes to the filesize of the inbox file actually occur - after the repair it's still sitting at 0kb.

* Restarting Thunderbird results in an immediate activity in the activity manager of "Bringing Inbox up to date" -- right after I've just told TB to sync/download the folder!

* After clicking around again and deleting a few messages from Inbox, nothing has changed with the filesize. It also is still downloading the message I click on every time.

* I then saw another activity "Bringing Inbox up to date" where it is showing that it is downloading all 110 messages again, but nothing much is happening to the inbox IMAP file on disk.

I have another mail client attached to this same account (TB15 on Fedora 16) and the Inbox file is approximately 100meg. Before the repair on TB16/Win7x64 the Inbox file was only up to about 46 meg.

Something is definitely completely bonkers with the IMAP engine in TB16+. 16 and 16.0.2 seem to do the same thing, and it's gnarly.

This should probably be a blocker for bug 805830 (banned from gmail). And I would suggest raising the importance a notch.

*** Bug 798013 has been marked as a duplicate of this bug. ***

I finally got Glodaquilla to work against 16.0.2. Guess what? Not a single message in inbox is being marked as "on disk." In fact, after looking through every folder I have, I would say that less than 20 messages are marked as being "on disk." This is despite the fact that the "Imapmail" folder for this profile is ~117MB.

So, something is definitely going on here.

Ah, nice addon! The one folder where the continuous downloading happens for me has one mail marked as not on disk (all other folders have all mails downloaded after repairing them), and that is the only mail with the gloda dirty flag as well. The flag clears after 30 seconds or so, and then when the next re-download happens another 30 seconds or so later, its obviously set again. Rinse and repeat.

18 comments hidden view all 121 comments
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → In Progress
19 comments hidden view all 121 comments

What does the dirty flag imply? What is 0 and what is 1? I'm seeing odd behavior in inbox.

I can provide a sample mail account for anyone who needs to test this against a server that actually causes it.

Thanks for all your triage work, everybody. The information from Glodaquilla is very helpful. I can reproduce this in my development environment and I'm working on a fix; I'll reach out to you if I need any additional information.

http://mesquilla.com/extensions/glodaquilla/ describes the flags.

more detail
- https://developer.mozilla.org/en-US/docs/Thunderbird/Gloda_indexing describes indexing
- https://developer.mozilla.org/en-US/docs/Thunderbird/gloda gloda generally

dirty means needs to be reindexed
0 means not indexed
1 means bad message / dont' reindex (iirc)

(In reply to Wayne Mery (:wsmwk) from comment #22)
> http://mesquilla.com/extensions/glodaquilla/ describes the flags.
>
> more detail
> - https://developer.mozilla.org/en-US/docs/Thunderbird/Gloda_indexing
> describes indexing
> - https://developer.mozilla.org/en-US/docs/Thunderbird/gloda gloda generally
>
> dirty means needs to be reindexed
> 0 means not indexed
> 1 means bad message / dont' reindex (iirc)

sorry, correction (I shouldn't trust memory)
- dirty flag -
1 means dirty, needs index update
- gloda id -
0 not indexed
1 means bad message / dont' reindex
2 to 15 or 32 (reserved)

Disabling download of MIME parts on demand may work around this issue - could some of you try setting the advanced preference

mail.imap.mime_parts_on_demand

to false, restart Thunderbird, and see if the problem goes away?

(In reply to Irving Reid (:irving) from comment #24)
> Disabling download of MIME parts on demand may work around this issue -
> could some of you try setting the advanced preference
>
> mail.imap.mime_parts_on_demand
>
> to false, restart Thunderbird, and see if the problem goes away?

I had tested this to see if it fixes the issues mentioned in comment #9, but it doesn't.

I saw no change.

I am not seeing as much "bringing up to date" as I was before, but no messages are flagged as being on disk and it tries to download every one every time I click on it. So something is still wrong.

Sergio Benjamim (sergio-br2) wrote :

No change to the last update, 16.0.1 --> 16.0.2. Take a look to the image. High bandwidth, it's insane.

Redownload also happens with: Thunderbird 16.0.2, WinXP and Win 7 X64, Server: Zarafa 7.1.1.

After repairing the problematic folders, the problematic mails are not offline available any more! In my inbox are only such mails, thus the local inbox file is always empty (file size = 0 bytes) now...

mail.imap.mime_parts_on_demand = false didn't change anything.

1 comments hidden view all 121 comments

I have the same issue, beginning with 16.0, now with 16.0.2. Dovecot 1.2 is the remote server, I can provide access to it if that is helpful.

If it helps, here's my report:

I'm configured for offline folders with a limit of 50 KB per message. It seems that since TB 16.x, messages from several folders are reloaded periodically, even if I hadn't opened them for weeks. Also, the status line is wrong, e.g. it shows "Loading message 1 of 1 from Folder XYZ", although in the folder there are e.g. 500 messages.

Compacting messages and repairing folders didn't help at all. What is interesting, though, is that the problem seems to vanish for the current session only, when I sync all messages, even if new messages arrive after that. After a TB restart, the same problem occurs, until I sync again.

We've started having IMAP issues with our Exchange server at work. I don't think our IT group has thought of it yet but it could very likely related to the fact that we have a large number of Thunderbird users that have upgraded to this issue.

As Thunderbird user I'm also having similar issues with my Gmail but it doesn't seem as bad. Either Google can better handle the extra demand or have been temporarily blocking the worst offenders.

I hope this gets fixed before our IT department bans Thunderbird.

I offered to irving to look at this, and I played around with this for a few hours, using a test mail he sent me. I really cannot reproduce anything though - but I am not really sure what I need to do to get there.

It would be very helpful to me if those who are seeing this would try to create a reproducible case on a fresh profile. Alternately, if you are seeing this on a working profile but cannot reproduce on a fresh profile, that would also be interesting to know.

I'm happy to fix a problem that I can reproduce, but I need help to get to that reproducible condition.

When you say "fresh profile" you mean a brand new Thunderbird profile, right?

100% of my testing was done with a new Thunderbird profile that had zero mail accounts in it, that I then attached to an existing Zarafa 7.0.x account via IMAP.

There are multiple people in this thread offering to set up accounts on servers that cause this behavior, myself included.

I'll just privately give you my account where it can clearly be duplicated. (Gmail account).

Thunderbird was banned Campus wide today, due to basically crashing IMAP servers for constant re-downloading.

Erik, could setup a test account that shows the issues that you are having (including having sample problematic emails in the folders), and then tell me what configuration I need to use to connect Thunderbird so that I can duplicate this?

I would also appreciate either a detailed summary STR post, or reference specific comments that you think do that already.

Connor, if you have a setup that you think that I could use to reproduce your issues, I would be happy to try that as well. Private information you can send to <email address hidden>

Kent - I sent you an email directly to your caspia email address and provided login details for our mail system.

I tried the repair folder trick, and it seemed to work. But the operation reset the folder settings; I like to see additional columns such as "Recipient". As soon as I set that, I noticed the issue started again.

Win7 (all updates applied), x64. Sorry I didn't test on a new profile, and the timing of my change and noticing the issue may be coincidental. But I figure every bit of info may help you.

What also should be mentioned, is that there are known IMAP problems with recent version of MS Exchange. So much so, I ended up installing the DavMail gateway.

8 comments hidden view all 121 comments

Have had massive increase in my internet downloads - (now shaped) since upgrading some users PC's to Ubuntu 12.04 and Thunderbird 16.0.2 from 10.04 a weeks or so ago. Have been chasing crackers all week, but this may be the problem !

They are reporting constant downloads. Were existing profiles moved over. Will try to repair and see if fixes problem.

50 comments hidden view all 121 comments

Comment on attachment 679311
Update message size in database on every full message download

Review of attachment 679311:
-----------------------------------------------------------------

Sorry for late sr. This looks like the right thing to do. Given all the positive comments so far, I think we should take this into 17 as well, so a=me for branches.

The nightly in comment #70 worked against my Zarafa instance with my personal account. Glodaquilla indicated all messages in Inbox got downloaded and were "on disk". Clicking around through the message pane didn't result in messages trying to be fetched from the server. Manually forcing an offline sync of all folders seemed to get everything to be indicated as "on disk" with Glodauilla.

Looks like it is working.

Interesting spot: It seems that since I ran the nightly build, also my regular 16.0.2 stopped downloading over and over again. Maybe a coincidence, but maybe the nightly also changed the mailspool's database.

Maybe once the messages are in the local database, they are no longer refetched from server even with the logic of TB16. The bug was that under some circumstances (size differences) TB16 refused to store the msgs into the database (or did not mark it as successfully downloaded/stored). So had to refetch them again and again.

Do I assume right that the fix is not included in 17.0b3? Tried it, and still has that bug.

(In reply to Florian Effenberger from comment #79)
> Do I assume right that the fix is not included in 17.0b3? Tried it, and
> still has that bug.

Have you repaired the folder? Right click on the folder, select "Properties...", in the "General Information" pane click "Repair Folder". Thunderbird should download the messages one more time and then stop.

Changed in thunderbird:
status: In Progress → Fix Released

FWIW I just switched to 17.0b3 and it's working fine for me. I already repaired all my folders when I moved to the 19 nightly to test the fix.

Also, as an Ubuntu user I found this very helpful:
https://launchpad.net/~mozillateam/+archive/thunderbird-next

I'm still starting tbird on the command line to make sure that there are no problems, and I see this error periodically:

autosyncActivities ERROR OnDownloadError: Folder of Account

When I saw that error with 16 it always heralded another round of repetitive downloading, however with the fixed versions it seems to simply be an indicator that the folder is out of synch on my local system, and once it gets updated it seems to stay that way. I use both a laptop and a desktop to access the same mail accounts, so it's expected that the folders on one or the other will be out of synch if I downloaded mail in that folder to the other system already.

hth,

Doug

Very strange... repaired and compacted the folder a view times, but it seems it was not until I deleted the local folder file, redownloaded again, and repaired and compacted again, until it worked. I'll have a look and see if it works now :)

I have tested thunderbird trunk now with two different Imap server.

Thunderbird against Dovecot works as expected, emails are downloaded to local Imap folders and everything is fine.

Thunderbird against Zarafa downloads emails but when finished the local Imap folders are reset to a very small size, so emails are not kept. This causes thunderbird to download over and over again.

I have started completely fresh with thunderbird trunk.

Anything I can to help debugging?

I.e. this issue is not fixed...
I have also reported this issue in Zarafa forum, https://forums.zarafa.com/showthread.php?8211-A-few-users-with-IMAP-performance-issues-via-Thunderbird.

It seems it is not fully fixed in 17.0b3 (w/ Dovecot 1.2)
It works much better than 16.0.2, however, from time to time, a message folder is loaded forever and forever. The folder changes, it seems the pattern is MIME/multipart messages (HTML mails, to be precise)

Compacting and/or repairing the folder, as well as downloading all messages (synchronizing) does NOT help. It seems it helps to manually open each message.

Right now, I have a folder where "1 of 2 messages" are continously being loaded, it always stucks at message #1. The folder, however is definitely empty, has been compacted, repaired, and downloaded. To no avail.

Error console shows, but might be unrelated:

Zeitstempel: 17.11.12 20:28:56
Fehler: 2012-11-17 20:28:56 moveCopyModule ERROR Exception: [Exception... "'Component is not available' when calling method: [nsIActivityManager::removeActivity]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource:///modules/activity/moveCopy.js :: <TOP_LEVEL> :: line 133" data: no]

Quelldatei: resource:///modules/gloda/log4moz.js
Zeile: 687

and

Zeitstempel: 17.11.12 20:28:21
Fehler: 2012-11-17 20:28:21 moveCopyModule ERROR Exception: [Exception... "'Component is not available' when calling method: [nsIActivityManager::removeActivity]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: resource:///modules/activity/moveCopy.js :: <TOP_LEVEL> :: line 133" data: no]

Quelldatei: resource:///modules/gloda/log4moz.js
Zeile: 687

Quitting and restarting Thunderbird helps, it seems.

Does this patch apply clean to 16.0.2? Its disappointing that such a critical fix hasn't been pushed to stable release yet...:(

It does seem that a beta from Thunderbird 17 (from ubuntu mozillateam) fixes the issue for me. The fix does not seem to be in Thunderbird-trunk yet, I hope it gets there...

I re-downloaded all my email from zarafa-IMAP with thunderbird 17 beta from mozillateam and after many hours of waiting, and downloading some messages twice, it now seem stable and calm.

Thanks! I can now use thunderbird again. It was depressing not being able to use it for a couple of weeks.

It seems this issue is indeed not fixed yet. This morning, I had a folder downloading over and over again, with wrong message count (19 messages were in and about 7 were to be downloaded according to the activity window). I have, previously, for several times compacted, downloaded and repaired that folder, and also have deleted all sbd and msf files belonging to it, to no avail. Had to repair the folder again today to make the download stop.

(In reply to Sunil from comment #86)
> Does this patch apply clean to 16.0.2? Its disappointing that such a
> critical fix hasn't been pushed to stable release yet...:(

Thunderbird 17 is being released tomorrow with this fix.

(In reply to Florian Effenberger from comment #88)
> It seems this issue is indeed not fixed yet.

If you are still seeing issues, please file a *new* bug.

It is obvious from comments here that we've fixed at least some of the issues, hence we won't be re-opening this bug. Further comments on this bug may get lost as it isn't open.

If you are filing a bug, it would also be useful to have prepared a log of what Thunderbird is doing:

> It would also help us a lot if you could run from the command line with IMAP and related
> logging turned on; set the environment variable
>
> NSPR_LOG_MODULES=imap:5,ImapAutoSync:5,msgdb:5,timestamp,sync

See https://wiki.mozilla.org/MailNews:Logging for more info.

Why was the change that introduced this issue not rolled back? Why not make 16.0.3 release? How do we know we haven't gotten plethora of new bugs with TB17?

Are you folks trying to kill off Thunderbird as an email client? This is a widespread breakage and its killing servers with redundant traffic.

1 comments hidden view all 121 comments

I'm sorry to say, but for me it got *MUCH* worse with 17.0 now.
Several times, messages are redownloaded, and when that's done, the activity window shows nothing, but Thunderbird still consumes 100% CPU power.

I deleted my whole ImapMail folder, to no avail.

I'll try to get some debug information soon and open a new bug, because it's really unusable for me now. :(

Please leave the bug number for new bug here. TB has not been usable for me for more than a week now, and I have been using alternatives. Someone at TB development has messed up change management really badly!

1 comments hidden view all 121 comments

Just to note for completeness - Tb17 unstable 03 did fix this issue for me too.
I presume the new released stable 17.02 will too.

2 comments hidden view all 121 comments

*** Bug 805830 has been marked as a duplicate of this bug. ***

Tipi Koivisto (tipit) wrote :

I also got a _pretty_ slow Thurdebird and after investigating found a 190G ImapMail folder.

I deleted the files and upgraded from 16.0.1+build1-0ubuntu0.12.04.1 to 17.0+build2-0ubuntu0.12.04.1 from default repo. Now (after two days) the ImapMail seems to stay way smaller and Thunderbird faster all to together.

Im running the latest stable version, and it is downloading the same 4746 emails in the "All Mail" folder.... constantly. Seems to start over again almost as soon as it finishes. Im surprised gmail hasn't shut me down yet.

This is the same thing it did on my prev laptop, moving to a new one hasn't helped at all.

This needs to be resolved now.

Just noticed it is set to resolved/fixed. It most definitely is not.

(In reply to boomhauer from comment #96)
> Just noticed it is set to resolved/fixed. It most definitely is not.

The specific issue described in this bug is indeed fixed in TB17.
What you are seeing, as a gmail user, is something different described in bug 816327.

Florian, Sunil,
Can you please post the imap protocol log. That would be really helpful for us to analyse what is going on. Thanks :-)

Sorry for this delay - finally I was able to produce a log when TB got sluggish. I tested it with TB 20 as well, same problem.

Can I send the log to someone in private, because I assume it may contain sensitive data?

Yes, you can send it to me - is it OK if I also share it with Atul, if he has more time to work on it? Just click on my name in the Bugzilla comment and you'll get the right address.

Yes, I'll surely look upon the protocol log.

Robert Mast (beheerder-x) wrote :

This bug has been bothering me for some weeks now. I decided to try Thunderbird (under Windows!), because of its conversation-view capabilities, and wanted it to be used by some computer-illiterates as well, but this redownloading IMAP-stuff reduces Thunderbird to a small incrowd aware of gloda and dirty cache only.

I Googled the origin of the problem: I found some very intersting comments dating from 2009 about some messages not completely downloading:

https://bugzilla.mozilla.org/show_bug.cgi?id=341225
Bug 341225 -IMAP: Thunderbird caching incomplete downloaded

https://bugzilla.mozilla.org/show_bug.cgi?id=468595 see comment 17 about the risk of a fuzz factor heuristic to fall down, which it does in our case.

This heuristic seems to be a workaround for not downloading messages completely by different threads, (inline images and attachments), while for some reason the download of a part marks the download of the rest as done.

So I guess anyone willing to fix this issue should separate these two download-statusses and kill this previous workaroud.

Robert Mast (beheerder-x) wrote :

One of the authors of this thread left to Postbox.

I checked PostBox if the IMAP-messages I have also get stuck in Postbox. 3 out of 5 get through.

Of those 3 2 get through when I move them to another directory, and then let them reload completely before I open them in Thunderbird.

The other one (12 MB) contains two attachments of which one refuses to load.

The other 2 messages also fail to download in postbox. Postbox however doesn't lock up the downloading of the rest.

Conclusion: Postbox will probably have a better heuristic or cuts impossible downloads earlyer, but still uses this heuristic philosophy over a reliable method.

I'm still having this problem, but I am stuck on Thunderbird 17.04 on Ubuntu Linux. Even though there are newer versions available for Windows. I previously had set the Default Character Encoding to UTF-8 the Character Encoding had been set to Western (IS0-8859-1). If this is being reset by an upgrade, it is possible that other things are being changed that affect this issue.

(In reply to Thomas Sisson from comment #102)
> I'm still having this problem...

Please see comment 97. If your problem sounds like the bug linked there, you can help by posting more detailed information on that bug, such as the exact wording of messages that your are seeing or screenshots. If you are experiencing something different, please search for another open bug or file a new one.

Thanks and good luck.

Thomas, Can you confirm if your problem was solved?
Thanks :)

Not fixed! Using 17.0.5 on Win 7 and Ubuntu 12.04 and copied profile from Win to Ubuntu. Ubuntu "synchronizing)reloading and reindexing all my IMAP folders repeatedly. I let updates run to completion overnight, then first operation on inbox started another reload and reindex of all IMAP folders. Had same problem a year or more back when bringing up my profile on my notebook and other Win machines. FWIW found that my User Name had to be the the same or thunderbird exhibited the same symptoms. I currently have multiple Win 7 machnes running this profile with no problems. I have a Ubuntu machine log file capturing thunderbird actions starting with a fresh copy of my profile from the Win 7 machine.

Robert Mast (beheerder-x) wrote :

Today I tried this again with the same non-synchronizing e-mails with 'Dovecot' instead of 'Courier' as the IMAP-server in TB 17.0.6

All the previous blocking mails stored in a non-synchronizing folder downloaded right away when I clicked on that folder, and all have got a green gloda spot now.

Thunderbird has even ended downloading all other mail.

So there probably is a difference between the Dovecot and Courier-mailservers.

This is still happening in TB 24.0.1
I have a user who's sent folder downloads so much it fills up her hard drive. I turned off the 'save for offline' checkbox, but basically I need to rebuild this sent folder. The folder is 8GB on the server and about 24GB on her local machine.

Is there anyway to just rebuild one folder, rather than rebuilding her whole mail profile? She uses many add-ons and would be a big job to rebuild the entire profile.

Any ideas?

> Is there anyway to just rebuild one folder, rather than rebuilding her whole
> mail profile? She uses many add-ons and would be a big job to rebuild the
> entire profile.

That is easy. Just close down the program completely, open the profile in the
explorer and drill down to the folder where the mail is stored (Profile/ImapMail/
servername) and delete the Sent and Sent.msf files.
When you start the program again, it will download the headers of the Sent folder
into Sent.msf again and will not create Sent (when you have switched off the
offline copy and there is not some wiseguy programmer who thinks it is a good
idea to save everything for offline just in case).

FractalizeR (fractalizer) wrote :

This isn't fixed. Definitely. My office downloads about 40-50Gb from IMAP servers daily due to this bug. Any working workarounds?

Displaying first 40 and last 40 comments. View all 121 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.