Ubuntu One filelink upload failed

Bug #1054803 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2012-09-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Medium
James Henstridge

Bug Description

Tried to email a 2.5MB attachment, thunderbird suggested I use file link. Never used it before, so went through the setup, chose Ubuntu one, entered my email address and password and it span for a little while to authenticate, and some stuff happened in U1 (I got a new folder for Thunderbird stuff). Then it failed to upload the image.

Got a dialog:-

"Upload error"
"Unable to upload Screenshot from 2012-09-23 00:59:08.png to Ubuntu One."

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 15.0+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Uname: Linux 3.2.0-31-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: alan 2585 F.... pulseaudio
 /dev/snd/controlC0: alan 2585 F.... pulseaudio
 /dev/snd/pcmC0D0p: alan 2585 F...m pulseaudio
BuildID: 20120827103657
Card0.Amixer.info:
 Card hw:0 'PCH'/'HDA Intel PCH at 0xf2620000 irq 52'
   Mixer name : 'Intel CougarPoint HDMI'
   Components : 'HDA:14f1506e,17aa21da,00100002 HDA:80862805,80860101,00100000'
   Controls : 27
   Simple ctrls : 9
Card1.Amixer.info:
 Card hw:1 'Snowball'/'BLUE MICROPHONE Blue Snowball at usb-0000:00:1a.0-1.1.3, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB0d8c:0005'
   Controls : 2
   Simple ctrls : 1
Card29.Amixer.info:
 Card hw:29 'ThinkPadEC'/'ThinkPad Console Audio Control at EC reg 0x30, fw unknown'
   Mixer name : 'ThinkPad EC (unknown)'
   Components : ''
   Controls : 1
   Simple ctrls : 1
Card29.Amixer.values:
 Simple mixer control 'Console',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Channel: Unavailable
Date: Sun Sep 23 01:02:29 2012
EcryptfsInUse: Yes
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static
 10.0.3.0/24 dev lxcbr0 proto kernel scope link src 10.0.3.1
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.129 metric 2
 192.168.122.0/24 dev virbr0 proto kernel scope link src 192.168.122.1
MostRecentCrashID: bp-a30e8c1a-772e-4959-b11b-b5bb12120709
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=15.0/20120827103657 (In use)
RelatedPackageVersions:
 google-talkplugin 3.6.1.0-1
 rhythmbox-mozilla 2.96-0ubuntu4.2
 totem-mozilla 3.0.1-0ubuntu21.1
RunningIncompatibleAddons: False
SourcePackage: thunderbird
SubmittedCrashIDs:
 bp-a30e8c1a-772e-4959-b11b-b5bb12120709
 bp-f2f319e9-4fd1-4a35-afa3-aa28d2120622
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/15/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET52WW (1.22 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4287CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET52WW(1.22):bd09/15/2011:svnLENOVO:pn4287CTO:pvrThinkPadX220:rvnLENOVO:rn4287CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4287CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO

Stuart Langridge (sil) on 2012-09-23
Changed in thunderbird (Ubuntu):
assignee: nobody → James Henstridge (jamesh)

Tried renaming the file to foo.png and it worked. Tried again with a smaller screenshot (750K) with the default filename and it failed again. So I suspect it doesn't like the filename format with the colons and spaces and other silly stuff *

* I have long lamented that the filename format for screenshots we have by default is demented. You can't (for example) easily "scp" a screenshot file to another host (something we do a _lot_ without renaming it), tab completing it doesn't work.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
James Henstridge (jamesh) wrote :

This is a bit depressing. It looks like a class of problem I identified and fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=764312. The fix was merged to the trunk branch, and I verified that it was also in the comm-beta branch while things were still in beta, but it doesn't appear to have made it into the release from what I can tell.

The initial cut of the back end was using OAuth HMAC-SHA1 signatures for authentication, since that is what Thunderbird's existing OAuth library supported. This caused problems due to characters in the URL being escaped or unescaped at some level of our stack (probably Apache or Django) prior to signature verification as described in bug 1013126.

James Henstridge (jamesh) wrote :

And it looks like the problem was not completely fixed in trunk either: my fix depended on extending TB's OAuth library to support PLAINTEXT signatures: my changes to the Ubuntu One backend made it into trunk okay, but the changes to the OAuth library seem to still be sitting in Bugzilla tied up in review of the Spideroak backend.

So the missing changes are:

http://hg.mozilla.org/comm-central/rev/b6b7503a7ed3
https://bug744035.bugzilla.mozilla.org/attachment.cgi?id=636163

Chris Coulson (chrisccoulson) wrote :

The fix for https://bugzilla.mozilla.org/show_bug.cgi?id=764312 was landed during the Thunderbird 16 cycle, and is currently in the Thunderbird beta 16 release.

Can you comment on https://bugzilla.mozilla.org/show_bug.cgi?id=744035 ? I'm not sure why your patch landed without that one, as it's marked as blocking in bugzilla.

Changed in thunderbird (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
James Henstridge (jamesh) wrote :

The PLAINTEXT OAuth patch has been split out from the Spideroak bug and merged: https://bugzilla.mozilla.org/show_bug.cgi?id=793749

The patch has been merged for Thunderbird 16, according to that bug report. If we want to back port the fix for our Thunderbird 15 packages, the patches needed are:

http://hg.mozilla.org/comm-central/rev/b6b7503a7ed3
http://hg.mozilla.org/comm-central/rev/6eea3c05df45

Chris Coulson (chrisccoulson) wrote :

Thanks for following this up. I'll upload the latest beta today at https://launchpad.net/~mozillateam/+archive/thunderbird-next if you want to test. We probably won't backport this to 15, unless we need to do an update for another reason (which is quite unlikely now, given how close we are to the 16.0 release)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.