Thunderbird 13/13.0.1 Stable Update

Bug #1007556 reported by Chris Coulson on 2012-06-01
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
enigmail (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
lightning-extension (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
thunderbird (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Natty
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
Micah Gersten (micahg) on 2012-06-07
summary: - Placeholder
+ Thunderbird 13 Stable Update
Changed in thunderbird (Ubuntu):
status: New → Invalid
Changed in enigmail (Ubuntu):
status: New → Invalid

These packages are now available in ppa:ubuntu-mozilla-security/ppa and ppa:mozillateam/thunderbird-stable
We're currently investigating what appear to be corner case bugs before pushing these to the main archive.

Mozaic (mozaic) wrote :

In Thunderbird 13.0.1 some bugs on linux are resolved:
https://www.mozilla.org/en-US/thunderbird/13.0.1/releasenotes/

Micah Gersten (micahg) on 2012-06-19
summary: - Thunderbird 13 Stable Update
+ Thunderbird 13/13.0.1 Stable Update
Launchpad Janitor (janitor) wrote :
Download full text (3.6 KiB)

This bug was fixed in the package thunderbird - 13.0.1+build1-0ubuntu0.12.04.1

---------------
thunderbird (13.0.1+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream stable release (THUNDERBIRD_13_0_1_BUILD1)
    - see LP: #1007556 for USN information

  * Refresh build-depends:
    - Bump minimum GTK version to 2.14 as we build with GIO support
    - Add minimum requirement for glib (2.18)
    - Drop libidl-dev, this doesn't appear to be needed now
    - Bump minimum NSPR version to 4.9.0 for --enable-system-nspr builds
    - Bump minimum sqlite version to 3.7.10 for --enable-system-sqlite
      builds
    - Bump minimum NSS version to 3.13.2 for --enable-system-nss builds
  * Clean up the file exclude list and add comments for excluded files
    - update debian/build/create-tarball.py
  * Make it easy to run Thunderbird in valgrind for builds that are compiled
    with explicit valgrind support
    - update debian/thunderbird.sh.in
  * Refresh patches:
    - update debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/theme-refresh-addressbook-toolbar-icons.patch
    - update debian/patches/theme-refresh-compose-toolbar-icons.patch
    - update debian/patches/theme-refresh-messenger-toolbar-icons.patch
    - update debian/patches/dont-include-hyphenation-patterns.patch
  * Drop patches fixed upstream:
    - remove debian/patches/use-menubar-text-colour-on-tabbar.patch
    - remove debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - remove debian/patches/distro-locale-searchplugins.patch
    - remove debian/patches/avoid-dbus-roundtrip-for-httpchannel.patch
    - update debian/patches/series
  * Bump debhelper compat to 7
    - update debian/apport/blacklist.in
    - update debian/appoty/source_thunderbird.py.in
    - update debian/compat
    - update debian/config/mozconfig.in
    - update debian/control.in
    - update debian/rules
    - update debian/thunderbird-dev.install.in
    - update debian/thunderbird-dev.links.in
    - update debian/thunderbird-globalmenu.dirs.in
    - update debian/thunderbird-gnome-support.install.in
    - update debian/thunderbird.dirs.in
    - update debian/thunderbird.install.in
    - update debian/thunderbird.links.in
    - update debian/thunderbird.lintian-overrides.in
    - update debian/thunderbird.sh.in
  * Use "general.useragent.locale" to select the searchengine locale
    - update debian/patches/distro-locale-searchplugins.patch
    - add debian/patches/dont-override-general-useragent-locale.patch
    - update debian/patches/series
  * Drop no-dynamic-nss-softokn.patch. This patch has no documentation and
    it doesn't look like it's actually useful for anything
  * Apport hook improvements:
    - Add support for reporting preference defaults that are set by extensions
    - When reporting preferences, record the source of each preference
    - Report plugin packages for plugins that are installed with the
      package manager
    - Add some addon manager related prefs to the whitelist
    - Display additional metadata in the extensions report
    - Take "default-to-compatible" in to account when determining whether
      the user is runni...

Read more...

Changed in thunderbird (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package thunderbird - 13.0.1+build1-0ubuntu0.10.04.1

---------------
thunderbird (13.0.1+build1-0ubuntu0.10.04.1) lucid-security; urgency=low

  * New upstream stable release (THUNDERBIRD_13_0_1_BUILD1)
    - see LP: #1007556 for USN information

  * Refresh build-depends:
    - Bump minimum GTK version to 2.14 as we build with GIO support
    - Add minimum requirement for glib (2.18)
    - Drop libidl-dev, this doesn't appear to be needed now
    - Bump minimum NSPR version to 4.9.0 for --enable-system-nspr builds
    - Bump minimum sqlite version to 3.7.10 for --enable-system-sqlite
      builds
    - Bump minimum NSS version to 3.13.2 for --enable-system-nss builds
  * Clean up the file exclude list and add comments for excluded files
    - update debian/build/create-tarball.py
  * Make it easy to run Thunderbird in valgrind for builds that are compiled
    with explicit valgrind support
    - update debian/thunderbird.sh.in
  * Refresh patches:
    - update debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/dont-include-hyphenation-patterns.patch
    - update debian/patches/use-new-yasm-in-lucid.patch
  * Drop patches fixed upstream:
    - remove debian/patches/use-menubar-text-colour-on-tabbar.patch
    - remove debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - remove debian/patches/distro-locale-searchplugins.patch
    - update debian/patches/series
  * Don't build with gnomevfs anymore
    - update debian/config/mozconfig.in
    - update debian/control.in
    - update debian/rules
  * Bump debhelper compat to 7
    - update debian/apport/blacklist.in
    - update debian/appoty/source_thunderbird.py.in
    - update debian/compat
    - update debian/config/mozconfig.in
    - update debian/control.in
    - update debian/rules
    - update debian/thunderbird-dev.install.in
    - update debian/thunderbird-dev.links.in
    - update debian/thunderbird-globalmenu.dirs.in
    - update debian/thunderbird-gnome-support.install.in
    - update debian/thunderbird.dirs.in
    - update debian/thunderbird.install.in
    - update debian/thunderbird.links.in
    - update debian/thunderbird.lintian-overrides.in
    - update debian/thunderbird.sh.in
  * Use "general.useragent.locale" to select the searchengine locale
    - update debian/patches/distro-locale-searchplugins.patch
    - add debian/patches/dont-override-general-useragent-locale.patch
    - update debian/patches/series
  * Drop no-dynamic-nss-softokn.patch. This patch has no documentation and
    it doesn't look like it's actually useful for anything
  * Apport hook improvements:
    - Add support for reporting preference defaults that are set by extensions
    - When reporting preferences, record the source of each preference
    - Report plugin packages for plugins that are installed with the
      package manager
    - Add some addon manager related prefs to the whitelist
    - Display additional metadata in the extensions report
    - Take "default-to-compatible" in to account when determining whether
      the user is running incompatible addons
    - Attach submitted crash ID's to bug reports
    - Report if files in t...

Read more...

Changed in thunderbird (Ubuntu Lucid):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.3 KiB)

This bug was fixed in the package thunderbird - 13.0.1+build1-0ubuntu0.11.10.1

---------------
thunderbird (13.0.1+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream stable release (THUNDERBIRD_13_0_1_BUILD1)
    - see LP: #1007556 for USN information

  * Update globalmenu-extension to v3.2.3
    - Reduce our memory footprint a bit, which wasn't really a lot anyway
    - Avoid the use of the component manager for accessing commonly used
      services, where "commonly used" means "accessed when building every
      menu item". This should save some CPU cycles when building or
      refreshing menus
    - Try to recycle menuitems when they are removed from a menu by
      adding contiguous blocks of removed items to a "free list" which
      is emptied asynchronously, and reusing the items in this list when
      new items are added in place of the removed items. This means that
      menus which fully refresh on opening no longer alter the menu
      structure, but instead just update properties on existing nodes.
      This has a few benefits:
      + With no layout changes, unity-panel-service doesn't request
        the entire menu structure, which significantly reduces dbus traffic
        and makes it much faster to refresh the menu contents
      + The size of the menu doesn't change when it is refreshed, which
        eliminates the flicker that used to occur when opening some menus
    - Remove all use of the global observer service for sending our own
      internal notifications around
    - Get rid of a static initializer
    - Don't support older than Thunderbird 11
    - Fix some GError leaks
    - Hide the internal menu when creating a native menu, rather than
      waiting for confirmation that the native menu is registered
      successfully. We don't try to create a native menu if we don't
      find a menu service to register the menu with anyway
    - Keep menu contents updated whilst the menu is open, rather than
      just whilst it is opening
    - Fix LP: #915888 - Formatting toolbar menu entry is inverted
  * Refresh build-depends:
    - Bump minimum GTK version to 2.14 as we build with GIO support
    - Add minimum requirement for glib (2.18)
    - Drop libidl-dev, this doesn't appear to be needed now
    - Bump minimum NSPR version to 4.9.0 for --enable-system-nspr builds
    - Bump minimum sqlite version to 3.7.10 for --enable-system-sqlite
      builds
    - Bump minimum NSS version to 3.13.2 for --enable-system-nss builds
  * Clean up the file exclude list and add comments for excluded files
    - update debian/build/create-tarball.py
  * Make it easy to run Thunderbird in valgrind for builds that are compiled
    with explicit valgrind support
    - update debian/thunderbird.sh.in
  * Refresh patches:
    - update debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/theme-refresh-addressbook-toolbar-icons.patch
    - update debian/patches/theme-refresh-compose-toolbar-icons.patch
    - update debian/patches/theme-refresh-messenger-toolbar-icons.patch
    - update debian/patches/dont-include-hyphenation-patterns.patch
  * Drop patches fixed upstream:
    - remove ...

Read more...

Changed in thunderbird (Ubuntu Oneiric):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4.2-0ubuntu0.12.04.1

---------------
enigmail (2:1.4.2-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream release v1.4.2
    - LP: #1007556
 -- Chris Coulson <email address hidden> Mon, 28 May 2012 14:06:44 +0100

Changed in enigmail (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4.2-0ubuntu0.10.04.1

---------------
enigmail (2:1.4.2-0ubuntu0.10.04.1) lucid-security; urgency=low

  * New upstream release v1.4.2
    - LP: #1007556
 -- Chris Coulson <email address hidden> Mon, 28 May 2012 14:09:43 +0100

Changed in enigmail (Ubuntu Lucid):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4.2-0ubuntu0.11.10.1

---------------
enigmail (2:1.4.2-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream release v1.4.2
    - LP: #1007556
 -- Chris Coulson <email address hidden> Mon, 28 May 2012 14:07:58 +0100

Changed in enigmail (Ubuntu Oneiric):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.5~b2+build1-0ubuntu0.12.04.1

---------------
lightning-extension (1.5~b2+build1-0ubuntu0.12.04.1) precise-security; urgency=low

  * New upstream release from the beta channel (CALENDAR_1_5b2_BUILD1)
    - LP: #1007556

  * fix LP: #996817 - Add a transitional package to remove the old
    lightning-extension package which still has files installed in
    /usr/lib/thunderbird/extensions
    - update debian/control
 -- Micah Gersten <email address hidden> Fri, 08 Jun 2012 01:06:18 -0500

Changed in lightning-extension (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.5~b2+build1-0ubuntu0.11.10.1

---------------
lightning-extension (1.5~b2+build1-0ubuntu0.11.10.1) oneiric-security; urgency=low

  * New upstream release from the beta channel (CALENDAR_1_5b2_BUILD1)
    - LP: #1007556

  * fix LP: #996817 - Add a transitional package to remove the old
    lightning-extension package which still has files installed in
    /usr/lib/thunderbird/extensions
    - update debian/control
 -- Micah Gersten <email address hidden> Fri, 08 Jun 2012 01:02:31 -0500

Changed in lightning-extension (Ubuntu Oneiric):
status: New → Fix Released
Micah Gersten (micahg) wrote :

lightning-extension is not in lucid

Changed in lightning-extension (Ubuntu Lucid):
status: New → Invalid
Changed in lightning-extension (Ubuntu):
status: New → Invalid
Micah Gersten (micahg) wrote :

There seems to be a regression similar to Bug #1010466 still in natty that appears to affect thunderbird. I'll keep this bug updated as to the status of the natty update.

Micah Gersten (micahg) on 2012-06-22
description: updated
Mozaic (mozaic) wrote :

Thanks for update

Launchpad Janitor (janitor) wrote :
Download full text (5.1 KiB)

This bug was fixed in the package thunderbird - 13.0.1+build1-0ubuntu0.11.04.1

---------------
thunderbird (13.0.1+build1-0ubuntu0.11.04.1) natty-security; urgency=low

  * New upstream stable release (THUNDERBIRD_13_0_1_BUILD1)
    - see LP: #1007556 for USN information

  * Update globalmenu-extension to v3.2.3
    - Reduce our memory footprint a bit, which wasn't really a lot anyway
    - Avoid the use of the component manager for accessing commonly used
      services, where "commonly used" means "accessed when building every
      menu item". This should save some CPU cycles when building or
      refreshing menus
    - Try to recycle menuitems when they are removed from a menu by
      adding contiguous blocks of removed items to a "free list" which
      is emptied asynchronously, and reusing the items in this list when
      new items are added in place of the removed items. This means that
      menus which fully refresh on opening no longer alter the menu
      structure, but instead just update properties on existing nodes.
      This has a few benefits:
      + With no layout changes, unity-panel-service doesn't request
        the entire menu structure, which significantly reduces dbus traffic
        and makes it much faster to refresh the menu contents
      + The size of the menu doesn't change when it is refreshed, which
        eliminates the flicker that used to occur when opening some menus
    - Remove all use of the global observer service for sending our own
      internal notifications around
    - Get rid of a static initializer
    - Don't support older than Thunderbird 11
    - Fix some GError leaks
    - Hide the internal menu when creating a native menu, rather than
      waiting for confirmation that the native menu is registered
      successfully. We don't try to create a native menu if we don't
      find a menu service to register the menu with anyway
    - Keep menu contents updated whilst the menu is open, rather than
      just whilst it is opening
    - Fix LP: #915888 - Formatting toolbar menu entry is inverted
  * Refresh build-depends:
    - Bump minimum GTK version to 2.14 as we build with GIO support
    - Add minimum requirement for glib (2.18)
    - Drop libidl-dev, this doesn't appear to be needed now
    - Bump minimum NSPR version to 4.9.0 for --enable-system-nspr builds
    - Bump minimum sqlite version to 3.7.10 for --enable-system-sqlite
      builds
    - Bump minimum NSS version to 3.13.2 for --enable-system-nss builds
  * Clean up the file exclude list and add comments for excluded files
    - update debian/build/create-tarball.py
  * Make it easy to run Thunderbird in valgrind for builds that are compiled
    with explicit valgrind support
    - update debian/thunderbird.sh.in
  * Refresh patches:
    - update debian/patches/revert-bmo621446-investigation.patch
    - update debian/patches/dont-include-hyphenation-patterns.patch
  * Drop patches fixed upstream:
    - remove debian/patches/use-menubar-text-colour-on-tabbar.patch
    - remove debian/patches/no-sps-profiler-on-unsupported-archs.patch
    - remove debian/patches/distro-locale-searchplugins.patch
    - remove debian/patches/av...

Read more...

Changed in thunderbird (Ubuntu Natty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.4.2-0ubuntu0.11.04.1

---------------
enigmail (2:1.4.2-0ubuntu0.11.04.1) natty-security; urgency=low

  * New upstream release v1.4.2
    - LP: #1007556
 -- Chris Coulson <email address hidden> Mon, 28 May 2012 14:08:51 +0100

Changed in enigmail (Ubuntu Natty):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lightning-extension - 1.5~b2+build1-0ubuntu0.11.04.1

---------------
lightning-extension (1.5~b2+build1-0ubuntu0.11.04.1) natty-security; urgency=low

  * New upstream release from the beta channel (CALENDAR_1_5b2_BUILD1)
    - LP: #1007556

  * fix LP: #996817 - Add a transitional package to remove the old
    lightning-extension package which still has files installed in
    /usr/lib/thunderbird/extensions
    - update debian/control
 -- Micah Gersten <email address hidden> Fri, 08 Jun 2012 00:58:50 -0500

Changed in lightning-extension (Ubuntu Natty):
status: New → Fix Released
Micah Gersten (micahg) on 2012-06-27
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers