Thunderbird sound alert doesn't work with accentuated directory.

Bug #1005835 reported by L_d_v_c@ on 2012-05-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Sounds alert dont't work with accentuated directory. When sounds alerts are in non accentuated directory, it will work but if the same sound alert are in accentuated directory, it won't work.
French translation :
Les alertes sonores ne fonctionnent pas à partir des répertoires accentués de fichiers." (oui... ce n'est pas facile déjà en français)
Ensuite une description : "quand les sons d'alertes sont dans un répertoire non-accentué cela fonctionne, mais si le son est rangé dans un répertoire comportant un caractère accentué, cela ne fonctionne plus.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 12.0.1+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-24.39-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
BuildID: 20120430060637
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfe9fc000 irq 44'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,14627529,00100202'
   Controls : 40
   Simple ctrls : 21
Card1.Amixer.info:
 Card hw:1 'M2496'/'M Audio Audiophile 24/96 at 0xe880, irq 17'
   Mixer name : 'ICE1712 - multitrack'
   Components : ''
   Controls : 48
   Simple ctrls : 26
Card2.Amixer.info:
 Card hw:2 'U0x46d0x8da'/'USB Device 0x46d:0x8da at usb-0000:00:1d.1-1, full speed'
   Mixer name : 'USB Mixer'
   Components : 'USB046d:08da'
   Controls : 3
   Simple ctrls : 2
Channel: release
Date: Tue May 29 11:23:36 2012
ForcedLayersAccel: False
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
IpRoute:
 default via 192.168.0.254 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.0.0/24 dev eth0 proto kernel scope link src 192.168.0.1 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=12.0.1/20120430060637
RfKill:

RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
WifiSyslog:
 May 29 08:49:05 ubuntu kernel: [ 3420.504909] process `skype' is using obsolete setsockopt SO_BSDCOMPAT
 May 29 08:49:28 ubuntu kernel: [ 3444.089274] type=1400 audit(1338274168.884:27): apparmor="DENIED" operation="mkdir" parent=1 profile="/usr/lib/telepathy/telepathy-*" name="/home/ludovic/.config/indicators/" pid=4653 comm="telepathy-haze" requested_mask="c" denied_mask="c" fsuid=1000 ouid=1000
dmi.bios.date: 07/28/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V4.7
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: G31TM-P21 (MS-7529)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV4.7:bd07/28/2010:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7529:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnG31TM-P21(MS-7529):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7529
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD

L_d_v_c@ (l-d-v-c) wrote :
L_d_v_c@ (l-d-v-c) wrote :

My mistake : the two files are identical, buit if you put one file to "Idées" folder, it will fail, and if you put the sounds files to "Idees" folder without accented character, it will work !

ok
Ludovic

Mozaic (mozaic) on 2012-05-29
Changed in thunderbird (Ubuntu):
status: New → Invalid
L_d_v_c@ (l-d-v-c) on 2012-05-31
summary: - Thunderbird doesn't sound with sample 8 kHz WAV
+ Thunderbird sound alert doesn't work with accentuated directory.
description: updated
Mozaic (mozaic) on 2012-05-31
Changed in thunderbird (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Mozaic (mozaic) wrote :

I reproduce if the file are in accented name in path directory like ~/écoute/ or with space in the name like ~/son email/

To post a comment you must log in.