Thunderbird hangs accessing eds on startup

Bug #1040839 reported by Steve Magoun
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
High
Chris Coulson
Quantal
High
Chris Coulson
thunderbird-couchdb (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Thunderbird 15.0~b4+build1-0ubuntu1 always hangs on startup on my 12.10 system. The hang renders thunderbird unusable.

This is a recent regression; downgrading to 15.0~b1+build1-0ubuntu1 solves the problem on my machine.

The hang is in accessing/initializing libedataserver; see attached stack dump (which has been slightly redacted to hide mail addresses)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: thunderbird 15.0~b4+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.5.1-0ubuntu1
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: steve 2188 F.... pulseaudio
BuildID: 20120820154157
Channel: Unavailable
Date: Thu Aug 23 15:13:26 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
IpRoute:
 default via 10.0.1.1 dev wlan0 proto static
 10.0.1.0/24 dev wlan0 proto kernel scope link src 10.0.1.121 metric 9
 169.254.0.0/16 dev wlan0 scope link metric 1000
MostRecentCrashID: bp-35c21ea2-f9e2-42f3-aded-2d9ea2120823
PrefSources: prefs.js
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profiles: Profile0 (Default) - LastVersion=15.0/20120820154157 (In use)
RelatedPackageVersions:
 rhythmbox-mozilla 2.97-1ubuntu3
 google-talkplugin 3.2.4.0-1
 totem-mozilla 3.4.3-0ubuntu1
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
RunningIncompatibleAddons: False
SourcePackage: thunderbird
SubmittedCrashIDs:
 bp-35c21ea2-f9e2-42f3-aded-2d9ea2120823
 bp-06578412-5f07-4f11-a583-3f4332120123
UpgradeStatus: Upgraded to quantal on 2012-08-07 (16 days ago)
dmi.bios.date: 03/05/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP31.88Z.0070.B07.0803051658
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F4238BC8
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F4238BC8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP31.88Z.0070.B07.0803051658:bd03/05/08:svnAppleInc.:pnMacBookPro3,1:pvr1.0:rvnAppleInc.:rnMac-F4238BC8:rvrPVT:cvnAppleInc.:ct2:cvrMac-F4238BC8:
dmi.product.name: MacBookPro3,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Revision history for this message
Steve Magoun (smagoun) wrote :
Revision history for this message
Steve Magoun (smagoun) wrote :

Reproduced this with b5. This bit in the b3 changelog seems suspect: "Update eds extension to 0.5 prerelease r141"

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Do you have evolution-data-server installed? If not, then this is bug 1038047 (although, I'm confused why it doesn't just abort)

affects: thunderbird (Ubuntu) → evolution-data-server (Ubuntu)
Revision history for this message
Steve Magoun (smagoun) wrote :

@Chris: e-d-s 3.5.90-0ubuntu1 is installed

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Could you please do "cat /proc/`pidof thunderbird`/maps | grep edataserver" when it hangs? I bet there are 2 copies of libedataserver loaded (different ABI's)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in evolution-data-server (Ubuntu):
status: New → Confirmed
Revision history for this message
Guy Schlosser (guyster) wrote :

I did the cat command mentioned above, and here are my results. BTW, I am running the 32-bit version, so this bug doesn't seem to be architecture dependent.

cat /proc/`pidof thunderbird`/maps | grep edataserver

a1ea2000-a1ee4000 r-xp 00000000 08:05 3411664 /usr/lib/libedataserver-1.2.so.15.0.0
a1ee4000-a1ee5000 r--p 00041000 08:05 3411664 /usr/lib/libedataserver-1.2.so.15.0.0
a1ee5000-a1ee6000 rw-p 00042000 08:05 3411664 /usr/lib/libedataserver-1.2.so.15.0.0
adb82000-adbfc000 r-xp 00000000 08:05 3410730 /usr/lib/libedataserver-1.2.so.17.0.0
adbfc000-adbfd000 r--p 0007a000 08:05 3410730 /usr/lib/libedataserver-1.2.so.17.0.0
adbfd000-adbff000 rw-p 0007b000 08:05 3410730 /usr/lib/libedataserver-1.2.so.17.0.0

I hope this helps and thanks in advance.

Revision history for this message
Steve Magoun (smagoun) wrote :

Similar to guyster, I see 2 versions of libedataserver loaded - 15.0 and 17.0 - with thunderbird 15.0+build1-0ubuntu1.

$ cat /proc/`pidof thunderbird`/maps | grep edataserver
7f85f4999000-7f85f49de000 r-xp 00000000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7f85f49de000-7f85f4bdd000 ---p 00045000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7f85f4bdd000-7f85f4bde000 r--p 00044000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7f85f4bde000-7f85f4bdf000 rw-p 00045000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7f8602980000-7f86029fc000 r-xp 00000000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7f86029fc000-7f8602bfb000 ---p 0007c000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7f8602bfb000-7f8602bfd000 r--p 0007b000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7f8602bfd000-7f8602bff000 rw-p 0007d000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0

For comparison, with (functional) 15.0~b1+build1-0ubuntu1 on my system, it looks like they are loaded in the opposite order (17 first):

$ cat /proc/`pidof thunderbird`/maps | grep edataserver
7fa2ac660000-7fa2ac6dc000 r-xp 00000000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7fa2ac6dc000-7fa2ac8db000 ---p 0007c000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7fa2ac8db000-7fa2ac8dd000 r--p 0007b000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7fa2ac8dd000-7fa2ac8df000 rw-p 0007d000 08:03 5509708 /usr/lib/libedataserver-1.2.so.17.0.0
7fa2ace96000-7fa2acedb000 r-xp 00000000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7fa2acedb000-7fa2ad0da000 ---p 00045000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7fa2ad0da000-7fa2ad0db000 r--p 00044000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0
7fa2ad0db000-7fa2ad0dc000 rw-p 00045000 08:03 5511794 /usr/lib/libedataserver-1.2.so.15.0.0

Revision history for this message
Steve Magoun (smagoun) wrote :

Purging libedataserver-1.2-15 seems to have done the trick - after doing so, thunderbird is functional and I see just one instance of libedataserver in /proc/*/maps

I still have 2 versions of libedataseerver on disk:
ii libedataserver-1.2-16 3.4.3-1 amd64 Utility library for evolution data servers
ii libedataserver-1.2-17 3.5.90-0ubuntu1 amd64 Utility library for evolution data servers

Revision history for this message
Guy Schlosser (guyster) wrote :

Aha Steve, you beat me to the punch. *lol* removing libedataserver-1.5 did the trick for me too. Now, I have 1.6 and 1.7 on disk, with 1.7 being the one that's loaded. Thunderbird is now working for me too.

Revision history for this message
Guy Schlosser (guyster) wrote :

Correction: libedataserver-1.2-15 is what I purged, just to make the package name accurate for other people that might have the same problem and come across this bug report.

Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This is because of thunderbird-couchdb. Does contact syncing even work for anybody now?

affects: evolution-data-server (Ubuntu) → thunderbird-couchdb (Ubuntu)
Changed in thunderbird-couchdb (Ubuntu):
status: Confirmed → New
Changed in thunderbird-couchdb (Ubuntu):
importance: Undecided → High
Changed in thunderbird-couchdb (Ubuntu Quantal):
status: New → Triaged
Revision history for this message
Steve Magoun (smagoun) wrote :

@Chris - Some more data related to your comment #1:

on my system, thunderbird-couchdb depends on libedataserver-1.2-16, not libedataserver-1.2-15. -16 is still present on disk, and thunderbird functions fine when -16 is present on disk alongside -17.

thunderbird-couchdb version is 0.0.1-0ubuntu4.

Revision history for this message
Oriol Fernàndez Abat (oriolfa) wrote :

I upgraded to 12.10 from 12.04, and I had the same problem with thunderbird hanging at startup (Loading Inbox folder). I confirm tha deleting libedataserver-1.2.15, and in my case libedataserver-1.2-14 solved the problem. Thanks for sharing the solution.

Revision history for this message
Marek Novotny (hotmana76) wrote :

I had the same issue after upgrade to 12.10 from 12.04. Purging of libedataserver-1.2.15 helped me too.

Revision history for this message
Didier Roche (didrocks) wrote :

The package is not maintained anymore and nobody is available to port it to the new e-d-s API

Changed in thunderbird-couchdb (Ubuntu Quantal):
status: Triaged → Fix Released
Revision history for this message
Didier Roche (didrocks) wrote :

I removed it from the archive FYI

Changed in thunderbird (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in thunderbird (Ubuntu Quantal):
status: Triaged → Fix Committed
Changed in thunderbird (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in thunderbird (Ubuntu Quantal):
status: Fix Released → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 15.0.1+build1-0ubuntu2

---------------
thunderbird (15.0.1+build1-0ubuntu2) quantal; urgency=low

  * Update globalmenu-extension to 3.5.1
    - Fix LP: #1051152 - Crash in nsIContent::SetAttr
    - Improve handling of radio items, and work correctly for radio items
      without a name
    - Stop causing nested DOM mutations. There is a big warning about doing
      this in nsIMutationObserver.h
    - Delay processing of DOM mutations during code sections when we are
      dispatching events. This should prevent a recurrence of
      reentrancy-triggered crashes such as LP: #1025011, LP: #1035305 and
      LP: #1051152, which have been exposed by updates of third-party addons
      recently and caused because our view of the menu changes during
      event delivery
  * Update messagingmenu extension to 1.0
    - Ignore case when comparing email addresses (thanks Tom Jaeger)
    - Stop using nsIMsgMessageService.streamHeaders, as this doesn't work
      reliably all of the time (and has been triggering a crash too)
  * Update eds extension to 0.5
  * Fix LP: #1040839 - Thunderbird breaks thunderbird-couchdb in Ubuntu 12.10
    - update debian/rules
 -- Chris Coulson <email address hidden> Thu, 13 Sep 2012 12:04:29 +0100

Changed in thunderbird (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers