Slowdowns/freezes with SVG/ODT/ODF file templates

Bug #994546 reported by Pablo Angulo on 2012-05-04
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Invalid
Medium
thunar (Ubuntu)
Low
Unassigned

Bug Description

1) Open a thunar window
2) Right click and try to 'create a new file'
3) Instead of the templates that I used to see, Thunar freezes for a few seconds, then return to normal.

I just upgraded frmo xubuntu 10.04 to 12.04. It was a clean install from a usb disk, but I kept the home folder. I've tried removing the ~/.config/Thunar folder, but the problem persisted.

Regards!

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunar 1.2.3-3ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic i686
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Fri May 4 14:20:44 2012
ExecutablePath: /usr/bin/Thunar
InstallationMedia: Xubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/usr/bin/fish
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

1. Thunar "Create document" menu takes a while to popup if there are .svg file in ~/Templates folder.

2. Additionally, Thunar won't display svg icons in menus, although it opens an icon file.

Cutted strace:

gettimeofday({1316509097, 297060}, NULL) = 0
lstat64("/usr/share/icons/Faenza/mimetypes/scalable/application-xml.svg", {st_mode=S_IFLNK|0777, st_size=14, ...}) = 0
stat64("/usr/share/icons/Faenza/mimetypes/scalable/application-xml.svg", {st_mode=S_IFREG|0644, st_size=410787, ...}) = 0
readlink("/usr/share/icons/Faenza/mimetypes/scalable/application-xml.svg", "./text-xml.svg", 256) = 14
gettimeofday({1316509097, 297262}, NULL) = 0
open("/usr/share/icons/Faenza/mimetypes/scalable/application-xml.svg", O_RDONLY|O_LARGEFILE) = 20
fstat64(20, {st_mode=S_IFREG|0644, st_size=410787, ...}) = 0
read(20, "<?xml version=\"1.0\" encoding=\"UT"..., 65536) = 65536
gettimeofday({1316509097, 297400}, NULL) = 0

Desktop menu does not affected by this bug

Created attachment 3987
ODF templates that make Thunar sad

I think I'm having the same issue, but with ODF file templates.
xfdesktop shows the templates properly (with generic MIME icons), but Thunar will churn for a bit and then display the templates without any icons at all (a single white pixel).

I'm using the Tango icon theme which has SVG scalable MIME icons (but also pre-scaled 16, 22, 24, and 32px PNG versions), so it may just be related to the selection and display of the SVG scalable MIME icons; but I'm attaching the templates anyway just in case. If it IS trying to display the SVG icons, it should 1) probably be going for the pre-scaled icons instead, and/or 2) not fail at rendering them in the first place.

Pablo Angulo (pablo-angulo) wrote :
Pablo Angulo (pablo-angulo) wrote :

Gotcha!

In the ~/Templates folder, I removed the files one by one, and found that it was the paper.tex file that caused the problem. The other templates, of quite different sizes and file types, caused no problems.

Pablo Angulo (pablo-angulo) wrote :

I've renamed the file and the bug vanished... mark as invalid!

Changed in thunar (Ubuntu):
status: New → Invalid
Triadore (marcelocrt) wrote :

Confirmed: Thunar freezes with SVG templates.
A larger number of templates in SVG format increases the freezing time.

Triadore (marcelocrt) wrote :

SO: Xubuntu 12.04
XFCE 4.8

Triadore (marcelocrt) wrote :

Confirmed: Thunar freezes with SVG templates.
A larger number of templates in SVG format increases the freezing time.

Changed in thunar (Ubuntu):
status: Invalid → Confirmed
grubernd (grubernd) wrote :

same happens with .ods (spreadsheet) and .odt (textdocument) files on my xubuntu 12.04 install. currently only my textfiles (.txt .sh .c) can be used as templates.

Joachim Schwender (jschwender) wrote :

I have a single LO Calc Template that works. Other like LO writer templates and LO draw templates causes this freeze

Joachim Schwender (jschwender) wrote :

As a workaround i have removed all templates but a text template from XDG_TEMPLATES_DIR .
I created a new $HOME/LOTemplate dir and configured LO to use those.
Ugly, but prevents thunar from freezing. Any real solution would be highly appreciated!

summary: - Templates does not work in Thunar
+ Slowdowns/freezes with SVG/ODT/ODF file templates
Changed in thunar (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low

For the OpenOffice files, thunar generates thumbnails if there is a thumbnailer available. I suspect the same for the SVG. These are shown as icons in the templates menu. You can verify this by putting a jpeg file in the templates folder. Because the thumbnails generated for the Openoffice files are only white background, there is not much to see.

BTW: It may be enough to create such template files by simply creating empty files and renaming them so they have the appropriate extensions. This works fine on my system for LibreOffice files, and they are opened in the proper programs.

So far, this works as designed. Therefore I am closing this bug report. Reopen if necessary.

Changed in thunar:
importance: Unknown → Medium
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.