Left or right-clicking on 3MB or bigger svg file is unresponsive

Bug #893330 reported by klerfayt on 2011-11-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Unknown
Unknown
thunar (Ubuntu)
Medium
Unassigned

Bug Description

Unresponsiveness appears to be increasing as svg file size gets bigger. 8MB is really slow compared to other file managers like for example Dolphin.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunar 1.2.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-13.21~lp844957v1-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Mon Nov 21 22:56:19 2011
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

awol (awol99) wrote :

i can second this - i have Thunar 1.2.3, xubuntu 11.10, AMD64, Inkscape 0.48.2 r9819

just hovering (no mouse click at all) over a 7 MegaByte .svg file causes Thunar to lock while taking a whole CPU tread for about 50 seconds.

this does not happen with Nautilus, it does NOT happen for a 23 K file.

happy holidays.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
awol (awol99) wrote :

on a system that is much the same as the AMD64 described above EXCEPT that it is i386 there is NO PROBLEM.

awol (awol99) wrote :

i was wrong about i386 being unaffected. i now have this problem on i386.

Changed in thunar (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium

Thank you -

my system is updated as of now -

Sun Jan 8 13:43:16 EST 2012

and this problem continues.

On Sun, Jan 8, 2012 at 2:00 AM, Lionel Le Folgoc <email address hidden> wrote:
> ** Bug watch added: Xfce Bugzilla #2913
>   http://bugzilla.xfce.org/show_bug.cgi?id=2913
>
> ** Also affects: thunar via
>   http://bugzilla.xfce.org/show_bug.cgi?id=2913
>   Importance: Unknown
>       Status: Unknown
>
> ** Changed in: thunar (Ubuntu)
>       Status: Confirmed => Triaged
>
> ** Changed in: thunar (Ubuntu)
>   Importance: Undecided => Medium
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/893330
>
> Title:
>  Left or right-clicking on 3MB or bigger svg file is unresponsive
>
> Status in Thunar file manager:
>  Unknown
> Status in “thunar” package in Ubuntu:
>  Triaged
>
> Bug description:
>  Unresponsiveness appears to be increasing as svg file size gets
>  bigger. 8MB is really slow compared to other file managers like for
>  example Dolphin.
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: thunar 1.2.3-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-13.21~lp844957v1-generic 3.0.6
>  Uname: Linux 3.0.0-13-generic x86_64
>  ApportVersion: 1.23-0ubuntu4
>  Architecture: amd64
>  Date: Mon Nov 21 22:56:19 2011
>  InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
>  ProcEnviron:
>   PATH=(custom, no user)
>   LANG=en_US.UTF-8
>   SHELL=/bin/bash
>  SourcePackage: thunar
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/thunar/+bug/893330/+subscriptions

--
Sent from my recycled old computer.
<=>

isloer (isloer) wrote :

I have the same problem with thunar. Clicking , or just passing over the thumbnail of a .svg file of some Mb makes the system freeze (30--> less than a minute)

isloer (isloer) wrote :

.....(30seconds --> less than a minute)......of course

tags: added: fixed-in-master
tags: added: cherry-pick
Changed in thunar (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.0-0ubuntu1

---------------
thunar (1.6.0-0ubuntu1) raring; urgency=low

  * Upload to raring.
  * Remaining Ubuntu change:
    - debian/control: recommend udisks2 for mounting devices. lp: #1014632
  * Drop obsolete Ubuntu changes:
    - debian/patches/02_guard-for-no-supported-vfs-schemas.patch,
      debian/patches/xubuntu_fix-duplicate-volumes.patch: included upstream.
  * Bugs fixed:
    - "Thunar: sendto_printer broken" lp: #1061846
    - "segfault when a specific html file is selected" lp: #751739
    - "can't book mark remote shares" lp: #778268
    - "Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
      thinking a directory was a file" lp: #852410
    - "Left or right-clicking on 3MB or bigger svg file is unresponsive"
      lp: #893330
    - "Thunar crashed with SIGSEGV in fast_validate()" lp: #913041
    - "Thunar crashed with SIGSEGV in thunar_file_get_display_name()"
      lp: #931101
    - "Thunar crashed with SIGSEGV in sort_by_mime_type()" lp: #931842
    - "Thunar crashed with SIGSEGV in thunar_util_parse_parent()" lp: #969222
    - "thunar crashed with SIGSEGV in thunar_standard_view_cancel_thumbnailing()"
      lp: #1059397
    - "Does not unmount USB drive when you try first time" lp: #1059997
    - "regression: thunar no longer shows all unmounted, but mountable, volumes
      in sidepane" lp: #1068947
    - "Thunar shows folder sizes wrong" lp: #59235
    - "Right-click "Open With" list not refreshing" lp: #107392
    - "no thunar contextmenu with GTK setting "gtk-menu-popup-delay = 0""
      lp: #127372
    - "rename folder, still active but answers not on 'Enter'" lp: #479975
    - "Thunar hangs on first launch of each session" lp: #775117
    - "emblems disappear on rename" lp: #877755
    - "Remote Deleted file in Thunar remains visible until resfresh" lp: #999824
    - "Incorrect alphabetical sort order in thunar with non-latin (eg. cyrillic)
      file names" lp: #684317
    - "Thunar does not display current folder name" lp: #875193
    - "Thunar crashed with SIGSEGV in g_file_equal()" lp: #900306
    - "Hard to see, if volume is mounted or not" lp: #838917

thunar (1.6.0-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * Drop the "Send to printer" action, xfprint4 is obsolete.
  * debian/control:
    - dropped libtdb-dev from b-deps, emblems have been moved to gvfs.
    - bumped minimum required exo version to 0.10.0 for the new symbol.

  [ Yves-Alexis Perez ]
  * New upstream release.
 -- Lionel Le Folgoc <email address hidden> Mon, 03 Dec 2012 13:13:58 +0100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.