Thunar does not display current folder name

Bug #875193 reported by peterzay on 2011-10-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
Wishlist
Unassigned

Bug Description

When you navigate to /home/username/Downloads/test, you will see above the test file an icon for home, an icon for username, but no icon for Downloads.

Since properties on the test file does not give the path in this light version of XUbuntu, you have no GUI way of knowing where you are.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunar 1.2.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CasperVersion: 1.287
Date: Sat Oct 15 17:58:53 2011
LiveMediaBuild: Xubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

peterzay (peterzay) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thank you for reporting this issue. When I navigate using thunar, often the entire path can not be show. In that situation, there are arrow keys at both ends of the path shown. By clicking those arrows, I can move the path left or right to see the missing directories. I am attaching two screen shots of the same thunar window, both show the path, one starting at the right edge and one starting at the left edge. As you can see, neither one has the complete path. Do those arrows on each not appear? Does clicking those arrows move the path to show other parts?

Changed in thunar (Ubuntu):
status: New → Incomplete
Charlie Kravetz (charlie-tca) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Charlie Kravetz (charlie-tca) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

peterzay (peterzay) wrote :

Yes, the left and right arrows are visible and work. The rightmost folder name is not displayed.

peterzay (peterzay) wrote :

I am viewing an encrypted installation on the hard drive of Ubuntu 11.10 via a liveCD session of XUbuntu.

I get the following folders displayed between the Thunar arrows:
- icon of a hard drive
- media
- what looks like an encryption key
- home
- test

The username is test. I am looking at a text file named test in folder Downloads in folder test.

Changed in thunar (Ubuntu):
status: Incomplete → New
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

Although I can not reproduce this issue, I am marking it confirmed. Perhaps a developer will tell us which logs need to be attached to find the issue with the encrypted directory.

Thanks for taking the time to make Ubuntu better!

Changed in thunar (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
peterzay (peterzay) wrote :

I have repeated the test of comment #6 on an unencrypted hard drive (Ubuntu 10.04 Lucid) and got the same result.

peterzay (peterzay) wrote :

I have devised a simple demo with 2 screenshots to illustrate the problem.

peterzay (peterzay) wrote :

screenshot1

peterzay (peterzay) wrote :

screenshot2

peterzay (peterzay) wrote :

The encryption key from comment #6 also appears on an unencrypted installation. I think it might be a UUID. Sorry for the confusion.

Changed in thunar (Ubuntu):
importance: Medium → Low
Lionel Le Folgoc (mrpouit) wrote :

You can also change the UI to use a pathbar instead of that. Anyway, Thunar in Xfce 4.12 will have an option (hidden by default) to show the full file path in the title bar.

tags: added: fixed-in-master
Changed in thunar (Ubuntu):
status: Confirmed → Triaged
importance: Low → Wishlist
Changed in thunar (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.0-0ubuntu1

---------------
thunar (1.6.0-0ubuntu1) raring; urgency=low

  * Upload to raring.
  * Remaining Ubuntu change:
    - debian/control: recommend udisks2 for mounting devices. lp: #1014632
  * Drop obsolete Ubuntu changes:
    - debian/patches/02_guard-for-no-supported-vfs-schemas.patch,
      debian/patches/xubuntu_fix-duplicate-volumes.patch: included upstream.
  * Bugs fixed:
    - "Thunar: sendto_printer broken" lp: #1061846
    - "segfault when a specific html file is selected" lp: #751739
    - "can't book mark remote shares" lp: #778268
    - "Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
      thinking a directory was a file" lp: #852410
    - "Left or right-clicking on 3MB or bigger svg file is unresponsive"
      lp: #893330
    - "Thunar crashed with SIGSEGV in fast_validate()" lp: #913041
    - "Thunar crashed with SIGSEGV in thunar_file_get_display_name()"
      lp: #931101
    - "Thunar crashed with SIGSEGV in sort_by_mime_type()" lp: #931842
    - "Thunar crashed with SIGSEGV in thunar_util_parse_parent()" lp: #969222
    - "thunar crashed with SIGSEGV in thunar_standard_view_cancel_thumbnailing()"
      lp: #1059397
    - "Does not unmount USB drive when you try first time" lp: #1059997
    - "regression: thunar no longer shows all unmounted, but mountable, volumes
      in sidepane" lp: #1068947
    - "Thunar shows folder sizes wrong" lp: #59235
    - "Right-click "Open With" list not refreshing" lp: #107392
    - "no thunar contextmenu with GTK setting "gtk-menu-popup-delay = 0""
      lp: #127372
    - "rename folder, still active but answers not on 'Enter'" lp: #479975
    - "Thunar hangs on first launch of each session" lp: #775117
    - "emblems disappear on rename" lp: #877755
    - "Remote Deleted file in Thunar remains visible until resfresh" lp: #999824
    - "Incorrect alphabetical sort order in thunar with non-latin (eg. cyrillic)
      file names" lp: #684317
    - "Thunar does not display current folder name" lp: #875193
    - "Thunar crashed with SIGSEGV in g_file_equal()" lp: #900306
    - "Hard to see, if volume is mounted or not" lp: #838917

thunar (1.6.0-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * Drop the "Send to printer" action, xfprint4 is obsolete.
  * debian/control:
    - dropped libtdb-dev from b-deps, emblems have been moved to gvfs.
    - bumped minimum required exo version to 0.10.0 for the new symbol.

  [ Yves-Alexis Perez ]
  * New upstream release.
 -- Lionel Le Folgoc <email address hidden> Mon, 03 Dec 2012 13:13:58 +0100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers