Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions() thinking a directory was a file

Bug #852410 reported by Rena Kunisaki on 2011-09-17
66
This bug affects 7 people
Affects Status Importance Assigned to Milestone
thunar
Unknown
Unknown
thunar (Ubuntu)
Medium
Unassigned

Bug Description

Removed (rm) and re-created (mkdir) a directory on the command line while Thunar was displaying one of its subdirectories. When the directory was removed Thunar switched to displaying the parent directory. When creating it again it showed up as a file of type "(null)", showing its full path as its name. Right-clicking and selecting Properties triggered a crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: thunar 1.2.1-3ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-11.48-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
Architecture: amd64
Date: Sat Sep 17 01:52:28 2011
ExecutablePath: /usr/bin/Thunar
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Release amd64 (20110426.1)
ProcCmdline: Thunar --daemon
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f5a7841d331: repz cmpsb %es:(%rdi),%ds:(%rsi)
 PC (0x7f5a7841d331) ok
 source "%es:(%rdi)" (0x7f5a7842099b) ok
 destination "%ds:(%rsi)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: thunar
StacktraceTop:
 ?? () from /usr/lib/thunarx-2/thunar-uca.so
 ?? () from /usr/lib/thunarx-2/thunar-uca.so
 thunarx_menu_provider_get_file_actions () from /usr/lib/libthunarx-2.so.0
 ?? ()
 ?? ()
Title: Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Rena Kunisaki (i-am-inuyasha) wrote :

StacktraceTop:
 types_from_mime_type (mime_type=0x0) at thunar-uca-model.c:961
 thunar_uca_model_match (uca_model=0x7f5a8b24b2a0, file_infos=<optimized out>) at thunar-uca-model.c:1058
 thunar_uca_provider_get_file_actions (menu_provider=0x7f5a8b215d00, window=0x7f5a8ae6c170, files=0x7f5a8b3bd6a0) at thunar-uca-provider.c:205
 thunarx_menu_provider_get_file_actions (provider=0x7f5a8b215d00, window=0x7f5a8ae6c170, files=0x7f5a8b3bd6a0) at thunarx-menu-provider.c:97
 thunar_standard_view_merge_custom_actions (selected_items=0x7f5a8b3ba300, standard_view=0x7f5a8b168690) at thunar-standard-view.c:1669

Changed in thunar (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in thunar (Ubuntu):
status: New → Triaged
visibility: private → public
tags: added: precise
Rena Kunisaki (i-am-inuyasha) wrote :

Just had this again in 1.2.3. Managed to prevent the crash by deleting and recreating the directory from within Thunar. Any other method caused it to still show up as a file. If I renamed the file on the command line, it would appear as a directory, then creating a new directory with the same name as before, it again appeared as a file. Looks like Thunar has some cache of information about files it's seen, and creating the directory from within Thunar got it to remove/update the invalid entry.

Happened to me while reproducing a bug in file-roller on xubuntu 12.10
when thunar was reopened it had a folder
i was on my guest account making sure it was not a config error

tags: added: fixed-in-master
mrDoctorWho (mrdoctorwho) wrote :

Ohh! AMAZING! I waited it so many time! Thank you!

tags: added: cherry-pick
Changed in thunar (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.0-0ubuntu1

---------------
thunar (1.6.0-0ubuntu1) raring; urgency=low

  * Upload to raring.
  * Remaining Ubuntu change:
    - debian/control: recommend udisks2 for mounting devices. lp: #1014632
  * Drop obsolete Ubuntu changes:
    - debian/patches/02_guard-for-no-supported-vfs-schemas.patch,
      debian/patches/xubuntu_fix-duplicate-volumes.patch: included upstream.
  * Bugs fixed:
    - "Thunar: sendto_printer broken" lp: #1061846
    - "segfault when a specific html file is selected" lp: #751739
    - "can't book mark remote shares" lp: #778268
    - "Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
      thinking a directory was a file" lp: #852410
    - "Left or right-clicking on 3MB or bigger svg file is unresponsive"
      lp: #893330
    - "Thunar crashed with SIGSEGV in fast_validate()" lp: #913041
    - "Thunar crashed with SIGSEGV in thunar_file_get_display_name()"
      lp: #931101
    - "Thunar crashed with SIGSEGV in sort_by_mime_type()" lp: #931842
    - "Thunar crashed with SIGSEGV in thunar_util_parse_parent()" lp: #969222
    - "thunar crashed with SIGSEGV in thunar_standard_view_cancel_thumbnailing()"
      lp: #1059397
    - "Does not unmount USB drive when you try first time" lp: #1059997
    - "regression: thunar no longer shows all unmounted, but mountable, volumes
      in sidepane" lp: #1068947
    - "Thunar shows folder sizes wrong" lp: #59235
    - "Right-click "Open With" list not refreshing" lp: #107392
    - "no thunar contextmenu with GTK setting "gtk-menu-popup-delay = 0""
      lp: #127372
    - "rename folder, still active but answers not on 'Enter'" lp: #479975
    - "Thunar hangs on first launch of each session" lp: #775117
    - "emblems disappear on rename" lp: #877755
    - "Remote Deleted file in Thunar remains visible until resfresh" lp: #999824
    - "Incorrect alphabetical sort order in thunar with non-latin (eg. cyrillic)
      file names" lp: #684317
    - "Thunar does not display current folder name" lp: #875193
    - "Thunar crashed with SIGSEGV in g_file_equal()" lp: #900306
    - "Hard to see, if volume is mounted or not" lp: #838917

thunar (1.6.0-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * Drop the "Send to printer" action, xfprint4 is obsolete.
  * debian/control:
    - dropped libtdb-dev from b-deps, emblems have been moved to gvfs.
    - bumped minimum required exo version to 0.10.0 for the new symbol.

  [ Yves-Alexis Perez ]
  * New upstream release.
 -- Lionel Le Folgoc <email address hidden> Mon, 03 Dec 2012 13:13:58 +0100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.