Thunar crashed with SIGSEGV in thunar_file_is_ancestor()

Bug #847070 reported by Martin Laser
100
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Unknown
Unknown
thunar (Ubuntu)
Medium
Unassigned

Bug Description

trying to open directory

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: thunar 1.2.2-1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
Date: Sun Sep 11 16:45:04 2011
ExecutablePath: /usr/bin/Thunar
InstallationMedia: Ubuntu-Studio 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcCmdline: Thunar --sm-client-id 2a629708a-b6ae-4b26-b018-51088cca2bc2 --daemon
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fad3bb45160: mov 0x28(%rdi),%rdi
 PC (0x7fad3bb45160) ok
 source "0x28(%rdi)" (0xaaaaaaaaaaaaaad2) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: thunar
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: Thunar crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin audio cdrom dialout lpadmin nopasswdlogin plugdev sambashare

Related branches

Revision history for this message
Martin Laser (mlaser) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 thunar_file_is_ancestor (file=0xaaaaaaaaaaaaaaaa, ancestor=0x7fad20060360) at thunar-file.c:2172
 thunar_tree_view_visible_func (model=<optimized out>, file=0x7fad20060360, user_data=<optimized out>) at thunar-tree-view.c:2196
 thunar_tree_model_node_traverse_visible (node=0x7fad3c3cef60, user_data=<optimized out>) at thunar-tree-model.c:1777
 g_node_traverse_pre_order (node=0x7fad3c3cef60, flags=G_TRAVERSE_ALL, func=0x7fad3bb827d0 <thunar_tree_model_node_traverse_visible>, data=0x7fad3c0abaa0) at /build/buildd/glib2.0-2.29.90/./glib/gnode.c:563
 g_node_traverse_pre_order (node=<optimized out>, flags=G_TRAVERSE_ALL, func=0x7fad3bb827d0 <thunar_tree_model_node_traverse_visible>, data=0x7fad3c0abaa0) at /build/buildd/glib2.0-2.29.90/./glib/gnode.c:573

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in thunar (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote : Re: Thunar crashed with SIGSEGV

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
Changed in thunar (Ubuntu):
status: Confirmed → Triaged
visibility: private → public
summary: - Thunar crashed with SIGSEGV
+ Thunar crashed with SIGSEGV in thunar_file_is_ancestor()
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.2.3-3ubuntu2

---------------
thunar (1.2.3-3ubuntu2) precise; urgency=low

  * debian/patches:
    - 03_fix-crash-ancestor-remove.patch: added, should fix crashes when the
      ancestor of a folder is removed. lp: #847070
    - xubuntu_64px-tabwin-icons.patch: added, use a larger app icon by default,
      so tabwin won't show a blurry folder icon.
 -- Lionel Le Folgoc <email address hidden> Wed, 04 Apr 2012 18:51:36 +0200

Changed in thunar (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.