Hard to see, if volume is mounted or not

Bug #838917 reported by Jarno Suni on 2011-09-01
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Unknown
Unknown
thunar (Ubuntu)
Low
Unassigned

Bug Description

It is hard to see from the icon of a partition if it is mounted or not, especially, if you have highlighted (selected) the item. Some special symbol should be used to designate mounted partition.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: thunar 1.2.1-3ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-11.49~ppa1~loms~natty-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
Architecture: i386
Date: Thu Sep 1 18:53:37 2011
EcryptfsInUse: Yes
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: Upgraded to natty on 2011-05-25 (99 days ago)

Related branches

Jarno Suni (jarnos) wrote :
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to make Xubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Xubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted by the community and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in thunar (Ubuntu):
status: New → Invalid
Lionel Le Folgoc (mrpouit) wrote :

FYI, you have an eject symbol that appears only on mounted partitions in the side pane.

Jarno Suni (jarnos) wrote :

At least in Xubuntu 11.04 the eject symbol is visible at unmounted partitions, too. It is still an open bug in Xfce bugzilla: https://bugzilla.xfce.org/show_bug.cgi?id=7045 Are you sure it is fixed in 11.10?

Lionel Le Folgoc (mrpouit) wrote :

Oh, you're probably right, I'll check that (still, partitions are automounted by default, and you usually can't unmount without ejecting).

Changed in thunar (Ubuntu):
importance: Undecided → Low
status: Invalid → Incomplete
Jarno Suni (jarnos) on 2011-09-19
summary: - Storage icons too similar
+ Hard to see, if volume is mounted or not
Jarno Suni (jarnos) wrote :

Removable hard disks are unmounted without ejecting i.e. the item remains in the side pane. Also there may be many partitions in a removable drive.

In Xubuntu 11.10 the eject symbol is visible for unmounted hard disk drives.

tags: added: oneiric
Changed in thunar (Ubuntu):
status: Incomplete → Triaged
tags: added: fixed-in-master
Changed in thunar (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.0-0ubuntu1

---------------
thunar (1.6.0-0ubuntu1) raring; urgency=low

  * Upload to raring.
  * Remaining Ubuntu change:
    - debian/control: recommend udisks2 for mounting devices. lp: #1014632
  * Drop obsolete Ubuntu changes:
    - debian/patches/02_guard-for-no-supported-vfs-schemas.patch,
      debian/patches/xubuntu_fix-duplicate-volumes.patch: included upstream.
  * Bugs fixed:
    - "Thunar: sendto_printer broken" lp: #1061846
    - "segfault when a specific html file is selected" lp: #751739
    - "can't book mark remote shares" lp: #778268
    - "Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
      thinking a directory was a file" lp: #852410
    - "Left or right-clicking on 3MB or bigger svg file is unresponsive"
      lp: #893330
    - "Thunar crashed with SIGSEGV in fast_validate()" lp: #913041
    - "Thunar crashed with SIGSEGV in thunar_file_get_display_name()"
      lp: #931101
    - "Thunar crashed with SIGSEGV in sort_by_mime_type()" lp: #931842
    - "Thunar crashed with SIGSEGV in thunar_util_parse_parent()" lp: #969222
    - "thunar crashed with SIGSEGV in thunar_standard_view_cancel_thumbnailing()"
      lp: #1059397
    - "Does not unmount USB drive when you try first time" lp: #1059997
    - "regression: thunar no longer shows all unmounted, but mountable, volumes
      in sidepane" lp: #1068947
    - "Thunar shows folder sizes wrong" lp: #59235
    - "Right-click "Open With" list not refreshing" lp: #107392
    - "no thunar contextmenu with GTK setting "gtk-menu-popup-delay = 0""
      lp: #127372
    - "rename folder, still active but answers not on 'Enter'" lp: #479975
    - "Thunar hangs on first launch of each session" lp: #775117
    - "emblems disappear on rename" lp: #877755
    - "Remote Deleted file in Thunar remains visible until resfresh" lp: #999824
    - "Incorrect alphabetical sort order in thunar with non-latin (eg. cyrillic)
      file names" lp: #684317
    - "Thunar does not display current folder name" lp: #875193
    - "Thunar crashed with SIGSEGV in g_file_equal()" lp: #900306
    - "Hard to see, if volume is mounted or not" lp: #838917

thunar (1.6.0-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * Drop the "Send to printer" action, xfprint4 is obsolete.
  * debian/control:
    - dropped libtdb-dev from b-deps, emblems have been moved to gvfs.
    - bumped minimum required exo version to 0.10.0 for the new symbol.

  [ Yves-Alexis Perez ]
  * New upstream release.
 -- Lionel Le Folgoc <email address hidden> Mon, 03 Dec 2012 13:13:58 +0100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.