Failed to open encrypted home directory

Bug #754618 reported by Jesusfreak on 2011-04-08
216
This bug affects 44 people
Affects Status Importance Assigned to Milestone
lxde-common (Ubuntu)
Undecided
Unassigned
thunar (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: thunar

Occasionally I get the following error message when trying to access my home folder with thunar (1.2.1):

"Failed to open directory "myname". Error stating file '/home/myname/.gvfs': Transport endpoint is not connected."

At the same time its no problem to access the home folder with other file managers like nautilus. I should add that I use an encrypted home partition (sdb1) while my root partition is on a seperate partition (sda1). When this error occurs I usually reboot to fix it.

I have encountered this exact issue also, and also on a machine where I am using an encrypted home directory. Rebooting does also make it go away when it happens; simply logging out and back in is not sufficient to do so. It was also a newly installed system, so there was not much that yet had been tweaked or configured. Next time it happens I will see if there is also any log messages. Particularly I suspect maybe it is some issue with fuse mounting on top of ecryptfs.

Changed in thunar (Ubuntu):
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Xubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. Please include, if possible:

 1. The release of Xubuntu you are using, via 'lsb_release -rd'.
 2. ~/.xsession-errors log file in plain text
 3. /var/log/syslog after the failure.

summary: - Failed to open home directory
+ Failed to open encrypted home directory
Changed in thunar (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Download full text (13.8 KiB)

I think I can reproduce this bug. It seems to happen explicitly after I log out (to gdm) and then log back in again. I could setup a user with a non-encrypted home on this same machine to see if the behavior is truly specific to encrypted homes only or is related to some session/login issue on it. But now that I can reproduce it, it should be easy to answer these and perhaps other questions. I had started with an xubuntu 11.04 amd64 desktop cd, and it is current to today's updates.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

from mount:
/dev/sda2 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
/dev/sda3 on /home type ext4 (rw,commit=0)
gvfs-fuse-daemon on /home/dyfet/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=dyfet)
/home/dyfet/.Private on /home/dyfet type ecryptfs (ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs,ecryptfs_sig=c78d5f4ebad65466,ecryptfs_fnek_sig=10522851b850cc04)

May 26 19:15:53 apollo NetworkManager[797]: <info> (eth1): device state change: 8 -> 3 (reason 38)
May 26 19:15:53 apollo NetworkManager[797]: <info> (eth1): deactivating device (reason: 38).
May 26 19:15:53 apollo NetworkManager[797]: <info> (eth1): canceled DHCP transaction, DHCP client pid 1487
May 26 19:15:53 apollo wpa_supplicant[936]: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=0
May 26 19:15:53 apollo avahi-daemon[801]: Withdrawing address record for 192.168.1.102 on eth1.
May 26 19:15:53 apollo avahi-daemon[801]: Leaving mDNS multicast group on interface eth1.IPv4 with address 192.168.1.102.
May 26 19:15:53 apollo avahi-daemon[801]: Interface eth1.IPv4 no longer relevant for mDNS.
May 26 19:15:54 apollo acpid: client connected from 2082[0:0]
May 26 19:15:54 apollo acpid: 1 client rule loaded
May 26 19:15:55 apollo gnome-session[2105]: WARNING: Could not launch application 'metacity.desktop': Unable to start application: Failed to execute child process "metacity" (No such file or directory)
May 26 19:15:55 apollo gnome-session[2105]: WARNING: Could not launch application 'gnome-power-manager.desktop': Unable to start application: Failed to execute child process "gnome-power-manager" (No such file or directory)
May 26 19:15:55 apollo gdm-simple-greeter[2118]: Gtk-WARNING: /build/buildd/gtk+2.0-2.24.4/gtk/gtkwidget.c:5687: widget not within a GtkWindow
May 26 19:15:55 apollo gdm-simple-greeter[2118]: WARNING: Unable to load CK history: no seat-id found
May 26 19:15:55 apollo gdm-simple-greeter[2118]: Gtk-WARNING: gtk_widget_size_allocate(): attempt to allocate widget with width 378 and height -1
May 26 19:15:55 apollo gdm-simple-greeter[2118]: Gtk-WARNING: gtk_widget_size_allocate(): attempt to allocate widget with...

Changed in thunar (Ubuntu):
status: Incomplete → Confirmed

Furthermore, I also get this:

ls -alrt ~/.gvfs
ls: cannot access .gvfs: Transport endpoint is not connected

So clearly something is going on with gvfs...that's the error thunar shows also.

I can now confirm it is also likely, as suspected, specific to encrypted homes. I have no problem with a standard user account with a non-encrypted home on this same machine.

Cornelius Sicker (ysis) wrote :

I'm also affected by this bug. Running Xubuntu 11.04 64bit with an encrypted home folder.

Cornelius Sicker (ysis) wrote :

I forgot to mention: I can reproduce by just loggin out of Xfce to GDM and loggin back in. A reboot helps.

VastOne (vastone) wrote :

I am NOT using anything encrypted and just began receiving this out the blue... Meaning no new updates that rocked the boat

I am running wheezy debian (testing not sid) and completely up to date

Xfce 4.8

#!

For me this is happening in bith Thunar and pcmanfm

I can access everything but /home/myhome and the Desktop folder

I am going to reboot to see if it resolves, if not I am going to purge and reinstall gvfs

This is the complete error message

Error stating file '/home/vastone/.gvfs': Transport endpoint is not connected.

VastOne (vastone) wrote :

Reboot resolved mine.. Will report back if it pops again

Hi!
I think it is a "coming back" of an old issue: https://bugs.launchpad.net/bugs/212789

When you log out the gvfs does not unmount.
Reboot resolves this, but that cannot be an accepted solution.

Please, fix this again!

Redsandro (redsandro) wrote :

I have the exact same issue with the same specs as the reporter stated. Encrypted home. Before I encountered this, which is every single time when opening thunar, I removed the log files so I would only catch relevant errors. But nothing was reported/written.

$ lsb_release -rd
Description: Ubuntu oneiric (development branch)
Release: 11.10

Fully updated as of today, 64 bit. Thunar 1.2.3

~/.xsession-errors -> empty
/var/log/syslog -> empty

Redsandro (redsandro) wrote :

(meant to add to previous message)

Message on opening Thunar:
Failed to open directory "redsandro".
Error stating file '/home/redsandro/.gvfs': Transport endpoint is not connected.

And then nothing is displayed. Home seems empty.
Workaround: I can open nautilus in xubuntu just fine (when installed ofcourse) without errors and showing all the contents of my home dir.

nbl (nblouveton) wrote :

Hi all !

Same issue for me.

Not looks to affect only thunar package but also happens with command lines apps like "df" which displays the same error message: "Transport endpoint is not connected."

When run "ls -al" on my encrypted home directory ".gvfs" line is filled with "?" instead of showing me file's stats (no permissions are displayed). The file is locked with no write permission even for root.

I run ubuntu oneiric, all work fine with gnome-shell/nautilus.

Regards,
nbl

I am having this problem as well with both Thunar and pcmanfm. I prefer using Nautilus, even if that will replace my XFCE desktop with the one from GNOME. The home folder does not seem to work, but Thunar seems to open the subfolders (Music, documents, videos, pictures, blah blah blah...) without problem.

Running "ls -al" seems to work correctly on my end.

I am using Ubuntu 11.10 Oneiric as well.

nbl (nblouveton) wrote :

Hi Alejandro,

I solved the problem by unmounting the gvfs directory:
sudo umount /home/user/.gvfs

After that the problem disappeared totally.

Concerning Nautilus and your desktop, you probably should switch off the "have file manager handle the desktop" option of GNOME. It is possible to set this option through gnome tweaks utility.

Hope that help,
Cheers.

StewartM (smmillen) wrote :

I also ran into this problem on my inspiron 1525 N laptop after installing Xubuntu/Xfce on 11.10 to experiment with it. It also affected Nautilus's ability to open the top-level /home/myuser directory (subdirectories like /home/myuser/Documents open fine).

As I wanted just to experiment anyway, removing Xubuntu/Xfce restored everything back to normal.

StewartM

I am running Xubuntu 11.10 and had this bug pop up on my system today when trying to access my home directory with thunar. I unmounted /home/user/.gvfs as nblouveton suggested and that fixed it for now. I had it pop up last week and a reboot fixed it then.

Thanks!

Julian W (naboo-ws) wrote :

Hi, I have this exact problem and nbl's solution worked perfectly.

Pravin Paratey (pravinp) wrote :

+1 for nbl's solution

antoirehew (antoirehew-uk) wrote :

affected here too, same issue after i migrated to xubuntu, my home folder encrypted in gnome nautilus got this bug

J E (ptwobenis) wrote :

This error is reproducible in the following way:

Log into Xubuntu
Open an encrypted home under user A
Log out
Log into user B
Error will occur under Thunar when trying to open the HOME directory in user B ONLY. The sub-directories are accessible under Thunar and the home directory is accessible under a terminal or Gnome file browser.

I hope this helps.

Thanks!

rog (linux-rog) wrote :

I am seeing this problem in newly installed xbuntu 12.04 LTS. The various workarounds have not helped.

Strangely, I am also now being prompted to select a session after booting.

Looking at syslog, I see,
May 1 20:14:56 netbook sudo: pam_ecryptfs: pam_sm_authenticate: /home/roger is already mounted

Again, unmount doesn't work. Response is
umount: /home/roger/.gvs: not found

Implied is a problem with thunar because I can find and open files in /~, e.g., opening a document with Libre Writer. I can also see html files stored there with FireFox.

Maybe uninstall and re-install thunar?

/Roger

rog (linux-rog) wrote :

Well, apparently we can't delete thunar without killing the xbuntu desktop! (Based on what I see would be deleted - multiple packages - if I remove thunar.

I hope xbuntu guys get on this. It appears to have been around as a problem for A LONG TIME.

rog (linux-rog) wrote :

Issue disappeared when I turned-off "Display chooser on login" (under Settings | Session and Startup).

BUTT, this is still a bug as far as I am concerned!

Adam (adam-st-lawrence) wrote :

I encountered this problem today.

I added a serial-to-USB converter to my Xubuntu 12.04 system to configure some network devices. I added my user account to the dialout group and then relogged. After performing some config on some switches I attempted to open my home directory via Thunar and was greeted with the error described by everyone else.

I do not have "Display chooser on login" enabled in Settings > Session and Startup, however, unmounting /home/myuser/.gvfs did work.

I have the same bug. (Using encrypted home directories, and a separate root partition, with Thunar 1.2.3 in Xubuntu 12.04.)
Once it happens in one account, all the other accounts in the same computer start having the same problem.
The problem is rather frequent. And it's quite annoying, having to always reboot the computer in order to "solve" it...

I have this issue as well. I have an encrypted home directory, separate root partition, using Thunar 1.2.3 in Xubuntu 12.04. The issue started after I created a .gtkrc-2.0 file to increase the width of my scroll bars. I used the following command:

leafpad ~/.gtkrc-2.0

...created file with following contents

style "scroll"
{
    GtkScrollbar::slider-width = 25
    GthScrollbar::stepper-size = 25
}

class "*" style "scroll"

...saved the file. Logged out, logged back in....there was a lengthy wait for the display to come up. Thunar was dysfunctional afterwards. I removed the file, rebooted...and things seem to work normal. So far.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxde-common (Ubuntu):
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

Is it still an issue on quantal? It looks like $HOME/.gvfs has been moved to /run/user/<user>/gvfs, so this bug may be fixed as a side effect of the move.

Changed in thunar (Ubuntu):
status: Confirmed → Incomplete

Since this bug is still present in 12.04 and it is an LTS here is a solution automatize unmounting .gfvs at user login:
the second answer http://askubuntu.com/questions/94211/failed-to-open-home-directory

Lionel Le Folgoc (mrpouit) wrote :

As written previously, should be fixed in quantal and later.

Changed in thunar (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers