rename folder, still active but answers not on 'Enter'

Bug #479975 reported by LAZA on 2009-11-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Unknown
Unknown
thunar (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: thunar

After renaming a folder and enter it the folder itself is marked as active (colored) but by hitting 'Enter' again the folder does not open.
Enter has no effect!
In older versions of Thunar you could enter the folder at once by hitting twice 'Enter'...

Ubuntu 9.10
Linux ubuntu 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:05:01 UTC 2009 x86_64 GNU/Linux
Thunar 1.0.1-1ubuntu2
---
Architecture: amd64
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
NonfreeKernelModules: fglrx
Package: thunar 1.0.1-3ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic x86_64
UserGroups:

Related branches

LAZA (laza74) wrote :

Very very curious - some times it acts!
Maybe a problem where the curser is at the end of the renaming... (or something like that)

Vincent (vinnl) wrote :

I've had that too on Xubuntu 9.04.

Changed in thunar (Ubuntu):
status: New → Confirmed
Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If you could test the current Ubuntu development version, this would help us a lot. If you can test it, and it is still an issue, we would appreciate if you could upload updated logs by running apport-collect 479975.

Changed in thunar (Ubuntu):
status: Confirmed → Incomplete
LAZA (laza74) wrote :

seems for me the same/nearby problem like this bug:

https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/520118

apport information

tags: added: apport-collected
description: updated
Charlie Kravetz (charlie-tca) wrote :

Thanks for your response. Are you using detailed view in Thunar? If you are, this is indeed a duplicate of bug 520118. Please try to reproduce it using either icon view or compact view.

LAZA (laza74) wrote :

No, I changed of cause of this bug into ico view (CTRL+1) - so it is reproducible in every view i tried!

It happens also with F2 when I'd like to rename directorys...

Charlie Kravetz (charlie-tca) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.xfce.org/show_bug.cgi?id=6571

Changed in thunar (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
tags: added: fixed-in-master
Changed in thunar (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.0-0ubuntu1

---------------
thunar (1.6.0-0ubuntu1) raring; urgency=low

  * Upload to raring.
  * Remaining Ubuntu change:
    - debian/control: recommend udisks2 for mounting devices. lp: #1014632
  * Drop obsolete Ubuntu changes:
    - debian/patches/02_guard-for-no-supported-vfs-schemas.patch,
      debian/patches/xubuntu_fix-duplicate-volumes.patch: included upstream.
  * Bugs fixed:
    - "Thunar: sendto_printer broken" lp: #1061846
    - "segfault when a specific html file is selected" lp: #751739
    - "can't book mark remote shares" lp: #778268
    - "Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
      thinking a directory was a file" lp: #852410
    - "Left or right-clicking on 3MB or bigger svg file is unresponsive"
      lp: #893330
    - "Thunar crashed with SIGSEGV in fast_validate()" lp: #913041
    - "Thunar crashed with SIGSEGV in thunar_file_get_display_name()"
      lp: #931101
    - "Thunar crashed with SIGSEGV in sort_by_mime_type()" lp: #931842
    - "Thunar crashed with SIGSEGV in thunar_util_parse_parent()" lp: #969222
    - "thunar crashed with SIGSEGV in thunar_standard_view_cancel_thumbnailing()"
      lp: #1059397
    - "Does not unmount USB drive when you try first time" lp: #1059997
    - "regression: thunar no longer shows all unmounted, but mountable, volumes
      in sidepane" lp: #1068947
    - "Thunar shows folder sizes wrong" lp: #59235
    - "Right-click "Open With" list not refreshing" lp: #107392
    - "no thunar contextmenu with GTK setting "gtk-menu-popup-delay = 0""
      lp: #127372
    - "rename folder, still active but answers not on 'Enter'" lp: #479975
    - "Thunar hangs on first launch of each session" lp: #775117
    - "emblems disappear on rename" lp: #877755
    - "Remote Deleted file in Thunar remains visible until resfresh" lp: #999824
    - "Incorrect alphabetical sort order in thunar with non-latin (eg. cyrillic)
      file names" lp: #684317
    - "Thunar does not display current folder name" lp: #875193
    - "Thunar crashed with SIGSEGV in g_file_equal()" lp: #900306
    - "Hard to see, if volume is mounted or not" lp: #838917

thunar (1.6.0-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * Drop the "Send to printer" action, xfprint4 is obsolete.
  * debian/control:
    - dropped libtdb-dev from b-deps, emblems have been moved to gvfs.
    - bumped minimum required exo version to 0.10.0 for the new symbol.

  [ Yves-Alexis Perez ]
  * New upstream release.
 -- Lionel Le Folgoc <email address hidden> Mon, 03 Dec 2012 13:13:58 +0100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
Kangarooo Jānis (kangarooo) wrote :

Hello! I see This bug was fixed in the package thunar - 1.6.0-0ubuntu1
but in http://packages.ubuntu.com/precise/thunar i see its Package: thunar (1.2.3-3ubuntu2)
Or should i look different way or later? Or is this page wrong?

Kangarooo Jānis (kangarooo) wrote :

Also i cant do an update on 12.04 xubuntu. Its still original version.

Lionel Le Folgoc (mrpouit) wrote :

It's fixed in raring (the current development release), not in precise.The fix can't be backported easily. If you want to try Thunar 1.6.0 on precise, check the xubuntu-dev/xfce-4.12 ppa.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.