Jaunty Xubuntu installation fails at 85% "Select and install software" - 'post-installation trigger python-support'

Bug #323665 reported by Charlie Kravetz on 2009-01-31
2
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
High
Lionel Le Folgoc

Bug Description

Binary package hint: debian-installer

RELEASE: Xubuntu Jaunty 9.04 Development Version dated 01-31-2009
CD VARIANT: Alternate CD for both amd64 and i386
ISO BUILD: jaunty-alternate-i386.iso and jaunty-alternate-amd64.iso

SYMPTOMS:
Xubuntu installing from daily iso image, both 'jaunty-alternate-i386.iso' and 'jaunty-alternate-amd64.iso' fail at the same point. Installation proceeds normally to "Select and install software"; at 85%, 'post-installation trigger python-support' gives a failure. Any attempts to continue the installation fail from this point. I have not even been able to install the grub after this failure.

This is happening in VirtualBox and on hardware installations.

Attaching logs from the hardware installation failure.

STEPS TO REPRODUCE:
1. Download daily image from http://cdimages.ubuntu.com/xubuntu/daily/current/
2. Burn the ISO
3. Install from the cd or ISO image
4. Fails at 85% of "Select and install software"

Charlie Kravetz (charlie-tca) wrote :
Charlie Kravetz (charlie-tca) wrote :
Charlie Kravetz (charlie-tca) wrote :

Just a note, this failure occurs using both Guided/Use entire disk partitioning and Manual Partitioning.

Colin Watson (cjwatson) wrote :

A failure at this point is due to uninstallable packages; unless we're actively calling for testing for some kind of milestone release or whatever, it's usually best to wait a day or two to see if it goes away, as this is often due to transient build problems.

Reassigning to gamin just in case any manual attention needs to be paid to this.

Jan 31 18:02:31 in-target: The following packages have unmet dependencies:
Jan 31 18:02:31 in-target: gamin: Conflicts: fam but 2.7.0-13.3ubuntu1 is to be installed
Jan 31 18:02:31 in-target: libgamin0: Conflicts: libfam0
Jan 31 18:02:31 in-target: Conflicts: libfam0c102
Jan 31 18:02:31 in-target: E:
Jan 31 18:02:31 in-target: Broken packages

Colin Watson (cjwatson) wrote :

Actually, the problem is that the recent thunar merge apparently dropped the long-standing Ubuntu change to build-depend on libgamin-dev instead of libfam-dev and drop the build-conflicts on libgamin-dev. This resulted in libthunar-vfs-1-2 depending on libfam0 rather than libgamin0, making the xubuntu-desktop task uninstallable.

Changed in thunar:
importance: Undecided → High
status: New → Triaged
Lionel Le Folgoc (mrpouit) wrote :

Grmbl, I'll fix that, sorry.

But I can't really reproduce locally (on a pbuilder or my system), as libgamin0 provides libfam0, libgamin0 is correctly selected when I try to install thunar and gamin... I'll reintroduce the change anyway.

Changed in thunar:
assignee: nobody → mrpouit
status: Triaged → In Progress
Charlie Kravetz (charlie-tca) wrote :

Well, I'm sorry about the missed dates. This bug was present on 01-27-2009. I did give it a few days hoping it would resolve. This is now 02-02-2009 and the Xubuntu alternate cd still can not be used for installations. Alpha4 is scheduled for release on 02-05-2009. It would be nice to have a cd working before then.

The desktop cd's can be used to install with no problems. By the way, Lionel, great job on the updates to xfce and xfwm. The new desktop looks good, too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 0.9.99.1-0ubuntu2

---------------
thunar (0.9.99.1-0ubuntu2) jaunty; urgency=low

  * debian/control: build-depends on libgamin-dev instead of libfam-dev and
    remove the Build-Conflicts field (this should fix the alternate cd,
    LP: #323665)

 -- Lionel Le Folgoc <email address hidden> Tue, 03 Feb 2009 00:04:31 +0100

Changed in thunar:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers