Thunar interactive search sometimes stops accepting input after one character

Bug #1844771 reported by Forest
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Exo
Fix Released
Medium
exo (Ubuntu)
Undecided
Unassigned
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

Typing a file name in a thunar window (optionally pressing Ctrl+F first) normally selects the file whose name matches the entered text. After upgrading from Ubuntu 18.04 to 19.04, this feature started randomly breaking after a single character is entered.

To reproduce (sometimes):

1. Open a thunar window to a directory full of files.
2. Before doing anything in that window, Alt+Tab to a different window.
3. Alt+Tab back again.
4. Type the name of a file in the open directory.
5. Notice that, sometimes, the input text box stops accepting input after the first letter of the file name.

Revision history for this message
In , Mrniex (mrniex) wrote :

Somewhere between the last 2 Thunar releases "finding" a file/folder by typing its name stopped working on random intervals.

Expected behavior: I should be able to write the whole name of the file/folder I am looking for

Actual behavior: At random intervals (ie, cannot be replicated every single time) Thunar will only take the first letter of the input and ignore any other keyboard input after it - including Enter or ctrl+key - Esc may be an exception.

There is no reliable way to reproduce this behavior.

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

Most likely related to latest exo changes: Bug #14994

You are using exo-0.12.4 (libexo) ?

Revision history for this message
In , Mrniex (mrniex) wrote :

Yep, thats the version on my system. I noticed that the bug is related to two monitors though, I only use one, is that relevant?

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

Well, if the bug only appeared after upgrade to exo 0.12.4, than probably it is the cause.

Can you switch back to the old version and see if you can reproduce the bug there ?

I cannot reproduce this bug .. for me the search works like expected, tried for 5min now.

Revision history for this message
In , Mrniex (mrniex) wrote :

Im not sure if I can downgrade -- at least I dont know how to do it on Arch.

It doesnt help that the bug appears completely randomly either. It can go day without me hitting it, and then it suddenly reappears again.

Also, this probably isnt really helpful at all, but just in case Im describing the things wrong, this is a recording of the bug - no inputs after the first letter get registered, and only some keys work (backspace did work, but I believe delete and ctrl commands didnt).
https://my.mixtape.moe/fdrfva.webm

Revision history for this message
In , Mrniex (mrniex) wrote :

OK, I just hit the bug again literally 30 seconds after sending the last post - this time not even backspace or enter worked, the whole Thunar window just locked up input-wise until the prompt disappeared or until I clicked on a folder.

Also, I believe this bug may be affecting mostly older instances of Thunar open for about 30 minutes or so and longer.

Revision history for this message
In , Dwu-public (dwu-public) wrote :

Created attachment 8279
Experimental patch

I think I found a way to reliably reproduce the issue:

- open a Thunar window,
- without starting a search switch to some other window via alt+tab,
- switch back to Thunar and start a search via typing.

I so far had no success tracking down the exact cause of the issue in the current patch to #14994.

But maybe the following helps: As I was not aware of how exo-icon-view is used in applications other than Thunar the original patch for #14994 aimed at reproducing the implementation of GTK's treeview as closely as possible. When simplifying the code to what's needed for making type-ahead-search work in Thunar the issue does not seem to occur.

Please find a corresponding experimental patch for further discussion attached.

I'd be happy to test the patch against other applications using exo-icon-view if there are any.

Revision history for this message
In , Mrniex (mrniex) wrote :

Yep, I can confirm that alt tabbing out of the window does reproduce the bug in most (but not all?) cases. I just tried it on two windows I already had opened, and the bug did not occur. Opening a new window and alt+tabbing out of it and back replicated the bug.

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

Well done again dwu, thanks !

Yes, now I as well can reproduce the bug.

Your patch fixes the problem, I tested for thunar master and for the 4.12 branch. (Sorry dont know who else makes use of the search field other than thunar )

IMO code already looks good to get pushed .. or would you prefer to further search for the exact cause ?

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

@dwu

Ok for you if I ask bluesabre to test & push you experimental patch ? (IMO it looks good to get pushed)

Revision history for this message
In , Dwu-public (dwu-public) wrote :

Sorry for my late reply. Sure, please proceed as you see fit.

I currently don't have access to my development machine so I didn't really dig deeper into this. So while I'm pretty sure that the patch is not the best solution, it seems to fix the issue at least for Thunar.

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

*** Bug 15182 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Bluesabre-1 (bluesabre-1) wrote :

@alexxcons

Can you test this with thunar 1.6.x so we can make sure there's not a regression with the GTK2 version of the exo library?

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

@Sean Davis

I just tested, as well seems to work fine for thunar 1.6.x. Should be ok to get pushed.

Revision history for this message
In , Gitbot (gitbot) wrote :

Sean Davis referenced this bugreport in commit ae706f0be78bfc117973818a6a8c55168090349d

Fix typehead in ExoIconView (bug #15100)

https://git.xfce.org/xfce/exo/commit?id=ae706f0be78bfc117973818a6a8c55168090349d

Revision history for this message
In , Bluesabre-1 (bluesabre-1) wrote :

Added your patch in the above commit, thanks!

Revision history for this message
In , Alexxcons-x (alexxcons-x) wrote :

*** Bug 15316 has been marked as a duplicate of this bug. ***

Revision history for this message
Forest (foresto) wrote :
no longer affects: thunar
Changed in exo:
importance: Unknown → Medium
status: Unknown → Fix Released
Forest (foresto)
tags: added: disco patch-accepted-upstream regression-release
Revision history for this message
Theo Linkspfeifer (lastonestanding) wrote :

Fixed in Ubuntu 20.04.

Changed in exo (Ubuntu):
status: New → Fix Released
Changed in thunar (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.