Querying Thunar /proc directory causes hang

Bug #162448 reported by Steve Cayford on 2007-11-13
8
Affects Status Importance Assigned to Milestone
Thunar File Manager
Fix Released
Unknown
thunar (Ubuntu)
Medium
Unassigned

Bug Description

This is on a Xubuntu 7.04 machine functioning as an LTSP server.

#uname -a
Linux halorentz-acss 2.6.20-16-server #2 SMP Sun Sep 23 19:57:25 UTC 2007 i686 GNU/Linux

User authentication is done via an LDAP server. The /home directory is mounted over NFS from another server and users can mount their USB flash drives from the LTSP clients using LTSPFS.

On rare occasions I will find that running 'ps' will hang and the terminal becomes non-responsive. If I run 'ps awx' I get a list of processes which stops just before the "offending" process. If I then list the contents of /proc I can find the offending process ID (the next process numerically) and find out who owns it. However running 'cat' on the process's /proc cmdline file will also hang. (e.g. 'cat /proc/821/cmdline' hangs and the terminal becomes non-responsive). I can run top, but if I hit "c" to list the command line details then top hangs as well.

In the current case the offending process is "Thunar". I believe it was in the previous cases as well, but I don't recall for sure. Looking via top at the user's processes I can see that they have logged out, but there are a couple processes left:

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
  821 xxxxxxx 15 0 75608 13m 9356 D 0 0.2 0:01.01 Thunar
  824 xxxxxxx 15 0 2680 1212 884 S 0 0.0 0:00.32 gam_server
 1144 xxxxxxx 20 0 77848 1056 384 S 0 0.0 0:00.10 ltspfs
 1750 xxxxxxx 25 0 1716 524 444 S 0 0.0 0:00.01 soffice
 1766 xxxxxxx 15 0 203m 81m 58m D 0 1.0 0:14.87 soffice.bin
 7162 xxxxxxx 15 0 0 0 0 Z 0 0.0 0:00.63 Thunar <defunct>
 8770 xxxxxxx 15 0 0 0 0 Z 0 0.0 0:00.76 Thunar <defunct>

In this case it seems to be process 821 that is causing the problem.

I don't know how to reproduce this effect.

Killing the process returns everything to normal, but it seems to take quite a while to get it to quit. I tried several times before succeeding. Running 'pkill -9 -u xxxxxxx' seemed to do the trick.

Related branches

Steve Cayford (cayfo001) wrote :

Linux 2.6.24-17-generic
Xubuntu 8.04
Thunar 0.9.0

I have the same pb quiet often with no particular browsing (could be any directory). When I start another instance of Thunar, it's stuck too. The only way to get rid of that is to kill the process. What kind of output may I provide to help understanding this pb when it occures ?

Launching Thunar the same way and then running "ps aux |grep -i thunar",

sometimes I get this:

1000 6186 0.0 0.6 59668 13000 ? S 11:34 0:00 Thunar --sm-client-id 117f000101000120924840700000058170002 --daemon

and sometimes I get this:

1000 7509 1.0 0.5 56584 12340 ? Ss 11:52 0:00 thunar

What can explain this difference ?

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this issue and helping to make Ubuntu better.
Are you using FUSE at all?

Sebastien Lumineau :
When this happens, could you try to get a list similar to the way Steve did above?

> If I run 'ps awx' I get a list of processes which stops just before the "offending" process.
> If I then list the contents of /proc I can find the offending process ID (the next process numerically) and find out who owns it

Thanks again.

Changed in thunar:
assignee: nobody → charlie-tca
status: New → Incomplete

I guess so:

ii fuse-utils 2.7.2-1ubuntu2 Filesystem in\ USErspace (utilities)
ii libfuse2 2.7.2-1ubuntu2 Filesystem in\ USErspace library

Note that I have not re-experienced this problem for quite a while.
Maybe it has been solved by some kind of updates...

As soon as it occurs, I dump a current process list the way Steve did.

Changed in thunar:
importance: Undecided → Medium
Charlie Kravetz (charlie-tca) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in thunar:
assignee: charlie-tca → nobody
status: Incomplete → Confirmed

Charlie: you are doing a great triaging job, but if you don't forward the bugs to the xfce bugzilla or link to the existing bug report on this bugzilla, it's far less usefull.

It would be great if you could forward the bugs in the future.

Thank you,

Jérôme

Charlie Kravetz (charlie-tca) wrote :

 Jérôme: I am happy to report and link bugs to xfce when I know to. I am not a developer/coder, and do not always know if the bug is caused by something Ubuntu/Xubuntu did or upstream. If I can find the bug upstream, I do link it. If you let me know it should be upstream, I will gladly report it there. Thanks for helping me with this.

This bug is reported to xfce bugzilla on http://bugzilla.xfce.org/show_bug.cgi?id=4685 and linked now.

Changed in thunar:
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 0.9.99.1-0ubuntu1

---------------
thunar (0.9.99.1-0ubuntu1) jaunty; urgency=low

  * Merge from Debian pkg-xfce UNRELEASED (r2643), remaining Ubuntu changes:
    - debian/control:
      + use our Vcs-* fields.
      + build depends on gtk-doc-tools.
      + thunar-data: conflicts/replaces thunar-doc, libthunar-vfs-1-dev
        (<= 0.9.0-3ubuntu1).
    - debian/patches:
      + 06_fix-menu-icons.patch: correctly displays themed icons even if there's
        a dot in the middle of the filename (see Xfce #3614).
      + xubuntu-fix-desktop-files.patch: various fixes to desktop files:
        . make thunar and thunar-bulk-rename appear under Accessories not System
        . make destop-file-validate happy (remove 'Encoding' and 'Application;')
        . add 'OnlyShowIn="XFCE;"' to Thunar-folder-handler.desktop so that
          GNOME defaults to Nautilus and not Thunar.
  * Bugs fixed by this new release:
    - "Querying Thunar /proc directory causes hang" (LP: #162448)
    - "Thunar does not respond after second window is opened" (LP: #163587)
    - "Thunar does not show if drive is mounted" (LP: #181117)
    - "xfce desktop does not respect freedesktop desktop settings" (LP: #220318)
    - "thunar swaps behavior of forward / back (next / previous) buttons"
      (LP: #234217)
    - "Xubuntu 8.04 X64 Thunar randomly freezes - hidden files/tree view"
      (LP: #293839)
    - "Opening multiple instances of thunar causes system freeze" (LP: #317920)
  * debian/patches/02_fix-font-thumbnailer-desktop-file.patch: add missing keys
    in the font thumbnailer's desktop file (LP: #318290).

 -- Lionel Le Folgoc <email address hidden> Fri, 30 Jan 2009 14:47:35 +0100

Changed in thunar:
status: Triaged → Fix Released
Changed in thunar:
status: Unknown → Fix Released
Chris Samuel (chris-csamuel) wrote :

It's worth pointing out that this is/was a *kernel* bug not a XFCE/Thunar bug as it is the kernel responsible for how /proc behaves (and I'm seeing exactly the same issue on a headless RHEL5 IBM TSM backup server at work presently, which was how I stumbled across this report).

The "fix" that Xfce applied was to not monitor /proc which is completely unrelated to the original bug reporters problem and should not have closed this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.