right click drag&drop menu's missing

Bug #1509805 reported by Freihut on 2015-10-25
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Invalid
Medium
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

Thunar 1.6.10 & Xubuntu 15.10 (Upgraded from 15.04):

-Select random file by right clicking it and try dragging and dropping it somewhere else (normally the menu in the attached file would appear on dropping the file on the destination)

But: You can't even go this far with the selected file, because some other menu instantly appears which makes dragging and dropping some kind of impossible

A downgrade of the binary of Thunar to 1.6.6 made this gone and it behaved like expected.

Freihut (freihut) wrote :
Freihut (freihut) wrote :

I just tried to reproduce this on a Live Xubuntu (15.10): You need to have "View -> View as Detailed List (CTRL + 2)" enabled, on "View as Icons (CTRL + 1)" and "View as Compact List (CTRL + 3)" it doesn't happen.

Andy Bovett (abovett) wrote :

I can confirm that this problem is also affecting me, and is a significant regression as this is the way I normally use Thunar.

Andy Bovett (abovett) wrote :

I have found a work-around for this bug. Instead of right clicking and dragging on the icon or file name, right click and drag on the size or file type (i.e. in one of the other columns) .
Not a fix, but does make it usable.

Florian (burna1) on 2015-12-06
Changed in thunar (Ubuntu):
status: New → Confirmed
In , Florian (burna1) wrote :

Created attachment 6554
The drop-menu is missing

It is not possible to drag a file in Thunars detail view, with a right-click on the name-column of a file. Thunar will show the context-menu of the file immediately. This is inconsistent, as it works in the other views - but not in detail view. In Thunar 1.6.6 it worked as expected.

The goal is to use the "drop-menu" - "Move here"/"Copy here"/"Link here"

Expected behaviour:
1) right click on filename, keep mouse-button pressed
2) drag the file over a folder
3) drop, release the mouse-button
4) Thunar shows the drop-menu (attachment: missing_menu.png)

This works in the other views, but not in detail-view.

Actual behaviour:
1) right click on filename, keep mouse button pressed
2) Thunar shows context-menu of the file immediately

A workaround is to select the file, then right-click on another column of the file and start the drag&drop, this works and shows the drop-menu.

This bug has originally been reported on https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/1509805

Changed in thunar:
importance: Unknown → Medium
status: Unknown → Confirmed

If the view in Thunar is set as "View as Icons", right click and drag simply copies the file(s) over to the new location. There is no menu displayed when the files are dropped at the destination.

I have also tried the right-click and drag with the view in Thunar set as "View as Detailed List". I still get no menu when I drag and drop at the new location.

xfce4-about-4.13.4-20.fc29.x86_64
libxfce4util-4.13.2-20.fc29.x86_64
libxfce4ui-4.13.4-20.fc29.x86_64
xfce4-panel-4.13.4-1.fc29.x86_64
xfce4-notifyd-0.4.2-20.fc29.x86_64
xfce4-session-4.13.1-20.fc29.x86_64
xfce4-session-engines-4.13.1-20.fc29.x86_64
xfce4-settings-4.13.5-2.fc29.x86_64
Thunar-1.8.2-1.fc29.x86_64

Thats a known regression of 1.8.x and as well seems to be still a problem for thunar 1.6.x

 Hope I will have time to look into it soon

- Closed as a duplicate -

*** This bug has been marked as a duplicate of bug 14583 ***

Changed in thunar:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.