Scroll Position Jumps To Marked Item

Bug #1452943 reported by Ang Bongsong on 2015-05-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
thunar
Fix Released
High
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

This bug applies to thunar 1.6.7 from the Xubuntu Developers Team Xfce 4.12 PPA (https://launchpad.net/~xubuntu-dev/+archive/ubuntu/xfce-4.12).

Simply, if you select an item in thunar, then scroll up or down away from it, thunar will scroll back to the marked item so it is in view. Very annoying. More info and a fix here: https://bugzilla.xfce.org/show_bug.cgi?id=11855

Steps to reproduce:
1. Open a folder that contains more files than can be displayed (=> scrollbar present)
2. Mark the last file in folder
3. Slowly scroll towards the top (e.g., using mouse wheel)

In my case the scroll position jumps back to the marked file at the bottom.
Similar "jumping" effects occured when marking all files in a scrollable folder.

When rolling back thunar v1.6.6 the problem does not occur at all.

If there is any more information I can provide, just let me know.

That happens to me too, but only when tumblerd is working on the current folder

If all the thumbnails has been building before, everything is ok.

In , gniger (leeper) wrote :

Can confirm with thunar 1.6.7 in arch linux.

Yes, this is annoying. The tumblerd hint is quite valuable, maybe it can help with debugging.

Tracked it down, it is caused by http://git.xfce.org/xfce/thunar/commit/?id=4d19f45feb198b3a580ef2f777e2c50be2e3a0d3:

commit 4d19f45feb198b3a580ef2f777e2c50be2e3a0d3
Author: Harald Judt <email address hidden>
Date: Tue Mar 31 22:05:22 2015 +0200

    Restore selection on row changes too (bug #9886)

Despite the commit message, this does not exactly fix bug #9886 (which has been fixed by a separate commit), but it deals with related issues, e.g. when renaming files and their position in the view changes (for all views).

Fixing both issues is not quite trivial, need much more time looking into this.

On second thought, the model emits a "rows-reordered" signal which from a quick glance is not processed by any views. Calling the selection-restore code from there might be a better idea.

Created attachment 6226
call-selection-restore-only-when-rows-reordered-signal-is-received.patch

For a start, this patch should fix most issues.

Created attachment 6227
keep-the-scroll-position-when-restoring-the-file-selection.patch

Test case:

1) mkdir test
2) cd test
3) while true; do for i in a aa aaa b bb bbb c d e eee ff gg kk lll l x y g h i zz z u uu uuu xxxxx cb; do touch "$i"; sleep 1; done; done
4) open thunar window for this dir, switch ordering to modification date
5) make sure the window is not big enough to show all files
6) select a file and watch

Behaviour without the patch: View always tries to keep the selected file in the visible area.

Behaviour with the patch: View will not try to keep the selected file in the visible area.

I hope this patch has no bad side-effects for operations. In that case, one could still call scroll_to_file manually.

description: updated
Changed in thunar:
importance: Unknown → High
status: Unknown → Fix Released
tags: added: xfce-4.12 xubuntu-dev
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed

I can confirm this bug with thunar 1.6.6 xfce-412 ppa (Xubuntu 14.04.2)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.