Unable to expand directories in the tree pane and remain in the current directory

Bug #1424774 reported by Elfy on 2015-02-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Thunar File Manager
Fix Released
Medium
thunar (Ubuntu)
Low
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

Thunar 1.6.5 will longer expand directories in the tree pane while remaining in the current directory. Every time I click on one of the little triangles to expand the tree, Thunar navigates to that directory. Prior to 1.6.5 the tree could be expanded without changing the current directory when clicking on one of the little triangles.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: thunar 1.6.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Mon Feb 23 19:00:54 2015
InstallationDate: Installed on 2015-02-20 (3 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150219)
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Thunar 1.6.5 will longer expand directories in the tree pane while remaining in the current directory. Every time I click on one of the little triangles to expand the tree, Thunar navigates to that directory. Prior to 1.6.5 the tree could be expanded without changing the current directory when clicking on one of the little triangles.

I liked the old navigation better where clicking on a directory icon or name would take you to that directory and clicking the triangle would just expand the directory tree.

My system is Arch Linux x86_64. I also posted to the Xfce forum at https://forum.xfce.org/viewtopic.php?id=9423.

Thanks in advance for any consideration towards restoring the prior tree behavior.

Fixed by hjudt. Compiled and tested working. Resolving ticket.

Elfy (elfy) wrote :
Changed in thunar:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed

Well, i'm not sure that this should be called a "bug". It's more or less a matter of taste. It's up to the developers what they like or want. Personal i prefer this new tree "handling". However, it good way would be to add an UI option, that users can choose what they want. Maybe the "default" setting should be the old way. Just my thoughts :-)

Well, i'm not sure that this should be called a "bug". It's more or less a matter of taste. It's up to the developers what they like or want. Personal i prefer this new tree "handling". However, it good way would be to add an UI option, that users can choose what they want. Maybe the "default" setting should be the old way. Just my thoughts :-)

Changed in thunar (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Low
Changed in thunar (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.5-0ubuntu2

---------------
thunar (1.6.5-0ubuntu2) vivid; urgency=medium

  * debian/patches:
    Cherry pick 3 patches from upstream to fix bugs.
    - git_dont-move-on-expander-click.patch added, fixes LP: #1424774.
      Regression, clicking an expander in the treeview would also move there.
    - git_fix-endless-rename-loop.patch added.
      Error dialog appears forever repeatedly after clinking 'Close' button,
      so it cannot be canceled or re-rename.
    - git_hide-template-file-extensions-in-context.patch added.
      Hide template file extensions in context menu.
 -- Unit 193 <email address hidden> Mon, 23 Feb 2015 13:53:17 -0500

Changed in thunar (Ubuntu):
status: Triaged → Fix Released
Paul White (paulw2u) wrote :

Closing as all other bug tasks showing "Fix Released"

Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.