Thunar behaves inconsistently with USB flash drive FAT32 partitions

Bug #1332623 reported by Richard Elkins on 2014-06-20
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
Undecided
Unassigned
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Xubuntu 14.04 and performed no customizations or reconfigurations.

Observation: Thunar 1.6.3 ("File Manager" from menu) on Xubuntu 14.04 handles write permission to inserted USB flash drives inconsistently:
* I am able to create a nil file on the flash drive with Thunar and edit it. Clearly, the flash drive is not read-only.
* Using Thunar, I cannot copy an existing file (E.g. ~/.profile) and paste it on the flash drive - "destination is read-only" (not true!).
* However, in a terminal window, `cp` with the flash drive as a destination succeeds.

I tried this on drives by different manufacturers and with differing capacities and on two different Xubuntu 14.04 installations.

There might be a configuration change for Thunar to allow paste to flash drives. If so, this should be enabled when Thunar is installed as this behaviour is what users expect.

Note: I created the FAT32 partition with `gparted` on Linux. I also got the same results after creating a FAT32 partition using an MACOSX system.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: thunar 1.6.3-1ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: XFCE
Date: Fri Jun 20 11:30:40 2014
InstallationDate: Installed on 2014-06-19 (1 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Richard Elkins (texadactyl) wrote :
description: updated
description: updated
description: updated
Richard Elkins (texadactyl) wrote :

Still an issue in Thunar 1.6.3 (Xfce 4.10) of Xubuntu 14.04.2.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1332623

tags: added: iso-testing
Richard Elkins (texadactyl) wrote :

Still an issue in Thunar 1.6.6 (Xfce 4.12) of Xubuntu 15.04.

I copied a directory tree to the flash drive with `cp -r` in a terminal windows since I cannot paste with Thunar. I observed that with Thunar, I can delete (bypass trash) the tree on the flash drive and I can also move the tree from the flash drive to the trash.

Humorously, I cannot create by pasting with Thunar but I can destroy with Thunar!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
Richard Elkins (texadactyl) wrote :

Using Thunar 1.6.10 and a FAT32 USB-drive which is automatically-mounted in Xubuntu 16.04.Beta-2:

I can now paste to the USB drive, both files and folders.
With files and folders, I can still delete or move to Trash.
And, I can still edit files.

Finally, the automatically-mounted FAT32 USB-drive behaves exactly the way one would expected.
Thank you!

Changed in thunar (Ubuntu):
status: Confirmed → Fix Released
MDE (mde-bs) wrote :

I've found this bug on Ubuntu 17.10 with Thunar version 1.6.12-1 yesterday, and after a bit digging found the root cause in the gio part of glib:

https://bugzilla.gnome.org/show_bug.cgi?id=787731

They have found it using Nautilus earlier and created a fix, which was released in glib-2.55. Unfortunately the newest libglib2.0-0 available in Ubuntu (artful and bionic) is 2.54.1-1ubuntu1 which doesn't contain the fix.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.