[SRU] Thunar don't refresh directory on content change

Bug #1300398 reported by Jakub T. Jankiewicz on 2014-03-31
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
Medium
Gianfranco Costamagna
Bionic
Medium
Unassigned
Eoan
Medium
Unassigned
Focal
Medium
Gianfranco Costamagna

Bug Description

[ Info ]
When something change in directory, like saving (creating new) file, from terminal or just calling save as (for instance in inkscape or create compresed file using context menu) the file don't appear in directory (you need to hit F5 to refresh the view).

[ Steps to reproduce ]
To reproduce you can for instance,

1. Right click inside directory and create new file (it will appear)
2. Open terminal and go to the same directory
3. Remove the file from terminal

The file will not disappear from directory in Thunar.

Xubuntu 13.10, Thunar 1.6.3 package: 1.6.3-1ubuntu1(saucy)

[Regression potential]
* none, this is part of upstream code, and its a force of a refresh function in a particular situation

description: updated
Jakub T. Jankiewicz (jcubic) wrote :

It seems it invalid, when I restart system everything seems fine.

Changed in thunar (Ubuntu):
status: New → Invalid
Jakub T. Jankiewicz (jcubic) wrote :

It seem that this happen again after I run the system for a while. don't know what trigger this.

Changed in thunar (Ubuntu):
status: Invalid → New

Testing Xubuntu 15.04 currently. I cannot reproduce the described issue. However, if I rename the file instead, then it will disappear in Thunar (until next content refresh is triggered).

https://bugzilla.xfce.org/show_bug.cgi?id=11430

Changed in thunar (Ubuntu):
status: New → Incomplete

ApportVersion: 2.20.1-0ubuntu1
Architecture: amd64
CurrentDesktop: XFCE
DistroRelease: Ubuntu 16.04
InstallationDate: Installed on 2016-03-12 (25 days ago)
InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20160224)
Package: thunar 1.6.10-2
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 4.4.0-17.33-generic 4.4.6
Tags: xenial third-party-packages
Uname: Linux 4.4.0-17-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

tags: added: apport-collected third-party-packages xenial

apport information

apport information

apport information

Pavlushka (pavelsayekat) on 2016-04-15
Changed in thunar (Ubuntu):
status: Incomplete → Confirmed
Changed in thunar (Ubuntu):
importance: Undecided → High

This bug has been around for quite some time now (+ 3 years!). No activity and/ or solutions?

Angger B. Pinasti (anggerbp) wrote :

in my case, pressing f5 or refresh doest fix anything. worse, it display the wrong file; it's displaying file "A"; name is file "A", thumbnail is file "A" -- but if I open it, or worse, permanently delete it, it refers to another file. it could be the file I just edited. Disastrous file loss.

I have to go to parent folder then go forward to that folder again (using back doesn't fix in once occurence, yea, well, coz when this occur, it's too late to realize so I can't test it using diferrent approach coz, well, the bug already gone (or hide, maybe)).

it happens in random occurence, mostly like this:
0. let's say there's file A, B, C, D, E
1. edit a png/svg (gimp/inkscape) directly from thunar, say file A, and let thunar open.
2.a. After quite long period editing, save it or save as in the same dir, it happens.
2.b. More often, while saving progress almost done (or when progress bar likely stop a while),
     quickly switch to/raise thunar and wait for the file.
3. In my case visually it's file "A", but in fact, it's another file (file B).
   And file A is displayed as file E. So:
   * Visually, the file is in correct order ( A, B, C, D, E)
   * but phisically (or what should I called it?) it is B, C, D, E, A
   * the order is still following my sorting option, i.e, above is sort by name,
     if I sort by type, i.e. original sort is A, C, E, B, D, then 'phisically' the result is
     C, E, B, D, A.
   * I'm not quite remember whether changing sorting opts fix it or not
   * also can't remember right click > properties is the right or wrong file

System:
ubuntu 16.04.2 32 i686
using patch from this article http://tqdev.com/2016-xubuntu-16-04-thunar-crashes-on-rename
to patch another issue
thunar 1.6.10 xfce 4.12

Angger B. Pinasti (anggerbp) wrote :

Oh, one more, it's mostly (if not always) when saving/editing using gimp or inkscape, or renaming picture (mostly when renamed pic is opened with pic viewer). office that use preview
like libre, more often crash (close) thunar than displaying wrong thumb. (I moved to wps then).

David (david-9ei9nyjpwdex) wrote :

In my case if I run another program like gprename to rename some files in a folder when thunar is open showing those same files, it not only does not update but typically hangs and eventually terminates.

Angger B. Pinasti (anggerbp) wrote :

Still happen in thunar 1.6.11 Xfce 4.12.0 (X)Ubuntu 16.4.3 when editing svg file with inkscape. Also when exporting it to png files (still with inkscapes). never happen with plain text file. refresh does nothing. should go up to parent and go to that folder again to "real refresh" it.

thumbnailing problem? inkscape problem?

Stefan Wagner (wagner-stefan) wrote :

I'm curious, since I have the same problems in combination inkscape/thunar and thought it was a pure thunar problem, but it obviously isn't.

I created a textfile a1.txt, while thunar is open, iconview activated and order by modification time descending, so that the most recent file is on top.

"Save as..." a2.txt shows immediately a new file a2.txt, the marked a1.txt moves to the right, iconview and the filename in the thunar window is in sync with the filename, according to the statusbar.

But I often produce a SVG file a.svg, export a PNG a.png, and now the newest one is a.png. But the exportname gets stored in the SVG, so the SVG is marked as unsaved changed in Inkscape with an asterix, so shortly thereafter I will save the SVG again, so it changes Position with the PNG in Thunar, but it doesn't - maybe influenced by the fact, that both previews render the same output.

So the big window shows the files in wrong order or better said with wrong names and previews. Because the cursor, the marking of the file stays on the svg-file, changing position between 1 and 2 depending on the age and the statusbar seems always in sync with the real file upon which is acted, for instance, if I delete it or open it or something else in Thunar.

Is it suitable to append an ogv-Video of nearly 10 Mb? I try it, remove it, if unwanted.

alexxcons (alexander.schwinn) wrote :

Possibly fixed upstream: https://bugzilla.xfce.org/show_bug.cgi?id=12435

Please first verify, since comment #1 sounds like a slightly different bug .. however the later comments fit well for 12435
( For 12435 "F5"/refresh did not help. Re-enter the folder helped. Deleting the modified file will crash thunar )

This bug is not inkscape related, it appears for all types of thumbnails (e.g. .png, .jpg ... )
- You need to use icon view or compact view to reproduce
- You need to select view --> sort --> by modification date

For a simple reproduce, you may use the testers of these duplicates:
https://bugzilla.xfce.org/show_bug.cgi?id=14173
https://bugzilla.xfce.org/show_bug.cgi?id=14288

I uploaded a fix here:
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/costamagnagianfranco-ppa/+build/18202090

it might fix not all the refresh issues, but I have confirmations about an improvement of the current status-quo

Changed in thunar (Ubuntu):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
description: updated
Changed in thunar (Ubuntu):
status: Confirmed → In Progress
summary: - Thunar don't refresh directory on content change
+ [SRU] Thunar don't refresh directory on content change

I plan to fix only bionic since eoan and focal should be already ok

Changed in thunar (Ubuntu Focal):
status: In Progress → Fix Released
Changed in thunar (Ubuntu Bionic):
status: New → In Progress
Changed in thunar (Ubuntu Eoan):
status: New → Incomplete
status: Incomplete → Fix Released

Hello Jakub, or anyone else affected,

Accepted thunar into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/thunar/1.6.15-0ubuntu1.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in thunar (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jakub T. Jankiewicz (jcubic) wrote :

Sorry, I'm not able to test this anymore since I don't use Ubuntu anymore, I'm using Fedora (right now release 29), but I don't see the issue on this system, so maybe the upstream fix is working, I'm not sure If I ever had this issue on Fedora.

Mathew Hodson (mhodson) on 2019-12-28
Changed in thunar (Ubuntu Bionic):
importance: Undecided → Medium
Changed in thunar (Ubuntu Eoan):
importance: Undecided → Medium
Changed in thunar (Ubuntu Focal):
importance: High → Medium

I went ahead and tested it:
Setting up libxfce4ui-common (4.13.4-1ubuntu1) ...
Setting up libexo-common (0.12.2-0ubuntu0.18.04.1) ...
Setting up libxfce4util-common (4.12.1-3) ...
Setting up libexo-helpers (0.12.2-0ubuntu0.18.04.1) ...
Setting up libxfce4util7:amd64 (4.12.1-3) ...
Setting up libxfce4util-bin (4.12.1-3) ...
Setting up libexo-2-0:amd64 (0.12.2-0ubuntu0.18.04.1) ...
Setting up xfconf (4.12.1-1) ...
Setting up libxfconf-0-2 (4.12.1-1) ...
Setting up libxfce4ui-1-0:amd64 (4.13.4-1ubuntu1) ...
Setting up libxfce4ui-2-0:amd64 (4.13.4-1ubuntu1) ...
Setting up libexo-1-0:amd64 (0.12.2-0ubuntu0.18.04.1) ...
Setting up exo-utils (0.12.2-0ubuntu0.18.04.1) ...
Setting up libthunarx-2-0 (1.6.15-0ubuntu1.18.04.1) ...
Setting up thunar (1.6.15-0ubuntu1.18.04.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

The directory deleted with rm -rf on my bash terminal has been refreshed automatically in thunar

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.15-0ubuntu1.18.04.1

---------------
thunar (1.6.15-0ubuntu1.18.04.1) bionic; urgency=medium

  * debian/patches/bf4c333dbca1de6cd384e68a5caff027808a48bd.patch:
    - cherry-pick upstream fix for refresh issue (LP: #1300398)

 -- Gianfranco Costamagna <email address hidden> Mon, 02 Dec 2019 22:40:55 +0100

Changed in thunar (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for thunar has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.