Missing terminal and search in right click menu (detail view)

Bug #1256110 reported by Carsten Holzmüller on 2013-11-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunar
Invalid
Low
thunar (Debian)
Confirmed
Unknown
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using the detail view in thunar.

When I right-click on a empty space in a open thunar window, I have useful actions. I can open a terminal in the directory or I can search in the directory. I have also the paste-function for copy&paste.

That's all wonderful but it requires an empty space but a directory with many files in detail view has no empty space. So there is no way to use those actions easily.

Is it possible to add those actions in the right-click menu (or in a sub-menu)?

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: thunar 1.6.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Thu Nov 28 21:26:03 2013
InstallationDate: Installed on 2012-10-23 (401 days ago)
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
MarkForUpload: True
SourcePackage: thunar
UpgradeStatus: Upgraded to saucy on 2013-11-27 (0 days ago)

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070531 CentOS/1.5.0.12-1.el5.centos Firefox/1.5.0.12
Build Identifier:

The detailed list mode is my favorite mode, given the excellent speed of thunar, this mode makes it very speedy to find and sort files.

For folders with small amout of files, i.e. the detailed list is shorter than the height of the window, you can always right click on the white area in the bottom of the window to bring up the directory context menu, to create new sub-folders or open shell for the current folder.

However, for folders containing a long detailed list (i.e. longer than the window), you can not bring up the directory context menu with right click: any right click will select the file at the cursor position and the context menu of the file will pop up.

I know you can always create sub-folders or open shell with menu, but just for the sake of GUI consistancy and convenient, I would like to see someway to allow users to continue using right-click to access the current directory menu under this situation. (maybe with a key-pressed, or any thing that the developers would think is consistant here)

Reproducible: Always

Steps to Reproduce:
1.find a directory containing many many files
2.view it in detailed list mode
3.try to right click to get the context menu to create subfolders or open terminal

Actual Results:
you can not get the directory context menu for long detailed list view by right click

Expected Results:
right click on some part of the window allows you to open the context menu as you does in a directory with a shorter file list

an area or specific combination with right click can bring up the directory context menu

In , Rff1917 (rff1917) wrote :

A suggestion: why not add an option named "Full Row Selection" or something?

When you set this option to "off", a selection would only activate the file name, instead of activating the full row, just like in MS Windows Explorer.
The "white area" would now cover everything on the right of the file list and you'd be able to right-click and get the usual context menu.

In , upkpk (upkpk) wrote :

I can confirm this in Thunar 1.0.2.

In detailed list view, for folders containing a long detailed list (i.e. longer than the window), you can not bring up the directory context menu with right click: anyright click will select the file at the cursor position and the context menu of the file will pop up.

It could be good to force an empty line at the end of the list, to allow showing the right-click folder context menu.

*** Bug 5252 has been marked as a duplicate of this bug. ***

This bug is quite an irritation! I frequently want to 'open a terminal here' but have to change view to be able to.

Incidentally, this bug (3386) is almost a duplicate of bug 2444 "Open Terminal Here not always available", which also relates to bug 2959 "Feature request: gtk-accelerator for 'Open Terminal Here'".

https://bugzilla.xfce.org/show_bug.cgi?id=2444
https://bugzilla.xfce.org/show_bug.cgi?id=2959

Would it be ok if instead of a right-click menu for the folder, the items that would show up in the right-click menu instead appeared in the "File" menu?

(In reply to comment #5)
> Would it be ok if instead of a right-click menu for the folder, the items
> that would show up in the right-click menu instead appeared in the "File"
> menu?

I think just for consistency with Windows and other file managers, there should be a place in the list where it's safe to right-click.

This has bugged me for a long time -- I finally came to file a bug because someone else complained about it in a Slashdot thread as "the one thing they don't like about Thunar."

In , 8-nick (8-nick) wrote :

Pushed a fix to show the menu with Ctrl + 3rd click.

(In reply to comment #7)
> Pushed a fix to show the menu with Ctrl + 3rd click.

I don't mean to undermine your efforts, but I don't think this fixes the issue for two reasons:

1. People expect right click -> paste to work somewhere within the window. Everybody else works this way.

2. I'm only right clicking (as opposed to ctrl+v) in the first place because I'm working one-handed. Usually I have my left hand wedged in the waistband of my pants like Al Bundy and I'm too lazy to move. This doesn't help me then =)

Nautilus does not select the file when it is clicked with RMB, and displays a directory context menu instead. This seems like a reasonable solution (just right-click on an unselected file).

I agree that Ctrl+RMB can be a bit obscure.

In , 8-nick (8-nick) wrote :

Fine by me, ctrl is not needed anymore. Unselected items will unselect all and show the cwd menu.

Changed in thunar:
importance: Unknown → Wishlist
status: Unknown → Fix Released
Changed in thunar (Debian):
status: Unknown → Confirmed

In what sense is that bug fixed? I don't understand how I am supposed to open a terminal for the current folder in the list view. Is it an accident?

(In reply to Steve Dodier-Lazaro from comment #11)
> In what sense is that bug fixed? I don't understand how I am supposed to
> open a terminal for the current folder in the list view. Is it an accident?

It's not, at least as of Thunar 1.6.3 (neither is the bug marked as a duplicate).

Here is all we're trying to accomplish:

1) Open Thunar
2) Choose View -> View as Detailed List from the menu
3) Right click a file in $HOME, and choose "Copy"
4) Navigate to /usr/bin
5) Try to right click to paste the file
6) You can't, because everywhere you could right click selects a file, and gives you the file context menu.

Can someone please change the status back to NEW?

Reopening the report.

A note to devs / people willing to write a patch: the location bar, in "button" mode, provides a facility to paste into folder. It does not when in "toolbar" mode, but e.g. the folder icon directly left of the path could be given a right click menu *identical* to the buttons in the other location bar mode. That'd provide at least a hidden way to provide this (and future) feature(s).

One could also add a "Parent Folder" submenu to items in the list (right after/before the actions, but not at the end since the end is a convenient shortcut for Properties) and give that parent folder the *same* content as location bar buttons.

Any other Design SIG input is very welcome...

Changed in thunar:
importance: Wishlist → Low
status: Fix Released → Confirmed

For the record, I have implemented an experimental patch for this here:
http://git.xfce.org/users/hjudt/thunar/commit/?h=details-view-selection&id=89c7dc4aad1ecea7622a69fb6e57a8bd139dd699

However, it does more than that and also changes the drag&drop and rubber-band selection behaviour.

(In reply to Harald Judt from comment #14)
> For the record, I have implemented an experimental patch for this here:
> http://git.xfce.org/users/hjudt/thunar/commit/?h=details-view-
> selection&id=89c7dc4aad1ecea7622a69fb6e57a8bd139dd699
>
> However, it does more than that and also changes the drag&drop and
> rubber-band selection behaviour.

Very nice! I'm trying it, and it's soooo much better.

*** Bug 2444 has been marked as a duplicate of this bug. ***

Resolving duplicate.

*** This bug has been marked as a duplicate of bug 11605 ***

Changed in thunar:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.