Thunar works, closes okay, then cannot have new window

Bug #1253713 reported by gouri on 2013-11-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

Summary: Thunar works, closes okay, then cannot have new window, even killing all thunar processes and restarting

I have had this bug several times for the last few days, not before.

# Context

Normal xubuntu session.

# How to reproduce

* Launch thunar (actually, used from the shortcut dock app: click , it shows shortcut, click on one, it opens a new thunar window)
* Use thunar, it works normally.
* Close all thunar windows (not sure if necessary).
* Might be related to using fuse and/or remote features (or not, not known at this time).
* Then something must have happened because thunar no longer works. Impossible to launch a new window.

Try these actions:

* in the shorcut dock app, click see shortcuts, click on any (for example home dir)
* in a shell type "thunar"
* in a shell type "Thunar"
* same but first do "killall thunar Thunar"

## Expected behavior

Any of the actions above should open a new thunar window.

## Observed behavior

These actions launch a new process but no window appear.

## Additional information

* Attaching the result of: "strace -f thunar".
* Nearly all lines appear immediately, then just a few more, then nothing more.
* Running other instances of thunar does not cause more output from the strace'd one.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: thunar 1.6.3-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Thu Nov 21 17:43:07 2013
MarkForUpload: True
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

gouri (stephane-gourichon-lpad) wrote :
gouri (stephane-gourichon-lpad) wrote :

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu

lsb_release -rd

Description: Ubuntu 13.10
Release: 13.10

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center

LC_ALL=C apt-cache policy thunar

thunar:
  Installed: 1.6.3-1ubuntu1
  Candidate: 1.6.3-1ubuntu1
  Version table:
 *** 1.6.3-1ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
        100 /var/lib/dpkg/status

Regards,

gouri (stephane-gourichon-lpad) wrote :

Closing session normally then logging again (without a system reboot) fixes the problem in the short term.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers