thunar custom keyboard shortcuts are lost upon logout

Bug #1186846 reported by Forest on 2013-06-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Unknown
Unknown
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

Thunar accepts my custom keyboard shortcuts (set via the standard GTK editable menu accelerator feature) and honors them for the current session, but loses them when I log out. The next time I log in, I find the default keyboard shortcuts have returned.

This seems to be related to the way Thunar shuts down. If I kill the Thunar background process that Xfce creates at login time, then launch a new Thunar instance and customize my keyboard shortcuts, then close all Thunar windows before logging out, my shortcuts persist.

I'm getting the impression that Thunar doesn't bother saving customized keyboard shortcuts when they're defined, intending to save them at exit time instead, but failing to do so when exiting due to the user logging out.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
xkill (info-xkill) wrote :

I set a new hotkey to show desktop.

$ xfconf-query --channel xfce4-keyboard-shortcuts --property "/xfwm4/custom/<Super>d" --reset
$ xfconf-query --channel xfce4-keyboard-shortcuts --property "/xfwm4/custom/<Super>d" --create --type string --set "show_desktop_key"

This works until the next restart. Then the new hotkey is lost.

Martin Pitt (pitti) on 2014-04-09
Changed in thunar (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.3-1ubuntu5

---------------
thunar (1.6.3-1ubuntu5) trusty; urgency=medium

  * Add git-save-keyboard-shortcuts.patch. LP: #1186846
    - Keyboard shortcuts save when changed rather than when thunar is closed
  * Add menu-icon-tweaks.patch. LP: #1271861
    - Don't use generic folder icons for open with default application
    - Add icons for open in new tab, new window
  * Add git-force-toolbr-icons.patch
    - Fix for "Home" and "Open Parent" icons going missing from toolbar
 -- Jackson Doak <email address hidden> Sat, 05 Apr 2014 08:22:40 +1100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.