thunar crashed with SIGSEGV

Bug #1176354 reported by Eliah Kagan on 2013-05-04
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

I ran thunar 1.6.2-0ubuntu1 remotely via ssh -X; the server (on which it ran) was Raring i386. The desktop environment on the *client* (in case this is an interface problem) is LXDE; the client is an Lubuntu Oneiric i386 system. Notification area integration (for the "tray icon" accompanying file copy dialogs) worked fine.

I was copying a number of files--in a single job, not multiple simultaneous jobs--from an ext4 volume to an NTFS volume. During the copy operation, I clicked on a volume on the list on the left. This was in one open tab. Then I switched to another open tab. Either at that point, or soon thereafter, Thunar segfaulted.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: thunar 1.6.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
Date: Sat May 4 09:18:00 2013
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/thunar
ExecutableTimestamp: 1356872238
InstallationDate: Installed on 2005-04-15 (2940 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327.1)
MarkForUpload: True
ProcCmdline: thunar
ProcCwd: /home/ek
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: thunar
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
Title: thunar crashed with SIGSEGV
UpgradeStatus: Upgraded to raring on 2013-03-20 (45 days ago)
UserGroups: adm cdrom dip lpadmin netdev plugdev sambashare sudo

information type: Private → Public

StacktraceTop:
 ?? ()
 thunar_device_operation_finish (object=0xb9e41d80, result=0xb91322f0, user_data=0xb9b2c820) at thunar-device.c:258
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers