regression: thunar no longer shows all unmounted, but mountable, volumes in sidepane

Bug #1068947 reported by Jamin W. Collins on 2012-10-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
Medium
Unassigned

Bug Description

Thunar no longer shows available (but unmounted drives) on the left-hand side (side pane), instead they are only visible under "computer:///", which is not listed under the "Go" menu at all and must be manually entered.

Even after one of these volumes is mounted it still isn't listed in the side pane.

Volumes in question are lvm logical volumes on a removable drive.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: thunar 1.4.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.1-0ubuntu3
Architecture: amd64
Date: Fri Oct 19 21:08:19 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: Upgraded to quantal on 2012-10-12 (7 days ago)

Related branches

Jamin W. Collins (jcollins) wrote :
tags: added: unreproducible
removed: regression-release
Jamin W. Collins (jcollins) wrote :

Please stop removing tags without providing details of what you tried in attempting to reproduce this. As indicated in the description this is for unmounted LVM volumes.

See the attached screen shot for illustration of the issue. Note that "vms", "qpc", "games", and "smb-backups" are not listed in the left hand side pane.

Lionel Le Folgoc (mrpouit) wrote :

The tag regression-alert should only be used for SRUs, that's why I removed it (I added the unreproducible tag by mistake because I was touching your second bug at the same time, sorry).

tags: removed: unreproducible
Lionel Le Folgoc (mrpouit) wrote :

(Bwarf, you used regression-release and not regression-alert... I misread, sorry.)

Anyway, support of lvm partitions is a bit flaky, I'm not sure if it depends on Thunar, gvfs or udev. For example, previously, too many volumes were shown (Bug #876823, I had to use udev rules with UDISKS_PRESENTATION_HIDE to hide them), but the code in Thunar hasn't changed much since then, so it's probably a change of behavior in gvfs/udev/something else.

If you have a machine to do some tests, you can try the new development release of thunar (1.5.0, will become 1.6.0 with Xfce 4.12) at <https://launchpad.net/~xubuntu-dev/+archive/xfce-4.12>. The sidepane and mounting code has been rewritten, so maybe your issue is fixed already. You can also try with another gtk file manager, like nautilus or pcmanfm.

Jamin W. Collins (jcollins) wrote :

Nautilus shows them just fine, see the attached.

Jamin W. Collins (jcollins) wrote :

The proposed Thunar package resolves the issue, see attached screen shot.

Lionel Le Folgoc (mrpouit) wrote :

Thanks for testing. This means the issue will be fixed in Xfce 4.12 (however, there have been so many changes in Thunar 1.5.0, it's not backportable to quantal unfortunately I'm afraid).

Changed in thunar (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: fixed-in-master
Changed in thunar (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.0-0ubuntu1

---------------
thunar (1.6.0-0ubuntu1) raring; urgency=low

  * Upload to raring.
  * Remaining Ubuntu change:
    - debian/control: recommend udisks2 for mounting devices. lp: #1014632
  * Drop obsolete Ubuntu changes:
    - debian/patches/02_guard-for-no-supported-vfs-schemas.patch,
      debian/patches/xubuntu_fix-duplicate-volumes.patch: included upstream.
  * Bugs fixed:
    - "Thunar: sendto_printer broken" lp: #1061846
    - "segfault when a specific html file is selected" lp: #751739
    - "can't book mark remote shares" lp: #778268
    - "Thunar crashed with SIGSEGV in thunarx_menu_provider_get_file_actions()
      thinking a directory was a file" lp: #852410
    - "Left or right-clicking on 3MB or bigger svg file is unresponsive"
      lp: #893330
    - "Thunar crashed with SIGSEGV in fast_validate()" lp: #913041
    - "Thunar crashed with SIGSEGV in thunar_file_get_display_name()"
      lp: #931101
    - "Thunar crashed with SIGSEGV in sort_by_mime_type()" lp: #931842
    - "Thunar crashed with SIGSEGV in thunar_util_parse_parent()" lp: #969222
    - "thunar crashed with SIGSEGV in thunar_standard_view_cancel_thumbnailing()"
      lp: #1059397
    - "Does not unmount USB drive when you try first time" lp: #1059997
    - "regression: thunar no longer shows all unmounted, but mountable, volumes
      in sidepane" lp: #1068947
    - "Thunar shows folder sizes wrong" lp: #59235
    - "Right-click "Open With" list not refreshing" lp: #107392
    - "no thunar contextmenu with GTK setting "gtk-menu-popup-delay = 0""
      lp: #127372
    - "rename folder, still active but answers not on 'Enter'" lp: #479975
    - "Thunar hangs on first launch of each session" lp: #775117
    - "emblems disappear on rename" lp: #877755
    - "Remote Deleted file in Thunar remains visible until resfresh" lp: #999824
    - "Incorrect alphabetical sort order in thunar with non-latin (eg. cyrillic)
      file names" lp: #684317
    - "Thunar does not display current folder name" lp: #875193
    - "Thunar crashed with SIGSEGV in g_file_equal()" lp: #900306
    - "Hard to see, if volume is mounted or not" lp: #838917

thunar (1.6.0-1) UNRELEASED; urgency=low

  [ Lionel Le Folgoc ]
  * Drop the "Send to printer" action, xfprint4 is obsolete.
  * debian/control:
    - dropped libtdb-dev from b-deps, emblems have been moved to gvfs.
    - bumped minimum required exo version to 0.10.0 for the new symbol.

  [ Yves-Alexis Perez ]
  * New upstream release.
 -- Lionel Le Folgoc <email address hidden> Mon, 03 Dec 2012 13:13:58 +0100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers