not able to automount usb flash drives

Bug #1090974 reported by Hennadiy Brych on 2012-12-16
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Thunar Volume Manager
Unknown
Unknown
thunar-volman (Ubuntu)
Undecided
Unassigned

Bug Description

On my desktop Xubuntu 12.10 x86_64 system USB flash drive automounting isn't working. I have also fresh installation of Xubuntu 12.10 x86_64 for my laptop, and there I am able to successfully mount USB flash drive approximately every 5th try, by constantly reinserting USB stick until it'll mount. I believe that root cause of these two problems is the same.
Before anyone will ask about XFCE configuration:
1. Settings Manager -> File Manager -> Advanced -> Volume Management is turned on
2. Settings Manager -> Removable Drives and Media -> Storage -> Mount removable drives when hot-plugged/inserted is turned on
3. Settings Manager -> Session and Startup -> Launch GNOME services on startup is turned on (unsure if that's needed)
4. dconf: org/gnome/desktop/media-handling/{automount/automount-open} keys are turned on (unsure if that's needed)

udisks2 version: 2.0.0-1ubuntu1
gvfs-daemons version: 1.14.0-0ubuntu6

(also I tried several USB sticks and different USB2/USB3 ports, all of them are working on windows for example)

Based on some forum posts I tried to reinstall udev/udisks2/gvfs-daemons, but with no luck.
Also I tried to restart udev service, and try to insert USB stick again after that, but it didn't helped.

Then I started to look in depth, what's happening when I am inserting USB stick.
ps aux | grep ud
root 382 0.0 0.0 17232 904 ? S 11:52 0:00 upstart-udev-bridge --daemon
root 389 0.0 0.0 21740 1576 ? Ss 11:52 0:00 /sbin/udevd --daemon
root 740 0.0 0.0 0 0 ? S< 11:52 0:00 [hd-audio0]
root 825 0.0 0.0 0 0 ? S< 11:52 0:00 [hd-audio1]
g 1531 0.0 0.0 507528 6728 ? S<l 11:52 0:00 /usr/bin/pulseaudio --start --log-target=syslog
g 10644 0.0 0.0 216740 5312 ? Sl 12:38 0:00 /usr/lib/gvfs/gvfs-udisks2-volume-monitor
root 12742 0.0 0.0 343772 5148 ? Sl 12:46 0:00 /usr/lib/udisks2/udisksd --no-debug
root 12952 0.0 0.0 21736 1032 ? S 12:46 0:00 /sbin/udevd --daemon
root 12953 0.0 0.0 21736 1056 ? S 12:46 0:00 /sbin/udevd --daemon

I restarted /usr/lib/udisks2/udisksd, but without --no-debug flag to be able to see debug output (I see this output on every insertion of USB stick):
13:24:02.593:[18627]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb4/4-1/4-1:1.0/host16 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:24:03.592:[18627]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb4/4-1/4-1:1.0/host16/target16:0:0 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:24:03.593:[18627]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb4/4-1/4-1:1.0/host16/target16:0:0/16:0:0:0 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:24:03.693:[18627]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb4/4-1/4-1:1.0/host16/target16:0:0/16:0:0:0/block/sdc [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:24:03.729:[18627]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb4/4-1/4-1:1.0/host16/target16:0:0/16:0:0:0/block/sdc/sdc1 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]

My Xubuntu laptop provides similar output in case of unsuccessful mount, but in case of successful mount I have:
13:30:25.352:[3524]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/host18 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:30:26.349:[3524]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/host18/target18:0:0 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:30:26.351:[3524]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/host18/target18:0:0/18:0:0:0 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:30:26.476:[3524]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/host18/target18:0:0/18:0:0:0/block/sdb [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:30:26.532:[3524]:[DEBUG]: uevent add /sys/devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2:1.0/host18/target18:0:0/18:0:0:0/block/sdb/sdb1 [udiskslinuxprovider.c:630, udisks_linux_provider_handle_uevent()]
13:30:26.618:[15556]:[NOTICE]: Mounted /dev/sdb1 at /media/g/GFLASH on behalf of uid 1000 [udiskslinuxfilesystem.c:1474, handle_mount()]

so difference is only this notice of successful mount.
Maybe I am wrong, and problem is in different place (possible in /usr/lib/gvfs/gvfs-udisks2-volume-monitor), but as of now I am unsure where should I look next, thus I am posting bug report here.
That thing is very annoying, to mount USB stick manually every time, I would be more than happy to hear any opinion/workaround for this problem, thank you.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: udisks2 2.0.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
CustomUdevRuleFiles: 80-canon_mfp.rules 01-razer-udev.rules
Date: Sun Dec 16 12:47:18 2012
InstallationDate: Installed on 2012-11-06 (40 days ago)
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-21-generic root=UUID=181e5032-a0fb-4be9-bd1b-c5afda5dfc40 ro quiet splash
SourcePackage: udisks2
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/04/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.name: Z77 Pro4
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd09/04/2012:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnZ77Pro4:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Hennadiy Brych (superg) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in udisks2 (Ubuntu):
status: New → Confirmed
blinkblink (thomasthoma) wrote :

I experience the same problem with Xfce 4.10

in both Xubuntu 12.10 and Xubuntu 12.04 with xfce 4.10 updated from ppa.

Xubuntu 12.04 with xfce 4.8 doesn't have this issue.

I feel that this bug report could shed some light in the situation: https://bugzilla.xfce.org/show_bug.cgi?id=9193

blinkblink (thomasthoma) wrote :

I followed vaxon77's instructions from here: https://bugzilla.xfce.org/show_bug.cgi?id=9193
and seems to work OK now.

so the workaround is this one:

1. create empty file /usr/local/bin/thunar-volman

2. put this inside:

#!/bin/sh
sleep 1
exec /usr/bin/thunar-volman $@ >/tmp/thunar-volman.log 2>&1

3. make the newly created script (/usr/local/bin/thunar-volman) executable

4. reboot or restart xfce

Hennadiy Brych (superg) wrote :

It finally works with this workaround, thank you guys!

Martin Pitt (pitti) on 2012-12-27
affects: udisks2 (Ubuntu) → thunar-volman (Ubuntu)

This is also an issue on 13.04, but the suggested workaround is ineffective there.

vmc (vmclark) wrote :

Maybe related to this one, that has been fixed:
https://bugs.launchpad.net/ubuntu/+source/linux-lts-raring/+bug/1207934

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.